Answered

Sonos Beam Not Recognized by Samsung Tv

  • 6 October 2023
  • 51 replies
  • 6397 views

good morning,

 

Good morning,

 

I have a Samsung neo QLED TV, with a Sonos Beam connected through the E arc port, however frequently when I turn the TV on the TV has reverted to TV speaker and it is not possible to play any sound through the Sonos beam despite going on the device connection which shows the Sonos background.  the only way to reconnect is to completely disconnect everything and reconnect, which is extremely frustrating as the beam is on the wall with all the cables hidden in the wall, which means taking the TV off when it happens. 
 

any ideas? 

icon

Best answer by buzz 6 October 2023, 11:39

View original

51 replies

Userlevel 1
Badge

I am also having these same exact issues with my beam! Every couple of days my beam disconnects and the only way I have found to get it back is to unplug/turn it off and plug it back in. Sonos please get this fixed!!!!!

I had the same issue with my Beam reverting to the TV Speaker after being off for awhile. I have an OLED S95B Samsung TV. The only way it would get back to the Beam was to turn the power off on the Beam, turn it back on again, and the TV would then pick up the Beam when turned on.

I spoke with Sonos Customer Support and had the audio set to PCM. That did the trick. You can get there on my TV by going to Settings > Input Device Manager > Sound > Expert Settings > Digital Output Format and select PCM (from a list that included Auto and Pass-Through).

Not only does this keep the Sonos Beam always connected (via HDMI e-Arc), the sound also connects with my Play 1 satellite speakers and the Mini Sub to which the Beam is linked for my living room Sonos audio setup. The bonus is also that by using the Spotify App on the my Roku controlled screen, my music playlist plays through all my speakers with a screen on the TV that displays the album cover of the song and other information about the artist. Very cool!

And the TV sound is awesome too via the linked Sonos speakers.

Hope that helps!

 

My Beam 2 upgraded to v16 - I’ve had 3 days of no issues of Samsung not detecting the beam.

 

anyone else?

I’ve had the exact same issue. I’ve been dealing with both Sonos and Samsung on this.

long story short - Samsung need to release a software update to sort the problem out. They are aware of the issue, but can’t give any update on when this will be fixed.

Richer Sounds (who sold me both the Beam gen 2 and Samsung TV) have paid for me to have an optical adapter - which I purchased directly from Sonos. This has sorted the problem, at least until the Samsung software updates comes. The only negative is you can’t use the Samsung smart remote, you can only use the standard remote.

You have to program the remote to control the beam - which is easy to do using the Sonos app.

It’s not a Sonos problem - the Beam is fine. It’s a Samsung problem. Samsung are the ones that need to solve the issue, update the code.

It’s annoying that they don’t seem to let you know when or if they will do this.

I’ve had 3 home visits by Samsung and spent hours  with Sonos. I’ve also had Richer sounds look into this independently.

everyone has now said this is a Samsung issue and we’re waiting on Samsung to fix it.

that’s interesting re the remote. I’ll check that out later. Thanks!

Badge

For me this suddenly started after a long time with no issues, none of my devices had a firmware update at that time (can’t say about the Beam as Sonos has auto update.) and I hadn’t updated the TV’s firmware either, it just decided to stop working, the Sonos just wasn’t detected by the TV and the Sonos failed sometimes to turn on the TV by voice control (Sonos own). Sometimes the sound control can turn on the TV without the TV detects the Sonos.

I have updated firmware on the devices that had updates, this hasn’t changed anything.

My solution as a Philips Hue owner was to get a Smart Plug, I plugged the Sonos Beam 2 to it, so now I can restart the Beam without the need to crawl down and find the right cable and disconnect/connect it again. This is far from the optimal solution, but it works for me. I just wish there was the ability to restart the speaker directly in the Sonos app.

Yup, issue still happening here. 

 

SO annoying!! 

I wish someone from Sonos support would review this and other threads regarding this issue and provide an update. Clearly many people are having these issues and certainly none of us like to crawl behind our TVs to disconnect and reconnect our Sonos products!

Like a poster said above, the solution I have found for this is using a smart plug… it’s OK at resetting the beam each time the issue happens. Although, the issue SHOULDN’T be happening at all but hey ho. It’s a bit of a workaround for now if you can do it this way.

Userlevel 3
Badge +2

good morning,

 

Good morning,

 

I have a Samsung neo QLED TV, with a Sonos Beam connected through the E arc port, however frequently when I turn the TV on the TV has reverted to TV speaker and it is not possible to play any sound through the Sonos beam despite going on the device connection which shows the Sonos background.  the only way to reconnect is to completely disconnect everything and reconnect, which is extremely frustrating as the beam is on the wall with all the cables hidden in the wall, which means taking the TV off when it happens. 
 

any ideas? 

welcome to the club which grew day by day.

https://en.community.sonos.com/home-theater-228993/15-8-update-is-a-nightmare-6885678

Userlevel 7
Badge +18

Hi @JobieOneCojone et al

There was a similar issue recently whereby Beams would have no audio when playing TV audio coming from certain Samsung TVs, which has now been resolved. As your TV and Beam seem to be losing the connection between them, however, this seems like a different issue. I recommend you get in touch with our technical support team who have tools at their disposal that will allow them to give you advice specific to your Sonos system and what it reports.

I hope this helps.

Still happening March 2024 with Sonos informing of known issue but only happy to talk as you go through unplugging, resetting process, and when feature returns say monitor an call again when happens but it happens every day for me. I notice if I’m streaming audio, music from a app to then turn TV on it will not recognise this action an no Atmos, PCM or even volume control (Apple TV 4K) as it’s return to TV Speakers 😭 

I researched the Beams HDMI cable an found it might be 1.4 so replaced with 2.1 but issue still occurs 😭

For your region:

https://www.sonos.com/no-no/shop/optical-audio-adapter

Still happening to me and I manually updated Samsung tv software as someone else suggested. 

An update to my last post. Getting my smart plug to turn the Beam off then back on again a couple of minutes later early each morning does seem to have worked for me. 2 weeks without any issue. It’s still a work around but one that for me (fingers crossed) is working. 

My Beam 2 upgraded to v16 - I’ve had 3 days of no issues of Samsung not detecting the beam.

Still working 2 weeks later 

I wish 😂 all my devices are up to  date, what TV model do you have? 

S90C - purchased Dec 23 -  unsure what software version the TV is running, might be related.

This has been ongoing for me since I bought my Beam. I have called countless times, spent countless hours, even had Sonos send me a new Beam.  EXTREMELY FRUSTRATING. SONOS FIX YOUR ISSUES.  This is insane it’s 2024 and we still have to deal with incompetent technicians who can’t fix a problem to connect to a device it was made to connect to SMH

In reviewing the stream above, has anyone found a definitive solution yet, and determined whether it is a Samsung vs Sonos issue? Thanks all!

Anyone still getting this issue? Still happening for me now more frequent than ever. 

Yes - within the last week, with all software updated. Hope it works for you.

Same issue here can we add a reboot option from the app? It’s not easy getting behind the tv to unplug and plug the beam back in.

Userlevel 7
Badge +22

I added a remote power switch, a smart one is also an option. My creaky back loves it.

https://www.amazon.com/gp/product/B07KFMNJLH/ref=ppx_yo_dt_b_search_asin_title?ie=UTF8&psc=1

I have the same Issue, only that since month it never works… I tried several times resetting everything, took of all cables and power, switched it back on etc…  Samsung TV aks for configuration of new device, but setup always fails. On HDMI3 i can see the Beam Screen tough, but i am not able to get it to work.

I already put the Sonos Beam to another Samungs TV in my Apt, and there it immediatetly worked. 

 

So It seems not to be the Beam… but the Samsung TV… only that I dont geht much help from them either… ;-(

Same for me. :(

Badge

I notice the original post 15.8 update is a nightmare | Sonos Community has been closed for comment, not sure by who…….

Is everyone still having this problem?

I certainly am despite various software updates on the Beam, I’ve have had to resort to using Optical which is irritating as you get sound sync issues and lose Atmos and audio formats above Dolby Digital…….

Not seen any information from Sonos acknowledging the issue and support are no help

Reply