Answered

How can I configure LG Magic remote with Sonos playbar. TV Model: 55LM7600

  • 28 December 2014
  • 39 replies
  • 56744 views

Userlevel 2
Tried all options but it doesn't work. Suggestions given on this thread are not applicable as those options don't show up on my TV: http://forums.sonos.com/showthread.php?t=37555.. Very frustrating 😞
icon

Best answer by TBonePickenz 17 June 2016, 22:46

This is for the EF9500 series but is the first thing that comes up on Google. I'm posting here to save others the frustration and tech support calls I suffered.

I finally got it to work using a collection of Internet tips and customer support clues on my EF9500 hooked up to a Sonos playbar/ 5.1 system.

Part 1:
1) click the home button on your magic remote and scroll along the bottom (where Netflix, etc is) until you get to a purple icon "device connector"
2) select soundbar and pick the Phillips brand and select remote type 4
3) Select done

Part 2:
1) Open the Sonos app on your iPad or phone
2) select the gear icon "settings"
3) select the room your system is in
4) select TV setup and control
5) select remote control set up and follow the prompts using your "Phillips" magic remote

You are done!
View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

39 replies

Update: I've been playing around with the settings. The Philips (4 ) setting is the only one I've found that works. My Magic Remote is the older short one.
This is for the EF9500 series but is the first thing that comes up on Google. I'm posting here to save others the frustration and tech support calls I suffered.

I finally got it to work using a collection of Internet tips and customer support clues on my EF9500 hooked up to a Sonos playbar/ 5.1 system.

Part 1:
1) click the home button on your magic remote and scroll along the bottom (where Netflix, etc is) until you get to a purple icon "device connector"
2) select soundbar and pick the Phillips brand and select remote type 4
3) Select done

Part 2:
1) Open the Sonos app on your iPad or phone
2) select the gear icon "settings"
3) select the room your system is in
4) select TV setup and control
5) select remote control set up and follow the prompts using your "Phillips" magic remote

You are done!

Thanks this worked for me. with a couple of small points 1: I don't think it matters which you choose as long as you choose one. 2: after going to the room setup/remote on the App. I had to start over and choose another remote as it was defaulting to my cable remote. It picked up the IR from the Magic remote just fine. that remote has BOTH IR and RF. I guess that's why its called magic.
Userlevel 4
Badge +6
Is there anyway to have 2 remotes controlling volume of playbar
My virgin remote volume controls the playbar
But now got new LG TV and magic remote.
can I also get my LG Magic remote to control volume of Playbar as well.
Tried all options but it doesn't work. Suggestions given on this thread are not applicable as those options don't show up on my TV: http://forums.sonos.com/showthread.php?t=37555.. Very frustrating :(
Hi again, to everyone who didn't have the possibility to choose the manufacturer, here is how I finally managed to enable it on my LG 49UF772V:
Settings -> General -> Location -> Broadcast country. I had no country selected, so I selected Denmark (where I live). I am not sure why, but this somehow changes the TV settings and suddenly I was able to access the "universal control" menu. From there I could set up a sound bar and choose the manufacturer. I followed these instructions https://en.community.sonos.com/setting-up-sonos-228990/playbar-with-lg-magic-remote-37555/index1.html#post234277 and it worked! Vol+ Vol- and mute!
And I would add something for the sound quality: go the settings -> sound and make sure that the selected sound output is "Auto" and not "PCM", if you want the soundbar to receive a Dolby Digital 5.1 input (when the content offers it of course). Mine was set to PCM by default, which means that the only sound i got on the soundbar was stereo, no matter the content.
Thank you so much everyone for helping out on this. Thanks to you and a bit of persistence, I finally managed!
One thing I find strange though: on one side LG customer support claims they don't support SONOS soundbars and there is no solution, and on the other side SONOS claims that the only way to change the volume on an LG TV with magic remote is from the phone app. How come they don't tell us there is a workaround? Is there a catch? :-)


Legend
Thanks alot got my playbar working with my LG OLED55E7N
I wouldn’t think you could get two separate remotes to work, unless one was emulating the other. As far as I know, the Sonos can be set up to accept one version of IR commands, so as long as the remotes are sending that version , you could have infinite remotes.
Userlevel 5
Badge +3
Has anybody had success getting BOTH the LG and AppleTV remote to work? I had the AppleTV remote properly controlling everything, and the LG remote controlling everything except volume. Then followed the above suggestions using Philips and Type 4 settings.

The method does work to a degree. However, the sensitivity/reception on the AppleTV remote controlling the Playbar's volume is much worse. It is as if the LG remote goes into a sleep mode. If I put both remotes down for a bit, then try to use the AppleTV remote for volume, it will not work. I just need to pick up the LG remote...literally, don't even have to use it...and then the AppleTV volume control works again for everything including volume.
For the 2017 B7 LG OLED TV, using Pioneer Type 2 sound bar worked perfectly. Switches the magic remote to use RF for the Sonos sound bar.

Worked perfectly! Thanks for the suggestion.
For the 2017 B7 LG OLED TV, using Pioneer Type 2 sound bar worked perfectly. Switches the magic remote to use RF for the Sonos sound bar.
Just purchased an LG OLED 65B6P and using the Philips + Type 4 remote instructions finally got the volume control working on the LG Magic Remote. So much more convenient being able to use the single remote.

OLED55B6V – SONOS Playbar

I had issue to follow the instructions when configuring the OLED55B6V, but then I discovered that you need to have the SONOS app on your Ipdad active to detect the remote AT THE SAME TIME you are setting it up on your TV

This worked (with my swedish setup TV even though I copied and pasted in english below).

1. Add Philips soundbar and remote #4 in the the device connector screen.
2. The TV will then load the remote settings and show three "virtual remote buttons" on the screen (Power, Volume + and Mute). Don’t close his screen.
3. => OPEN THE SONOS APP (e.g. on your Ipad), at the same time as you have virtual remote buttons screen open on your TV
4. SONOS App: Select settings / room / TV setup & control
5. SONOS App: Select remote control setup / replace current remote
6. You will be asked to click the "Volume +" button on your remote. USING YOUR LG MAGIC REMOTE click the "Volume +" icon on the TV screen (do not click the actual "Volume +" button on the remote). If you're successful, the Sonos app will say that it recognized the remote.

I guess the reason SONOS, LG and the people in the shop is saying that it will not work is that they don’t want to take responsibility to support all related questions to get it working as the procedure is quite difficult.


Thank you!
This helped a lot, and my dad is now finally happy.
I bought an LG OLED65C7P (in US). I followed the instructions here. As others mentioned there was no way to select the soundbar manufacturer. While playing with the remote a message popped up on the TV about updating the TV software. After updating, I was able to select soundbar and Optical out, click Next, select manufacturer (Philips), click Next, select the model (4), click Done. Then went to Sonos controller (I used my PC) to set the remote in Sonos. It is working now.
Badge
Playbase now works on both magic remote on lg and fios remote thanks for the steps
Thanks! Tried all options but it doesn't work. Suggestions given on this thread are not applicable as those options don't show up on my TV: http://forums.sonos.com/showthread.php?t=37555.. Very frustrating :(
Thanks this also worked on my 2016 (LG) 60UF7700, It took a couple of tries not sure what was different but it worked. Now what would be nice is to be able to use more that one remote. But the phone is a good backup.
Badge
worked using Phillips type 4 settings then setting the remote up again in the Sonos app. You must do both in that order
This is for the EF9500 series but is the first thing that comes up on Google. I'm posting here to save others the frustration and tech support calls I suffered.

I finally got it to work using a collection of Internet tips and customer support clues on my EF9500 hooked up to a Sonos playbar/ 5.1 system.

Part 1:
1) click the home button on your magic remote and scroll along the bottom (where Netflix, etc is) until you get to a purple icon "device connector"
2) select soundbar and pick the Phillips brand and select remote type 4
3) Select done

Part 2:
1) Open the Sonos app on your iPad or phone
2) select the gear icon "settings"
3) select the room your system is in
4) select TV setup and control
5) select remote control set up and follow the prompts using your "Phillips" magic remote

You are done!


Thankyou so much! Worked perfectly :D:D:D
I can confirm this is a good setup for an lg oled 65e6p. I used the device connect
- chose optical out
-chose Phillips
- remote 4
- paired magic remote with sonos

My magic remote controls the sound. I also have an Apple TV connected and that remote also worked automatically
thank you worked a treat
I had received a Sonos playbar for Christmas, and then purchased a new LG tv in the sales. Upon setup, I was gutted to not being able to link the two together. A big thank you to everyone's posts on this forum, as using the "Phillips, type 4 remote" has certainly saved my frustration.
Got the volume and mute working but now the magic remote does not control the power on the tv!

I had issue to follow the instructions when configuring the OLED55B6V, but then I discovered that you need to have the SONOS app on your Ipdad active to detect the remote AT THE SAME TIME you are setting it up on your TV


Thank you Joe! I never thought to try this. Wish I could buy you a beer, this was driving me nuts.
This is for the EF9500 series but is the first thing that comes up on Google. I'm posting here to save others the frustration and tech support calls I suffered.

I finally got it to work using a collection of Internet tips and customer support clues on my EF9500 hooked up to a Sonos playbar/ 5.1 system.

Part 1:
1) click the home button on your magic remote and scroll along the bottom (where Netflix, etc is) until you get to a purple icon "device connector"
2) select soundbar and pick the Phillips brand and select remote type 4
3) Select done

Part 2:
1) Open the Sonos app on your iPad or phone
2) select the gear icon "settings"
3) select the room your system is in
4) select TV setup and control
5) select remote control set up and follow the prompts using your "Phillips" magic remote

You are done!


Thank alot mate, this made my day! :D


I LOVE YOU!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! I was this '____' close to sending the whole SONOS system back! You're amazing!
Exact Same as above with oled65B6T and AN-MR700
I installed sonos app worked through to failed volume set-up. Did as above Pioneer type 2. Back to sonos app on phone go to settings/select room / tv setup and control - works perfectly.
Genius so happy
Badge
Thanks, Kevin.

Worked for my Playbar with LG 65UF850T with WebOS 2.0 and AN-MR600 magic remote.

Smart Home button > Device Connector > Sound Bar > Optical > Next > Next > manufacturer = Pioneer > Remote Control Type 2 > Next > Done
Mate you are an absolute legend thank you so much!