Google voice - sorry i can’t find what you asked for.


I have a few recurring issues with google voice and my Sonos ones. Either when I ask to play a radio station the response is OK playing xxx radio station. Sorry I can’t find what you asked for. 
 

Or sometimes when I ask to play artist name I get Sorry I can’t do that here but you can ask me to play it on one of your other devices. 
 

And sometimes this commands work… wondering if Alexa might be more helpful?

 

We use Google WiFi and have a WiFi point in the neighbouring room to one of the Sonos ones and I wondered if this might cause something funky to happen as I don’t think this was a problem until I upgraded the WiFi points and now have one which is voice enabled. Can anyone help? Please!


69 replies

Userlevel 6
Badge +15

Hi @Chris Lin, welcome to the Sonos Community.

Issues like this are generally related to either how the network is setup, or an issue with the settings in the Voice Assistant app. 

Have you tried the troubleshooting steps listed in this thread already? If so, I’d recommend reaching out to our Support Team for some further, live troubleshooting, as they have more tools available to investigate this with you :)

I have the same issue with my Sonos one pair. It alwasy say OK, play … but sorry I can’t find what you asked for although all my Google assistant devices work in my house. 
please help to assist

My diagnostics number: 220599023

Same problem  using google asistent tunein error: I can’t find what you asked for

Diagnostic confirmation: 656720841

Same issue here with Sonos Arc I just got yesterday. Using the S2 app, was able to properly add my Google Assistant and YouTube Music, but when issuing most vocal commands for music, I get the same "ok, playing....... Sorry I can't find what you asked for". For some reason it does seem to work with a specific command like "play NPR on Sonos" issued to another one of my Google speakers, but otherwise it just refuses to play anything from my YouTube library or any of its free music. I already tried to unlink the music service and Google Assistant several times, but no luck. 

I called customer service earlier ([redacted]),and the guy was nice and patient but ultimately referred me to Google for this issue. Looking at this thread this is evidently an issue with Sonos, so any assistance with this would be much appreciated. 

Diagnostic # 685034964

Months later and still no solid solution? My roam will not play anything from YouTube music (radio stations seem to be okay). This is disappointing. Might have to return this speaker for another brand.

Indeed, tech support seems to be completely MIA on this, even though there's clearly an issue related to the YouTube Music product. I have yet to be able to play anything from my own library on my Sonos Arc, or any other music for that matter (aside from a few random radio stations).

Any way to obtain some assistance on this please? 

So just in case this could be useful to anyone, I found a "resolution" that at least worked for me: upgrading to YouTube Music Premium... I was using the free version and my Sonos Arc wouldn't play anything from YouTube Music, whether from my library or from asking for any genre or artist, but after upgrading to the premium version and re-adding my account in the Sonos app (the latter I had tried many times before of course), now my Arc plays whatever I ask for. Not sure if even Premium users still have the same issue anyway, but in my case it finally resolved it, so go figure.

Thanks chinowp. Maybe when I get a free trial I give that a shot. I think that's ridiculous that we have to use the paid version. I think the other obvious work around would be bluetoothing it and selecting YouTube songs from the phone or other device. But that's a pain.

I came looking for a solution to this issue but it looks like a Bermuda Triangle / X-files-y kind of place;

  1. Users submits the problem. Same issue everyone is having.
  1. Support guy chimes in with boilerplate and request for diagnostic. Never any kind of sense that this is a known issue
  1. User submits diagnostic case number….never to be heard from here again…..

    Has anyone actually gotten a fix for this?? Surely somebody must have after all the diagnostic cases submitted!

The only way it would work for me was with YouTube music premium. The regular free YouTube, forget it

Looks like many people have the very same issue. Is Sonos working on a solution or is there a workaround? I’m facing the same problem using Deezer Premium. Thanks in advance! 

So I’m here because I have the same issue. Google assistant will happily play YouTube music on my Sonos, but asking it to play radio fails with this message.

I’ve only just replaced Alexa with Google. Alexa managed fine. 

2 years on and still no resolution?

 

Try to find assistant settings and reconfigure

Userlevel 1
Badge

Any solution to this ridiculous problem?

I used to be able to ask Google to play a particular TuneIn radio station on one of my 12 or so Sonos products, and it worked.

Now, my favorite radio station I get the dreaded “sorry i can’t find what you asked for”.

The stupidity of it is that it works with other TuneIn radio stations, but as of the last week it doesn’t work with the station I spend 90% of my time listening to…..

I’ve disconnected from Google Assistant and reconnected, and it made no difference.

I’ll have to lodge a ticket I suppose…..

Userlevel 1
Badge

Sent diagnostics:  1220920682

Chance of a useful response?   Let’s see if Sonos support can exceed my (pretty modest) expectations….

Sonos support doesn’t monitor these forums, only Sonos Forum moderators. In order to contact the support folks, you need to call Sonos Support directly to discuss it.

Userlevel 1
Badge

OK thanks.  What a pain…..

I tried everything with Google assistant and the Sonos apps, resetting and reinstalling, reauthorizing and relinking, etc. FINALLY was able to fix this by downloading the Google Home app and adding Sonos as a device on there, I guess that was the only way. So for anyone who hasn’t tried through Google Home -- that might be your ticket.

It May 2024 and I also had this issue. What I did to make it work was:

  1. Add remove Google Assistant and Youtube Music, didn’t work.
  2. Add remove the Sonos app, didn’t work.
  3. Reset Sonos Roam multiple times, didn’t work.
  4. Added Sonos manually on Google Home, didn’t work.
  5. Reset Sonos Roam again and added everything back in Sonos app, worked.

I believe you just have to keep on trying until it works.

Reply