Google Assistant Setup issues with Sonos One (Gen2)

  • 23 December 2019
  • 75 replies

Show first post
This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

75 replies

@BerryV Thank you for the follow up information. Your newly supplied diagnostic report shows you have some of your Sonos products on the Apple router and your Arris router wirelessly. You will need to properly configure your network. Who setup your wifi network equipment as in you or an installer? You have two device(s) sending out the network name “Ziggo7678487”.

As a test, please take one of your Play:1’s named Badkamer or Logeerkamer and make one of them the Ethernet wired Sonos product to router you have your device(s) running the Sonos app on wireelssly. Next, power off/on all of your wifi network equipment for 30 seconds with no lights, meaning no battery backup. When they are powering back on then starting with the wired Sonos product power re-boot us off/on for 15 seconds with no lights. While we are powering back on then re-boot the device(s) running the Sonos app. When everything is reconnected then submit us a new diagnostic report number and hold on to it.

When you are back in the app then use these steps to teach Sonos the wireless connection to the router we are wired into with: On iOS or Android: From the Settings tab, tap System > Network > Wireless Setup. Once these steps are then just remove the Ethernet wire from the wired product. Next, test a stream of music grouped to your rooms in the Sonos app to confirm we are playing together. If no issues then attempt to re-add the surrounds to you Playbar.

Please let us know of any issues in the setup steps for the surround along with a new diagnostic report number here.

Lastly, if you are having issues with the surround setup wirelessly then re-wire the Play:1 to the router and power re-boot your surrounds and Playbar off/on for 10 seconds and when reconnected try the surround setup once more with reporting the results here.

the change in the url does work but then google assistant says there is no device found after ‘looking for devices,’ Ive been struggling with this all morning 

If you’re using an iOS device switch your default browser to Chrome. The issue seems to be the link in Safari. Process worked flawlessly in Chrome!

I am having switching from Alexa to Google Assistant as the Sonos Voice assistant.


But I am having trouble getting past the part after Sonos directs me to Google Assistant and it begins to search for the services on the same network. It keeps saying it cannot find any devices on the network. Yet they are all connected. Because I can still control my Sonos devices via the Sonos one app.


Please advise.


Diagnostic report: 1976444212

Userlevel 5
Badge +13

Hi @sonos_buron, welcome to the community, and thanks for sharing this with us. I hope I understand this clearly and yes, one Google account can only be used in one Sonos system or one household. If you have an existing system and already using a voice assistant you just have to link the same Google/Alexa account to the Sonos product and it should work flawlessly. 

We greatly appreciate you being a part of the Sonos family. It is our pleasure. Just let us know if you need anything. We and the community are always here to help.

Just got this speaker and have had no luck getting this to work for the first time setup, latest iOS 13, latest Sonos app and Google Assistant app and it just hangs on a loading screen in the Sonos app no app store redirect no redirect to Google Assistant app nothing then it says it has run into a problem. Any ideas? The URL method cannot be used as I can't even get up to that stage.

Tried all the suggestions above and no luck.   About to return all these speakers.  Sonos is the worst at software.  

Worked like a charm - thank you


I’m facing the same problem as above, and will try to fix it as you are suggesting, but wondering: Where do I find which numbers/letters to use instead of XXXX?

Thanks in advance!

I don’t get this URL work around🤷‍♂️ 

what xxxx letters on my end? And isn’t it All done via app and not via browser.

Same problems for me. I have several Sonos devices but only one Play One with in built mic. Not sure if the mic light is supposed to come on in response to the wake up “Hey Google”. I have reinstalled both Google Home & Google Assistant. Unlinked and linked devices to no avail. I can control the devices through the Google Assistant app on my device but not directly.

i have not tried the URL hack and may give that a go later but am more likely to return the speaker for one without the mic as this is more hassle than it is worth.

i am running on iOS 13.3 and all software versions are latest.

i don’t have Alexa elsewhere so don’t want to go down the road of installing another assistant just for a smart speaker.


Dear John, thanks for your response. Based on your feedback, I have been able to install Google assistant on the Sonos One speakers. However, if I try to connect these speakers back to the Playbar and Sub as surround speakers, Google Assistant disappears from the setup. 

I have sent diagnostic information (confirmation nr 803751036) of my set up without surround sound.

I am using an Arris Connect Box Eurodocsis 3.0 modem with 802.11ac Wave 2 wifi-standaard supplied by my provider. In addition an Apple Time Capsule router/access point  with the same SSID and password as the modem. Finally, a Ziggo Next 4K Ultra HD (UHD) decoder for HD TV including playback and cloud storage. The Sonos Playbar is connected to the decoder as my tv does not have a S/PDIF connector.

The following equipment is connected to the network

Apparaatnaam   IP-adres Snelheid (Mb/s) Verbonden via
AppleTV-404     1000 Ethernet
AppleTV-404     1000 Ethernet
Apple Time Capsule     1000 Ethernet
Apple Time Capsule     1000 Ethernet
Miele-     1000 Ethernet
Miele-     1000 Ethernet
Miele-     1000 Ethernet
Miele-     1000 Ethernet
Fibaro HC 2     1000 Ethernet
Fibaro HC 2     1000 Ethernet
SonosZP     1000 Ethernet
SonosZP     1000 Ethernet
EPSONF24430     1000 Ethernet
SonosZP     1000 Ethernet
SonosZP     1000 Ethernet
SonosZP     1000 Ethernet
SonosZP     1000 Ethernet
SonosZP     1000 Ethernet


The Miele connections are kitchen appliances provided with miele@home functionality. 

Hopefully, you are able to provide a solution where I can use my Sonos One speakers together with the SUB and Playbar for surround sound and still have Google Assistant working on the speakers.

Looking forward to your response.


**Moderator Note: Please censor personal information when posting.**

Userlevel 1

The deleting the Google Assistant app worked for me. whew! I did that after trying again and again with the URL edit process...

I was able to fix the issue on my end thanks to someone’s contribution on another thread.


When you try to add Google Assistant through the Sonos app, does it open the google assistant app or does it redirect you to the App Store instead? 

If it redirects you to the App Store, that’s where the problem is (that was the case for me).

This solved the issue for me :


Copy the URL from safari and edit it somewhere else.

If you have it like this:


Change it to: 



Replace XXXXX with whatever the numbers/letters you have on your end.

Thank  you so much!  Wasted so many hours on this yesterday and today - the above worked perfectly!!!!

@John G . I managed to get everything working following your guodelines. Thanks a lot.

I have attached some snapshots. It says ‘Sonos is linked ‘ and ‘account linked successfully ‘ but in actual Fact my Sonos devices are nowhere to be seen. It feels like it wasn’t unlinked properly and I can’t seem to be able to unlink it now 

I have the exact same issue and have got no workable response or resolution from Google or Sonos. They have been unable to tell me how to force unlink the Sonos credentials stored by google even though it does not appear as a linked service in the Home app. More frustrating is that I’m unable to enter my Sonos details because google simply skips this process. However if I use a different google ID/account it all works fine with the usual steps. Did you figure out or get a fix from Google/Sonos?

@BerryV Great to hear and thank you for the follow up. Let’s hope that these steps may help other Community users as well. Please feel free to us here with future questions or troubleshooting needs.

Userlevel 7
Badge +26

That’s for the details, I’ll pass your message along to the team and let you know if they require some more information. A diagnostic after there’s that problem would probably be really helpful.



I’ve just added a Beam to my setup using iOS 13.6.1 and Sonos App v 12.0.6. Adding Google Assistant as voice service still fails if the Sonos account is already linked to GA. As it will be if you are expanding an existing Sonos system that is already using Google Assistant.  I had to unlink first to solve it. I expect this to be a very common use case, and I am  surprised that the App or the troubleshooting page at doesn’t mention this. The link says ”4. Make sure your Google Assistant account isn’t in use on another Sonos system”

The actual problem seems to be that GA is in use with THE SAME system (= Sonos account).


Hope this post can help someone else seeing the same issue.

I am having the same problem.

Hey everyone, looks like the changing URL has worked for most of you, but there’s a potential fix in place now in the latest version of the Google Assistant app. If you’re still having trouble, you can try to delete the Google Assistant App from your iOS device. Then attempt to add Google Assistant from the Sonos app once more, this time you should be guided to "get" the Google Assistant App, tap get and once downloaded discovery should start. If that doesn’t work, trash both the Google Assistant app and also the Google Home App if installed and try again.

So you want to delete my google apps and lose over 100 smart devices setup inside those apps , plus my routines, rooms etc?

Hi. I can’t seem to unlink my Sonos from google assistant. Whenever I click + to add Sonos it says Sonos is linked but Sonos devices is nowhere to be seen. I don’t have this issue if I use other google emails. I only have this issue with this one particular email address. It’s so sudden used to work before. I checked everything about this email that doesn’t work such as location etc but it’s all looks alright. Anyone else having this issue ?

I am still having issues connecting the Google Assistant. I installed 2 Sonos One speakers and a Playbar as surround system. However, I cannot connect to Google Assistant. Still no fix for this issue?

thanks for advice here. simpler still I found if I copied the safari address that it sends you to from the Sonos app and pasted that into iOS chrome bowser the set up then worked fine.


OMG, this is the best answer out of the lot!!!  I tried the URL manipulation, failed and doesn’t work in GA.  I tried uninstalling GA and GA-Home, that just takes forever and didn’t fix the issue (got some weird Oauth redirect that hangs).  Finally, just copy the URL from Safari that the Sonos app forwards you to during the setup process (the one where it’s supposed to launch GA).  Paste that into another browser such as Chrome, and viola!  Works like a champ!  Now if I only didn’t waste 2 days on this...

@BerryV Thank you for bringing your concerns to us here and welcome to the Sonos Community. Have you spoken to anyone in our Dutch Forum? We can see that you tried to submit us a diagnostic report but it is showing as incomplete. We do not know your network topology but I would advise that you do a full wifi network and Sonos product power re-boot off/on for 30 seconds with no lights. When everything is reconnected confirm that your Sonos Ones are setup in their own room names and not part of a surround setup. If they are then remove then as surrounds and confirm in the rooms tab in the Sonos app that they have their own room names. I would then ask that you re-attempt to send us a diagnostic report number and hold on to it.

Next, confirm your Google Assistant is setup in one or both Sonos One units. You can then voice command tests for the weather or a joke and then try a music service. If there are no issues then set them back up as surrounds in your system. If you have any failures in the setup steps or testing the voice commands then follow up here with what issues are happening and at what point in the setups. We will also want to see a second diagnostic report number in your reply.

Lastly, as part of the follow up information needed if you’re having issues is that we will need your full network topology with the model names and numbers of the products that are wired or wirelessly connected on your network for any modem, router(s), extenders, access points or switches (managed or unmanaged).