Google assistant music play back issues

  • 1 September 2019
  • 67 replies

Userlevel 1
Google assistant works fine on my Sonos system for everything except music playback.

Assistant music playback works fine on all other devices in the house, just not Sonos.

Weather, general web enquiries all work fine, but here’s an example of the music problem:

”hey google, play Mumford and sons”

”Alright, playing Mumford and sons on YouTube music”
”sorry, I don’t know how to help with that”.


”hey google, play bbc radio 4 on tunein radio”

”ok, playing BBC radio 4 on tunein”
”sorry, I don’t know how to help with that yet”.

Already tried:
  • Removing and re-adding assistant
  • Removing and re-adding YouTube music
  • powering off and on Sonos speakers
  • powering off and on house router

Best answer by jack_vancouver 13 September 2019, 20:13

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

67 replies

Userlevel 1

Same here: still unresolved, I’m getting a nice mail every couple of weeks saying “they are on it”. Autotext probably, as nothing is happening.


This sucks so much.



I'm having the same issues and tried a multitude of previously mentioned options, even unlinking, removing and returning to factory settings and starting from scratch.  All settings seem correct and this is my first Sonos which I got for this google integration.  Thinking of returning for a google max.

Same here

Badge +1

I am in the same boat. Google Assistant works flawlessly with my new Sonos Beam with the exception of Google Play Music playback. I have tried what others have suggested, starting again from scratch with an all account removal and unlinking of services but without success.

What a frustration. I am tempted to switch to Amazon Alexa and give it a try but I have been a Google Play Music user since it launched in beta. I am reluctant to make the change.

I don’t get it. How can a bug be tagged to specific google accounts? So now I have to keep creating new google accounts whenever something like that happens again? 

Email just received from Sonos, cancelling my service call tomorrow because they know they can't fix it:

Hi Jack,

I was reviewing your case prior to our call tomorrow and it looks like you are one of a handful of customers suffering from a bug that is affecting specific accounts with Google Voice Assistant and Sonos.

The unfortunate news it that currently the only work around is to use a different gmail account to get Google Voice working on the system but we have opened up the bug with Google and are providing them information around the affected customers as we encounter them. I'm unsure of an ETA of the fix yet, but we will keep on top of this with them to ensure we obtain one because we know that using another Google account is not an ideal solution.

This means that there isn't anything we can really do for this with our call tomorrow, but I've added information from your ticket to our bug report and will keep your ticket in my court as we keep on this issue. Soon as I hear an update from the Google team, and if there is anything they want us to have our users try I'll reach back out to you.

Thank you,
Brandon G
Sonos Escalations Team


Brandon, i think you really need to have a list of people with this problem and see how big of an issue it is. I’m holding off buying more sonos products until this is resolved. 

Userlevel 1
Badge +1

Having the same problem.  Looking fwd to a fix.

Any update on a fix?!

Suddenly started working for me today. Guess they fixed it? Or did I just get lucky?

Suddenly started working for me as well today.

Yep, started working for me as well. Only problem now is both my phone and the Sonos try to respond at the same time, but I’m about to upgrade my phone which I’m hoping will resolve that.

Glad to see forward progress!


I just discovered this is now working for me as well. Very happy...but it would have been nice to have a heads up.

I was also experiencing this same issue and through a lot of trial and error discovered the fix. 

This issue is caused by Google Home assigning your Sonos items to individual rooms within the Home app and as such if any of these items ever get re-added it creates an internal assignment error. In order to correct this problem do the following: 

- Open the Sonos app > go to Settings and select Services > click on Google Assistant > select the Sonos device that isn't working > click on remove the Google Assistant. 

- Download the Google Home app from the app store > follow the instructions to add your Sonos speaker to your home group > once added assign a room name and location > after the Sonos speaker is added close the app. 

- Open the Sonos app again > add Google Assistant under the speaker with the issue and link your Sonos account to Google again. 

This fix worked for me after about two hours of frustration. I hope it helps. 

How did everyone get this to work? Ive tried all the workarounds and got nowhere ?

I’m also experiencing this issue. Can work around it by removing all connections between google home and Sonos, and then re-configuring it. It will then work for about a day, before entering broken state again.


Any permanent solution to this problem?? 

Thanks! 🙌🏽🤔

(SOLVED) Update from my end: After contacting Sonos support they told me that my system had "no access to cloud services”, based on my supplie diagnostics. Unfortunately they couldnt tell me anything else, nor help me troubleshoot further as a reslt of this.

After digging around in my router settings, and contacthing my ISP (recently moved, and got a new fiber agreement), I found that I was not assigned any public IPv4 address. I only had an internnal IPv4 due to address shortage. I made them remedy this, and got one assigned.

After this was fixed, all my issues were fixed. Google assistant now working flawlessly on Sonos One, and all GA can play Spotify / TuneIn on all sonos speakers. '

What I find strange is that the GA service on Sonos One and getting GA to play on sonos worked “sometimes” witouth a public address. If this is indeed a requirement (apparently is, when Google services tries to access my local sonos network from the cloud) I would expect it to NEVER work when no public address is available.. But somehow it worked for a few minutes every time I set it up, and sometimes once or twice the day after.. 


TLDR: Apparently you need a public IPv4 address for GA to communicate with Sonos, even though Sonos itself and GA itself does not require such. 

Userlevel 1
Badge +2

Hi All

I have just reviewed all the comments in this thread and feel partly relieved that I am not the only person who has had this problem.

One of my devices is a Sonos One and I have recently changed the voice assistant from Alexa to Google as I am more brought into the Google ecosystem for a variety of reasons. 

Alexa, I didnt suffer these issues but with the google assistant if I ask hey google, play a BBC station e.g. Radio 5 live I get the same reply as others have seen. However if I ask it to play another station which is not BBC related e.g. talksport it plays. 

I have tried some of the suggestions made but so far not much luck.

Is is worth me logging this with Sonos direct?


Many Thanks