Answered

SiriusXM channels unavailable/greyed out and not available

  • 10 February 2024
  • 22 replies
  • 1691 views

Userlevel 1

Yesterday the Sonos iPhone app prompted me to reauthorize my SiriusXM account. I did and ever since then all of the SiriusXM channels are greyed out and unselectable to play. I tried deleting the service and readding. No luck. I tried the Sonos iPad app and I’m experiencing  the same issue. 
 

If I go into the SiriusXM app and connect to my Sonos via AirPlay, it will work, which is my workaround for the time being, but it’s extra steps and annoying. Is anyone else having this issue?

 

I have the play bar, two sonos ones and the sub. 

Thank you.

icon

Best answer by BlackDot 24 February 2024, 16:10

View original

22 replies

I am having the same issue as of this weekend. A strange workaround is to use the “Search” feature to find the station (for example, search for “wave” to find “1st Wave”) and in that tab, the channel (at least for me) is not greyed out and I was able to get the station to play.  

For what it’s worth, I verified this (same issue, same workaround) on my iPhone, iPad and Mac Studio -- the behavior was consistent across all three devices.

I have opened a ticket with Sonos Support with these details, so hopefully the devs will be able to sort this out relatively quickly.

Good luck!

Userlevel 7
Badge +23

This is a SiriusXM issue, call them. It is they who are tagging the items as unplayable.

Userlevel 1

Thanks, all. I opened a ticket with SiriusXM and their technical team is supposed to call me tomorrow.

I have this issue as well - Did support get back to you with info? 

Userlevel 1

They did not. Guess I’ll try again tomorrow.

Userlevel 1

This is what I was told this morning:

We already filed the request. The Corporate Solutions Team will review the ticket and reach out to the customer within 72hrs.

I’m still having the problem and I assume others are too. If anyone else is up for contacting SiriusXM support, here is the ticket number. Might help if more people express that this is a problem for them.

Ticket#: (021624-16015)

I am having the same issue. Did the channel search which brings up the greyed out channels. I played each one I wanted and then had them available in the “Recently Played” tab in the SiriusXM tab. 

Hi everyone,

I’m having similar issue with my SiriusXM account on Sonos. Here’s what I was experiencing and here’s what I did to resolve it. 

 

TL;DR

Remove your SiriusXM profile (not just re-authorize) from the Sonos app and re-add it. Make sure when re-adding your profile, you select the right SiriusXM Plugin - US for US account or Canada for Canadian accounts.

 

Issue:

Some of the SiriusXM stations are greyed out when trying to select them to play within the Sonos app. For me, this was many of the rock / alt rock stations, and chill stations. All these stations still available in the SiriusXM Mobile app and I can use airplay to sent to my Sonos system even though it’s not convenient. Re-authorizing the account did not resolve the issue. 

 

Solution (for me):

Remove your SiriusXM profile (not just re-authorize) from the Sonos app and re-add it. This solved the problem. Why? Previously there was only one SiriusXM plugin to the Sonos app. Now there is SiriusXM plugin for US based account and a separate one for Canadian accounts. Since I have a Canadian account, I needed to re-add the plugin using the ‘SiriusXM Canada’ option. Doing this immediately solved the issue (which started about two weeks ago). Re-authorizing doesn’t help when you have the wrong plugin installed. This is why you need to fully remove and re-add.

 

Hope that helps!

Userlevel 1

This did not work for me. I’m still having the problem and SiriusXM has never called me back after opening and escalating the ticket.

I removed the profile and readded it. There was not an option for US or Canada for me. I’m from the U.S. There is one SiriusXM option. Once I add it back, it has me authorize. All the channels are still greyed out and unselectable for play. 
I’m about to give up. 

@Drproc79 

If all SiriusXM channels are greyed out on your Sonos app (not just a handful as mine was), then I’m guessing your issue could be related to your SiriusXM account. Since I’m in Canada, our Sirius accounts are provisioned with slightly different tiers than the US. Maybe SiriusXM in the US made a change to the tier you’re on so it only allows streaming through the Sirius app and not through any plugins? 

In the event that there’s some strange credential caching with the Sonos platform and it’s not fully removing your old profile or fully re-authorizing, what if you try changing your SiriusXM streaming login / password and seeing if that change will be enough to set your system right? This would obviously mean that you need to remove / readd the plugin and re-authorize your account again but it could be worth a shot since all these systems are so heavily reliant on the internet.

Another thought (and you’ve probably already tried this), but there’s been the odd time where my Sonos system completely loses its marbles, especially with the Move speakers and once every so often I actually need to power off all my Sonos speakers (8 of them in total), including the boost to let everything reboot. It’s important that all devices are fully powered down at the same time. Leave them all off for a couple of minutes and then start turning them on.

Good luck with your troubleshooting, I hope it works out.

Having the same issue here and seems to affect channels 100-132. I don’t have the subscription that gets Stern, but I should be getting the other channels. It seems to be only the desktop app that is affected. I can use the voice assistant to start channels, and also the iOS app. But with being at my desk for about 10 hours a day, I use the desktop app pretty heavily. 

These were great ideas and tips, but they did not help me either.  I was going to contact SiriusXM to see what they could do but I really wasn’t looking forward to the hassle… So I thought I would keep playing around until something worked…. and I got it working!

I had the same problem where I could authorize and reauthorize my SiriusXM account, but I would still see all the channels greyed out, or get ‘access denied’ messages. I decided to check my SiriusXM account to make sure they allowed streaming, and they do. But then I noticed that each of my SiriusXM users have different usernames than my SiriusXM account; the cars each have their own username and the overall SiriusXM account uses my email.  The email/password method is what I was using to add the account to Sonos, so I decided to try setting up with the one of the car’s username and password combination: it worked! 

TL;DR: Recommend setting up SiriusXM in Sonos using the username/password combo of your car instead of the main account email and password.

Userlevel 1

These were great ideas and tips, but they did not help me either.  I was going to contact SiriusXM to see what they could do but I really wasn’t looking forward to the hassle… So I thought I would keep playing around until something worked…. and I got it working!

I had the same problem where I could authorize and reauthorize my SiriusXM account, but I would still see all the channels greyed out, or get ‘access denied’ messages. I decided to check my SiriusXM account to make sure they allowed streaming, and they do. But then I noticed that each of my SiriusXM users have different usernames than my SiriusXM account; the cars each have their own username and the overall SiriusXM account uses my email.  The email/password method is what I was using to add the account to Sonos, so I decided to try setting up with the one of the car’s username and password combination: it worked! 

TL;DR: Recommend setting up SiriusXM in Sonos using the username/password combo of your car instead of the main account email and password.


Yes! Thank you, Scott! This is what finally fixed the issue for me. I had been signing in with my email when authorizing the account. I switched to signing in with my username instead and all of the channels immediately appeared. How strange. Doesn’t make sense to me, but it’s finally working again.

I have had this trouble for 6-9 months, ever since Sirius updated their app.  I have deleted apps and permissions and still not seeing the channels.  I can ask Alexa to play a specific channel but I cannot see the channel on the Sonos app.  I can’t help but feel this may be a problem Sonos may need to work out with their app and do an update.

Userlevel 7
Badge +23

I have had this trouble for 6-9 months, ever since Sirius updated their app.  I have deleted apps and permissions and still not seeing the channels.  I can ask Alexa to play a specific channel but I cannot see the channel on the Sonos app.  I can’t help but feel this may be a problem Sonos may need to work out with their app and do an update.

No, the app has nothing to do with this, its all on Sirius to fix their account system and SMAPI endpoint.

I am having the same issue as of this weekend. A strange workaround is to use the “Search” feature to find the station (for example, search for “wave” to find “1st Wave”) and in that tab, the channel (at least for me) is not greyed out and I was able to get the station to play.  

For what it’s worth, I verified this (same issue, same workaround) on my iPhone, iPad and Mac Studio -- the behavior was consistent across all three devices.

I have opened a ticket with Sonos Support with these details, so hopefully the devs will be able to sort this out relatively quickly.

Good luck!

Corroborating this issue and that this is a viable workaround.

Thank you NorthlandBob!  Your work around solution helped and worked for me too.  I hope they remedy this problem soon.

I have tried all of the suggested fixes with no solutions. Thank you NorthlandBob for the work around. I also hope they remedy this problem soon.

I’m having the grayed out issue as well.  I have sirius xm (US) and when I add it to sonos and click authorize, it brings me quickly to a page that says canada or US, and even though i press US, it always redirects me to the canada sirius xm  page for adding the sonos.  I can’t seem to find a work around yet.

It will let me log in but a lot of channels are grayed out. 🤷

I’m having the grayed out issue as well.  I have sirius xm (US) and when I add it to sonos and click authorize, it brings me quickly to a page that says canada or US, and even though i press US, it always redirects me to the canada sirius xm  page for adding the sonos.  I can’t seem to find a work around yet.

It will let me log in but a lot of channels are grayed out. 🤷

 

Login and make sure your country information is correct here:

https://login.sonos.com/

 

Also, check to see you are running the proper Sirius app on your device, and log in to that app before attempting to add. 

 

These were great ideas and tips, but they did not help me either.  I was going to contact SiriusXM to see what they could do but I really wasn’t looking forward to the hassle… So I thought I would keep playing around until something worked…. and I got it working!

I had the same problem where I could authorize and reauthorize my SiriusXM account, but I would still see all the channels greyed out, or get ‘access denied’ messages. I decided to check my SiriusXM account to make sure they allowed streaming, and they do. But then I noticed that each of my SiriusXM users have different usernames than my SiriusXM account; the cars each have their own username and the overall SiriusXM account uses my email.  The email/password method is what I was using to add the account to Sonos, so I decided to try setting up with the one of the car’s username and password combination: it worked! 

TL;DR: Recommend setting up SiriusXM in Sonos using the username/password combo of your car instead of the main account email and password.


Yes! Thank you, Scott! This is what finally fixed the issue for me. I had been signing in with my email when authorizing the account. I switched to signing in with my username instead and all of the channels immediately appeared. How strange. Doesn’t make sense to me, but it’s finally working again.

This also worked for me!  Thx for the info. I had been messing with this for almost 2 hrs after switching to my mesh network and couldn’t figure it out until I read this from you guys. 

Same greyed out issue.. I have a few questions..

As far as my online Sirius goes I only have an email user name. How did you guys find your vehicles username and password?

 

#2 How do I remove the Sonos profile? I just checked and I am correctly in the right country. 

 

 

TL;DR

Remove your SiriusXM profile (not just re-authorize) from the Sonos app and re-add it. Make sure when re-adding your profile, you select the right SiriusXM Plugin - US for US account or Canada for Canadian accounts.

 

Issue:

Some of the SiriusXM stations are greyed out when trying to select them to play within the Sonos app. For me, this was many of the rock / alt rock stations, and chill stations. All these stations still available in the SiriusXM Mobile app and I can use airplay to sent to my Sonos system even though it’s not convenient. Re-authorizing the account did not resolve the issue. 

 

Solution (for me):

Remove your SiriusXM profile (not just re-authorize) from the Sonos app and re-add it. This solved the problem. Why? Previously there was only one SiriusXM plugin to the Sonos app. Now there is SiriusXM plugin for US based account and a separate one for Canadian accounts. Since I have a Canadian account, I needed to re-add the plugin using the ‘SiriusXM Canada’ option. Doing this immediately solved the issue (which started about two weeks ago). Re-authorizing doesn’t help when you have the wrong plugin installed. This is why you need to fully remove and re-add.

 

Hope that helps!

 

Reply