Question

SiriusXM channels unavailable/greyed out and not available

  • 10 February 2024
  • 8 replies
  • 234 views

Yesterday the Sonos iPhone app prompted me to reauthorize my SiriusXM account. I did and ever since then all of the SiriusXM channels are greyed out and unselectable to play. I tried deleting the service and readding. No luck. I tried the Sonos iPad app and I’m experiencing  the same issue. 
 

If I go into the SiriusXM app and connect to my Sonos via AirPlay, it will work, which is my workaround for the time being, but it’s extra steps and annoying. Is anyone else having this issue?

 

I have the play bar, two sonos ones and the sub. 

Thank you.


8 replies

I am having the same issue as of this weekend. A strange workaround is to use the “Search” feature to find the station (for example, search for “wave” to find “1st Wave”) and in that tab, the channel (at least for me) is not greyed out and I was able to get the station to play.  

For what it’s worth, I verified this (same issue, same workaround) on my iPhone, iPad and Mac Studio -- the behavior was consistent across all three devices.

I have opened a ticket with Sonos Support with these details, so hopefully the devs will be able to sort this out relatively quickly.

Good luck!

Userlevel 7
Badge +23

This is a SiriusXM issue, call them. It is they who are tagging the items as unplayable.

Thanks, all. I opened a ticket with SiriusXM and their technical team is supposed to call me tomorrow.

I have this issue as well - Did support get back to you with info? 

They did not. Guess I’ll try again tomorrow.

This is what I was told this morning:

We already filed the request. The Corporate Solutions Team will review the ticket and reach out to the customer within 72hrs.

I’m still having the problem and I assume others are too. If anyone else is up for contacting SiriusXM support, here is the ticket number. Might help if more people express that this is a problem for them.

Ticket#: (021624-16015)

I am having the same issue. Did the channel search which brings up the greyed out channels. I played each one I wanted and then had them available in the “Recently Played” tab in the SiriusXM tab. 

Hi everyone,

I’m having similar issue with my SiriusXM account on Sonos. Here’s what I was experiencing and here’s what I did to resolve it. 

 

TL;DR

Remove your SiriusXM profile (not just re-authorize) from the Sonos app and re-add it. Make sure when re-adding your profile, you select the right SiriusXM Plugin - US for US account or Canada for Canadian accounts.

 

Issue:

Some of the SiriusXM stations are greyed out when trying to select them to play within the Sonos app. For me, this was many of the rock / alt rock stations, and chill stations. All these stations still available in the SiriusXM Mobile app and I can use airplay to sent to my Sonos system even though it’s not convenient. Re-authorizing the account did not resolve the issue. 

 

Solution (for me):

Remove your SiriusXM profile (not just re-authorize) from the Sonos app and re-add it. This solved the problem. Why? Previously there was only one SiriusXM plugin to the Sonos app. Now there is SiriusXM plugin for US based account and a separate one for Canadian accounts. Since I have a Canadian account, I needed to re-add the plugin using the ‘SiriusXM Canada’ option. Doing this immediately solved the issue (which started about two weeks ago). Re-authorizing doesn’t help when you have the wrong plugin installed. This is why you need to fully remove and re-add.

 

Hope that helps!

Reply