S1 Android App crashes every time I search in "stations"

  • 28 September 2020
  • 58 replies

Userlevel 2

Hi - recently I’ve had this issue - every time I search for a radio station and click on “stations” to refine the search, the app crashes.  I’ve cleared the cache, I’ve re-installed the app and it hasn’t resolved it.

I’m using the S1 app, a Samsung S20, and have the following services installed:

Sonos Radio

Amazon Music

Radio Paradise extension

TuneIn Radio




Best answer by Echas1000 23 October 2020, 20:12

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

58 replies

Userlevel 3
Badge +1

It’s almost like the corporate strategy is to make legacy owners get fed up with their perfectly working home set-up and buy wholly un-necessary expensive upgrades that offer nothing new in functionality in any way whatsoever except allowing Dolby Atmos on the Arc sound bar.

Well that just isn’t happening and it is an obvious nonsense that a system with a technical bolt-on just isn’t possible within a networked infrastructure; that is quite clearly aggressively obtuse software design to force obsolescence.

The fact that even the older kit can handle FLAC means that it’s not a bandwidth issue.  I have yet to see *any* explanation that can account for the in-abilty for existing Sonos satellite speakers to not receive the decoded Dolby Atmos surround audio as they currently do with Dolby DTS.  DTS even has a higher potential bit rate than Atmos so it’s certainly not a processing restriction.  The Sonos soundbars decode the codec at source and then send what is left onwards to surrounds in a current Sonos 5.1 set-up, the satellite speakers just receive what they need.  I can currently stream to 8 simultaneous devices around my home without a problem and yet a Dolby Atmos 7.1 can’t be done on the existing system without junking half of it?  Give me a break.

None of the dual app smokescreen that is being pointlessly foist upon us is of any use to customer satisfaction or can possibly serve to keep previously happy investors in home systems investing any further in a willingly future-disproved system.

Please, please explain it to us.  Be as technical as you can or need to be.  Persuade me and I’ll be gladly evangelical as to the new way; I shall shout it with great gladness from every peak and rooftop.  Until then, you just are not going to get any more money out of us.

Userlevel 7
Badge +16

I'm on S1 using a Galaxy S20 and "Podcast and Shows" search instantly crashes the app..

Userlevel 3

Just wanted to add that I’ve had the same problem as Big Aura for a few weeks… coincidently about the same time as the most recent S1 update (11.2.4) on 9/23. 


My search works for Artists, Songs, and Albums (only returning hits from MP3s on my local network shared folders).  However, when I click to search Stations (or Genres, Podcasts & Shows, etc.), the app stays up… but as I start typing in the search box (when it would typically start filtering results back), the app immediately crashes.  Even if I just try to click on a previous station I’ve searched for and selected - the app crashes as well. 

I think there’s something wrong with the search function when it’s trying to get results from outside your local network (i.e. when it has to search the interwebs, specifically for such things as Stations, Podcasts, etc.). Hopefully this information will help your developers narrow down the cause (I'm a software developer myself).  Thanks. 


My specs: 

Sonos S1 app - 11.2.3 (no option to update to 11.2.4); build 57381090. 

Andoid version 11

Google Pixel 3

6 Sonos speakers, 1 connect:amp (powering 6 speakers), 1 connect (connecting 10 speakers). 


Userlevel 2

Hi Rowena


thanks for your response.  I’ve since found another thread that didn’t come up when I searched previously.  I don’t think it’s a great fix to suggest using IoS (I don’t have any apple devices).  The other suggestion is to search and not add the “stations” filter.  I’ve done this, and it doesn’t work - if I search for “BBC Radio 4” I have to have a filter applied (it defaults to “Artists”), and on the Artists filter, no results come up, so I am then forced to use the “stations” filter, and it crashes.


I see that earlier versions of the Android App don’t have this issue, so surely the answer is to roll back the most recent update, and re-issue it once Sonos have figured out what the problem is.  I used to be a beta tester for the Sonos app and recall multiple changes (almost daily) all made in advance of the launch of Apple Music - this seems like Android are being told “we’ll get to it” but with no time frame! Thanks.

Userlevel 1
Badge +2


Note to group: 

Older versions of the S1 Controller can be found here:

I installed a version from August and search works … 

How much longer am I expected to wait for an update to solve this problem? Most of us have spend hundreds or even thousands of dollars for your equipment. This problem has been ongoing for over 6 weeks. The solution of upgrading to S2 compatible equipment is unacceptable. Please advise.

Hi folks. Thanks for reaching out here in the community. I understand where you all coming from and this is being worked on by our engineers. We apologize for the inconvenience and we greatly appreciate your patience. We'll keep you posted here once an update is available for the fix using S1 app controllers.

Why it take so long, to fix a so evident bug ? 2 months. By experience, a so evident bug is usually fix in a couple of hours.  


We speak about 2 months for fix and publish a fix. 

We doesn’t want any new feature, just search a radio station like we do during the past years.

Same problem. I thinks sincerely to change to bose if Sonos don't patch s1 app.

Userlevel 2

@Rowena B.

Hi - it’s been more than a month since I originally posted this, and I see there’s been zero progress, which is very disappointing.  It’s Christmas season.  Every year I get 2-3 friends who call or text with “you’ve got a sonos speaker - are they any good”.  And I always explain the system and give it a thumbs up - it’s very solid if not highend, but it’s so user friendly, that makes up for it.

Now, after seeing the words:

In this specific scenario, we are still awaiting an update from our engineers for the development but as of this writing, we haven't received any.

for the umpteenth time, I am just entirely frustrated - I’ve already told someone to buy a Naim Muso.  This seems to be the most simple fix on earth - someone updated an app and it glitched.  Roll back the update, and solve it in the lab before rolling out the newer app version again.  Rather than just doing whatever it is they are doing.  Is this even a priority?  Are there people actually working exclusively on this problem, or is it on the “gosh maybe look at this later” list?

Can you please provide an update which has details as to when this will be resolved?  Many thanks.

Userlevel 2

Hi @Rowena B.  - I’ve just a diagnostic from my wife’s phone (immediately after trying, and succeeding, to seach for a radio station on the old app version) - it’s 801668321.

I’ve then searched on my (current version app) and it crashed.  I did a diagnostic on it too - 1620368692



Userlevel 3
Badge +1

Searches crash on all searches on Android S1 on the Samsung S9+

Many formerly working stations from many different countries will not play.

Some no longer exist and can’t be found on the searches that do actually work on the IOS and Windows.

IOS S1 app will not play the stations either so it is not a work around on iPhone 7

Windows app also does not play the same previously working stations.

It’s a frustrating mess.  The simplest of functions don’t work.  An expensive system should be glitch free or at least take iron them out much quicker.  I’ve ignored it for a while but I’m losing my will.  Why would I upgrade half of my already expensive system if it’s not going to work anyway?

Userlevel 1

Note to group: 

Older versions of the S1 Controller can be found here:

I installed a version from August and search works … 



Thanks Echas1000 for the link

It s fixed for me with an older Version of S1. 

Userlevel 3
Badge +1

Thank you for engaging Rowena.  I appreciate that your hands are tied and that you certainly wouldn’t be allowed to venture an opinion on what I posited above as to currently nefarious corporate designs.

Whilst you have helpfully laid out what the Arc soundbar is technically capable of, it doesn’t negate my assertions that even Sonos legacy products, long capable of processing larger FLAC lossless sized audio, *could* work with it.  I would delight in a chin wag with a Sonos engineer who might give an exacting answer, and I’m sure many others might find it absorbing.   If this question could be tackled it would be an enlightening start:

The Arc does the heavy lifting regarding the processing and decoding of the HDMI sent Dolby encoded audio packet, the satellite Sonos devices don’t need to process 32 channels of anything, they just receive the one discreet channel they need to play out in their assigned position.  Why does that suddenly cause an unmanageable bandwidth of data in the satellite positions?  I just can’t see it.  It is also not what Atmos is about.

In the same way that THX was only ever really an accreditation of recessed into a wall speaker design and base level of quality, Dolby Atmos is only really down to creating height visualisation.  This is achieved in cinemas with ceiling mounted speakers and mimicked in home set-ups with upwards firing tweeters.  It’s not about bandwith, or processing power, it is about intended effect and seeing as for over three years now since update 7.2 all Sonos has been able to play 24bit/48k FLAC and downsample on the fly, and domestic Atmos 24b/48k signals (which most are) just aren’t going to crack that, I still can’t grasp why it’s being proposed that swathes of the system need to be replaced.

Sorry for waffling on.  I really am interested.

Same issue. I have mixcloud and there is no way to search without the app search which keeps crashing. Forcing early supporters of Sonos to upgrade and change is a slap in the face for those of us that have spent thousands of dollars in my case 10 years ago and counting. Please sort this out. 

Is someone from Sonos gonna reply to this? Can I get a response please?

Userlevel 5
Badge +16

Hi @Earquake, thank you for reaching back to the Sonos Community. I appreciate you for letting us know about your concern and providing the details on your post. Your frustration is completely understandable. Let me help you with this.

We have identified that the Sonos app crashes on Android devices only. I'm sorry to hear that some stations are missing in the Sonos app.

I have a few questions and will give some suggestions on what you can follow.

1. When you tried to search for the station missing in the Sonos app, did the app crashed or hanged on your iPhone/Windows PC?
2. Do you experience this issue on a particular music service or on your music services?
3. Have you tried searching the stations on Tune-in or Sonos Radio?
4. Have you tried uninstalling and re-installing the Sonos app on your iPhone and Windows PC?

If after checking the inquiries above and you're still having the same problem with your iPhone and Windows PC, please submit a diagnostic report from these 2 devices for us to check and post the confirmation number when you reach back to us.

We'll wait for your reply.

You’ve posted in a thread about the Android controller app crashing when you use the ‘search’ function. May I suggest you open your own thread with your issue?


Userlevel 2

Hi @Big Aura, thank you for your response. I really appreciate the time and effort you've spent doing all the troubleshooting steps.

Let me suggest some steps to see if this would work for you. How about upgrading your system from S1 to S2? The known issue is happening on the S1 app only. I can check your system by submitting a diagnostic report to provide you what’s recommended.

If you wish to continue working with us over the phone to expedite the process,  you may reach our Sonos Customer Care support by remotely connecting to your device to check what's going on and to provide the best option for you.

We're here to answer any further questions you have.


Thanks Rowena - I’ve done a diagnostic (482864225), but given the issue is with the most recent update to the S1 app (and common to anyone with android), surely the solution is to roll that update back rather than looking at individual user diagnostics? 

My wife, I’ve discovered, didn’t update so she can search for stations in the normal way.  So if I want to listen to the radio, I have to wait until she’s home!  Not a good solution. 

Re “upgrading to S2”, I have 4 sonos devices, 3 of which are on the S1 path only.  I have previously had unexplained issues with unstable bandwidth (when there’s perfect 35+mbps broadband throughout the house, my device can only manange 1mbps).  It’s currently stable now, but after 4 months of intermittent service, I don’t want to do anyting to destabilise it.

Also, there appears to be no way to roll back the S2 if I dislike it or if it causes my low bandwidth to return, I cannot really take that chance.


What is the timeline to reverse/re-do the latest app change?  thanks

Reports are that it was fixed in last week’s software update. If you’re still having that issue after updating your system, I would recommend that you submit a system diagnostic within 10 minutes of experiencing a crash, and call Sonos Support to discuss it, or post the diagnostic number here for a Community Moderator to pick up.

There may be information included in the diagnostic that will help Sonos pinpoint the issue and help you find a solution.

When you speak directly to the phone folks, there are more options available beyond just the diagnostic analysis. 

Userlevel 3
Badge +1

Depending where you are you may get different results.  If you’re in the UK then the TuneIn service went as good as useless except for BBC channels after a copyright law suit was thrown on them last year so much of their content has gone.  Switch your searches to be via “myTuner Radio” instead and that will open up the list again.

If you can do it via the PC app you may find it the easiest way to do it.

I hope that solves at least part of the problem.

Hi Rowena,

I have Spotify, Mix Cloud, Tunein - Any search in “Station”, “Genres”, “Podcast & Shows”, and “Shows” results in the app crashing. Interestingly, I can search “users” without the app crashing.

Userlevel 3

Thanks Airgetlam.  I think we've all spelled out specific steps to easily replicate this issue for them, but I can do that.

I tried various search methods, and crashed the app multiple ways, then ran System Diagnostic upon restart of the app.  Here's my # 790931234. Hope it helps.

Will Sonos ever proritize this poorly functioning software?? It has been an issue for more than a month now. 


I have the same issue on 2 devices, both Android but different OS versions and different makers. One new and one old. 

I will not downgrade Sonos app as it will most likely expose security risk to my network. 

Switching to S2 will require my to spend a lot of money on hardware upgrades. If I take that step I will certainly swith to Bowers&Wilkins and avoid the Sonos support dead ends. 

Userlevel 1

I posted earlier about this being broken and am happy to report and confirm it is now fixed for me in a recent update a bit over 1 month ago, as @Airgetlam says. Thank you Sonos!


FYI: I have Sonos S1 on Android 10 (11.2.4) and my last update was 2nd December.