Not being able to send music through Music app in iOS anymore

  • 1 November 2023
  • 6 replies

As if the loud pop wasn’t enough, since I added more speakers to my Sonos system (I’d say that it was after adding the Sub Mini) I’m unable to send music directly via the Music app on iOS.
My Sonos equipment is a combination of Arc + 2 Era 300’s + Sub Mini.
The system does appear listed below, as you can see (it’s the one called “Comedor”):

But I select it, even though it looks as if it was sending sound, nothing would play and after a few minutes the streaming to that speaker set would be cancelled and the sound will start playing on the iPhone instead.

Surprisingly enough, if I add another speaker to the selection (even if it’s a Homepod), the sound will be send to the Sonos system. However, if the song is in Dolby Atmos, it will be sent in Stereo format instead (so it basically ignores the Dolby Atmos format. This does only seem to be happening when I only select the Sonos speaker system.

I’m not sure if this is due to changes in iOS 17 or to the fact that I added the Sub Mini to my setup, because I tried resetting everything and adding the speakers again one by one and I noticed that if the Era 300s are set up as stereo speakers (without the Arc) it does allow you to send audio directly via the Music app, even if it is Dolby Atmos content. But the moment you add the Arc and the Sub Mini it’s when it starts preventing you to send music directly via the Music app.

Of course, it does work if I send music through the Sonos app, and in fact that’s the only way I found to send Dolby Atmos music to the system (another option would be to use the integrated Music app in the Apple TV, but that does trigger the loud pop on the Arc just after a few minutes of playing music, so it’s definitely not at option), but considering that I’m getting that “'Unable to play - the song is not encoded correctly'” error for 50% of the songs, it’s not a solution.

I can’t believe that it’s all problems with Sonos. After investing 3000€ on the system (which is a lot of money for me as most salaries in Spain are not on the same range as in the US) I’m extremely disappointed with the brand and the lack of solutions from their side.


Best answer by jgatie 1 November 2023, 17:57

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

6 replies

Airplay is stereo only for non-Apple speakers, so even if you play an Atmos track, you are only getting stereo.  That’s an Apple limitation, not a Sonos one.  So your wrath is aimed at the wrong company.

@jgatie That’s only one of the issues that I’m having. It’s not only that I can’t play Atmos content via Airplay, the issue is that I cannot send audio at all using the Music app, even if it it’s on stereo.

My wrath is rightfully aimed as Sonos because I’m face with a combination of multiple issues which are caused directly by their hardware:
→ Loud pop on Arc
→ Not being able to send audio directly via the integrated music application on iOS
→ “Unable to play - the song is not encoded correctly” when using their official app to play Atmos content, which is the main selling point of their devices 

There is no real world reason why you cannot send audio through Airplay.  It’s not Sonos, it is your setup.  I suggest you contact them.

Badge +1

OP have you perhaps changed the name of Comedor lately? Be sure the room name matches the setup in HomeKit. I’ve seen something somewhere that if you change a room name, this very issue with Music can happen. 

Can you select the individual speakers in music and play to them? In other words, instead of trying to play to a room, play to a single speaker in that room. That could point the finger at your HomeKit setup. If so, consider deleting that room from HomeKit and then re-adding it again. Reboot your Apple device and then try selecting that room again.

And one more tip: I “think” I have noticed that HomeKit can have a “memory” even if you delete a room. So tweak the name for a test. If the test works as you want, rename it Comedor again and try again. If that works, problem solved. If that doesn't work, it may be this “memory” thing… so change the name to something you haven’t used before: Comedor2? Or something else.

Thank you for your suggestions, @HobeSoundDarryl! Unfortunately that’s not the case :/ When I created my system it was called “Salón” and it stopped working while it had that name. Then, I tried to change it to Comedor (even when I removed the system and I added all the speakers to my system again one by one), but that doesn’t seem to work. What makes this especially strange is that it does send sound to the system if I select an additional speaker that’s not on the system (a speaker from a different room), but the moment I deselect that speaker and leave only “Comedor”, it stops playing any sound :/ I tried changing the name again but it didn’t seem to work.

Refloating this in case anyone is having the same issue. I’m surprised that I’m the only one with this problem. Today I was in contact with Sonos Support and we weren’t able to fix the issue. The issue I’m having is that playing any kind of content using my iPhone via AirPlay won’t work (won’t send any audio) if only the Sonos system is selected. However, if I select any other device (for example, my Sonos system + a Homepod), the audio will play correctly.


Moderator Note: Removed case number. Modified in accordance with the Community Code of Conduct.