Audio actions in routines are currently not supported on this device.

  • 5 December 2018
  • 78 replies
  • 30375 views


Show first post
This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

78 replies

Userlevel 1

I appreciate the feedback. How do you like the Bose system?

Userlevel 7
Badge +20
I don't have any duplicate devices. It's a real pity since we wanted to use Sonos throughout our home instread of Alexa speakers/dots due to the sound quality. We had bought a Play One to trial this and it clearly does not work and I'm not putting up with that irritating message for each routine (even though the routine works 100% fine bar this quirk). Regardless of whether or not it is an Amazon or Sonos issue, Sonos should really try to address this in the interests of their customers. Now I need to find alternatives speakers for my home, the Sonos were so close to being perfect. Frustrating!

Hi

If the only devices in the Routine are smart switches then this isn't working as my system - I get no message for my Routines. Can you try Disabling the Sonos Skill and then Re-Enabling in the Alexa App and then ask Alexa to Discover Devices.
Userlevel 3
Done that. Still does not work.
Userlevel 7
Badge +20
Luckily I only bought one! Hopefully some manufacturer can get this right at some point, although I can see the day when Amazon release a high end audio device for £200/$200 and sweeps the market away. yes..Sonos need to up their game I agree. Before I bought my Sonos Ones I rang them to verify that the early shortcomings had been sorted out. I was told that they can do everything that an Echo can do. Obviously, the lady I spoke to was not up-to-speed. Disappointed to say the least. This will be the last ourchase from Sonos which is sad because they always delivered in the past and I was there from the outset. Sadly they are being left behind.

Whilst I agree that the gaps Voice Control has in functionality between native Echo devices and Alexa Enabled devices is frustrating, your comment 'Sadly they are being left behind.' is way off the mark. The multi room audio quality is by far the best I've experienced for the price and when Google Assistant is supported and the Sonos devices become Ai agnostic they will be well ahead of the field.
Userlevel 3
Badge
So I get this issue too when running a routine to turn off/on my lightwaverf lights. Randomly if I'm downstairs my sonos one stereo pair do not return the audio error. My stereo one pair upstairs do return the error. In both cases the lights do turn on/off. I don't care who's fault it is someone really needs to fix it.
Hi
I have already tried that but did not cure the problem.
Userlevel 7
Badge +20
Hi
I have already tried that but did not cure the problem.


What is your routine attempting to do? Sonos doesn't support its devices being included in Routines currently, but you can trigger a routine on a Sonos One to output Audio on to an Echo device.
turning off lights, turn off AVR, turn off DVR and turn off TV all worked fine last month with no audio message
Userlevel 7
Badge +20
turning off lights, turn off AVR, turn off DVR and turn off TV all worked fine last month with no audio message

I believe there may be a bug with the Beam that has recently caused this, do you have one? (My Sonos One is working fine with Routines - not much help to you sorry) If a Sonos One is the Alexa device, where are you located?
I agree that the Alexa integration needs to be much better, I’m very disappointed with that experience. I’d also love to be able to use it to group rooms to play music too but it doesn’t look like any progress is being made with that either.

I suggest you read this link:

https://en.community.sonos.com/announcements-228985/sonos-now-playing-with-alexa-groups-6817588
What I find peculiar is that despite saying it's "not supported on this device", it still works: https://twitter.com/customeroutrage/status/1083697659456770048
I believe I have figured out the problem. My Alexa-enabled Ecobee4 does the same thing. If you have a routine called “goodnight” which turns off all your lights, a true Amazon Alexa device will turn off all your lights AND say “goodnight, sleep tight” (or something similar). Our Sonos (or Ecobee4) are merely “Alexa-enabled” and aren’t full features Alexa devices. And they hit a brick wall with attempted conversation. If you create an identicle routine, with a nonsense name (“Waffle House”), your routine will be completed without a failed attempt to respond to you / the error message. Let me know if you think I’m right. But after a bit of research, it’s what I think I’ve figured out.

I just tried your exact example - changing my “turn off lamps” routine to “Waffle House”. The lamps turned off, but still the same phrase stating she didn’t support what she’d just done.
I just tried your exact example - changing my “turn off lamps” routine to “Waffle House”. The lamps turned off, but still the same phrase stating she didn’t support what she’d just done.Yes, I’m seeing the same on my Sonos devices too, the simple answer would perhaps be for Amazon to remove this response.
I'm with the others above that think this is a new problem. I've had a Sonos One in my system for about 7 months using quite a few routines and I don't think I've heard this till I added a new one today - which brought me to this thread.

The routines all apear to work... even any configured dialogue where Alexa responds but this new incorrect error message gets added in.

Per this chap having the same issue with his EchoBee: https://youtu.be/p4U7X3zq0bA the behavior seems inconsistent and some routines work without adding the message. It is as if Amazon have configured some whitelist of expressions/grammar intending to capture things that don't work (I have a strange feeling that some things used to fail silently). Unfortunately it would seem they forgot to handle the case of free form routine triggers. Given the same happens on other Alexa-enabled products that does suggest Amazon are the source of the problem. You'd think Sonos would be following up with them however as it is Sonos that lose out here.

I wish I had never bought the Sonos One. Dot + a Play works much better, especially with the Group "default speaker" thing.
“I wish I had never bought the Sonos One. Dot + a Play works much better, especially with the Group "default speaker" thing.”

This I think sums up the experience of many users lured into this by the unclear marketing (to not say deceiving). What indeed is the point of the Sonos One when the best solution was clearly Sonos Play + Dot?

As a person new to both Alexa and Sonos, I don’t get it.
This is an Alexa problem for some class of devices (undetermined). This isn't limited to Sonos, Eco Bee has the same issue reported as does the Alexa app on the iPhone. Try using the Alexa app to run the routine with your voice. Then run the same routine on the Alexa app using the play button next to the routine. Only voice activation gets the annoying message.
Badge +1
I think this issue might've been resolved as of tonight. We have a "good night" voice routine that we use from the Beam in our bedroom. Wed got used to sarcastically chanting "Audio routines are not supported..." and then suddenly tonight, the routine just ran without a fuss.

I suppose so Jammalam, very discouraging.

Badge
I think this issue might've been resolved as of tonight. We have a "good night" voice routine that we use from the Beam in our bedroom. Wed got used to sarcastically chanting "Audio routines are not supported..." and then suddenly tonight, the routine just ran without a fuss.
Could you please add an audio action to your routine and see if the error message comes back again or not? It seems that the error message happens only if you add an audio action to your routine.
Userlevel 3
Badge +1
I wish I had never bought the Sonos One. Dot + a Play works much better, especially with the Group "default speaker" thing.

Just FYI, Alexa-enabled speakers can now be assigned as the "preferred speaker" in a room, and also, more recently, the Alexa app was updated to allow these devices to be assigned to a specific room and therefore make Alexa room-aware. So, for example, I can say to the Sonos Beam in my living room, "Alexa, turn on the lights," and Alexa knows to only turn on the lights in my living room. Likewise I can say to the Sonos One in my bedroom, "Alexa, turn off the lights" and Alexa knows to only turn off the lights in the bedroom. This functionality was previously only available to actual Echo products, but was added to Alexa-enabled speakers... eventually. Yes, these devices are still missing some functionality when compared to actual Echo products (like drop-in and messaging) but I just wanted to chime in that there has been SOME progress on this front, and I'm happy to see it.
Hi. (Apologies if this has been mentioned or noticed or discussed already.) I noticed something odd while looking at Alexa Routines involving Audio Actions.

Currently I have a Beam connected to two ones for home theatre, (I also have several Philips Hue bulbs)

Prior to having the Hue bulbs I could say “Alexa, GoodNight” to which she would reply using a random phrase. Exploring the Alexa iOS app I found the Routines page.

There I noticed, listed under ‘Featured’ was the default preprogrammed Goodnight Routine... WHEN: Alexa, Goodnight,
ALEXA: Say A Random Phrase From Good Night FROM: The Device You Speak To.


Everything was fine and worked.
UNTIL, I got the Hue bulbs and connected everything up.

I thought I’d be clever and edit the original default preprogrammed Goodnight routine from the featured routines page. So all I did was in the action All Hue Lights - Turn Off.
Suddenly Alexa found the cursed “Audio Actions In Routines Not Supported” message!
Aha! I thought, in my amended routine, the audio action was listed before the lights off action, swap them and save the day.... but no. No matter the order of the actions Alexa gives an Audio reply saying she can’t give audio replies.

I realise that so far this is nothing new to this thread and conversation.

However, it strikes me as VERY VERY odd that the Alexa app comes with a featured preprogrammed routine, AND that routine is specifically an Audio Action routine. THAT WORKS with Sonos!!

To me this makes no sense. Pre-existing Audio Action Routine ~ works with Sonos. Add to that Routine ~ Audio Action doesn’t work but added action does??
Was the featured Goodnight routine, that comes with the app, not a true routine and just a command? Or does integrating more smart devices cause the problem? What’s the logic here?
I have smart plugs from different companies and apps. In each I had a scene called good night. The Alexa routine turned each scene on, and gave the error. I renamed one of the scenes to bed time 1, and now the Goid Night Alexa routine does not give the message any longer.

My good morning routine included similar goid morning routines, I renamed one. I still got the message. My good morning routine included play weather on the device I speak to. I changed the weather to output to an Alexa device and my messages have now cleared.
amadeoplaza,

Sonos does not (yet) officially support Alexa Routines with their devices as part of the routine itself, though you can launch some routines for light/plug control etc. We will have to wait and see if “the powers that be” decide to go onto to do this, but presumably Sonos have higher priorities with Google Voice Assistant being announced for next week in the U.S.
Userlevel 2
Badge +3
Have you tried looking at the audio routines subset and deleted or erase whatever is there (it could be a hit of the space bar or simply Alexa "thinks" something is there) doesnt hurt to try.

I have the opposite problem... I did place an audio routine - and it executes it - after saying "this device does not support audio..." lol..bugs in the system... I love the sound, though

I have been getting the same error so came looking for answers. Can’t believe this post is 1 year old

and still no solution to this issue.