Answered

Volume issues - Amazon Music and Atmos


Userlevel 1
Badge +1

Hi @Corry P,

I've just noticed that the issue discussed in the thread below has been solved. I don't know exactly when, as I was travelling these last weeks.

But, the fix seems to have generated another bug:

  • Now it's the opposite: when playing a non-Atmos song after an Atmos one, the volume becomes very much louder. If you pause this loud song and then resumes playing it, the volume returns to its normal level.
  • Additionally, in general, all songs appear to play in a lower volume than before.
  • When listening to my Play:1 in another room, I don't have any of these issues.
  • When listening to sources other than Amazon Music, I also don't have any issues.

My setup is a Beam Gen 2 with a pair of Symfonisk bookshelf speakers as surround, no Sub.

Could you let the team that worked on this fix know, please?

c.c @Mr. T , @Jimmy C 

icon

Best answer by Jimmy C 6 August 2022, 21:44

View original

21 replies

Userlevel 1
Badge +1

Hey @Corry P, the issue has just occurred and I submitted diagnostic #1236886664. I hope it helps.

Thanks,

Marcos

Userlevel 6

Hi @furacaopr,

I noticed a couple of weeks ago a fix for the low Amazon Stations Atmos volume had been implemented.

My setup is Arc, Sub and Play:3 surrounds.

For me, Atmos tracks now play around 10dB louder than non-Atmos tracks, therefore, there is still some work needed to align the relative sound levels between Atmos and non-Atmos tracks. Pausing and resuming playback has no impact on volume from initial testing just now.

I have not experienced a non-Atmos track being louder after an Atmos one so it looks like the experience now differs between Arc and Beam, which could be due to the recent changes made to the Arc in 14.12.

Userlevel 4
Badge +4

I also am not experiencing a non-Atmos track being louder after playback of an Atmos track.  I am just happy that after many months the original issue has improved enough (for me, at least) that I can actually enjoy listening to Amazon music on my HT system.

Userlevel 1
Badge +1

It seems then to be a Beam-only issue now.

Userlevel 1
Badge +1

@Corry P, the issue is solved now when crossfade if off, but persists when it's on.

Userlevel 1
Badge +1

Okay, this has been hard to replicate, but the issue persists even with crossfade off.

From what I was able to notice, you have to play a non-Atmos song, then an Atmos song and finally the next non-Atmos song will play much louder than normal.

I tried it with short songs, as it takes a shorter time to make all the tests:

HD - Maggie Mae (The Beatles) - 40 seconds

ATMOS - raindrops (Ariana Grande) - 38 seconds

If you try the following playlist in Sonos, with the repeat setting on, the second time you hear Maggie Mae, the volume will be much louder. Tap “pause” and then “play” and the volume will be back to normal.

https://music.amazon.ca/user-playlists/370eadf1b3c0449d8042274b45dfd939c2a0?marketplaceId=ART4WZ8MWBX2Y&musicTerritory=CA&ref=dm_sh_YOIZYL3SgchLvVhugjD6Kr3P9

Please, let me know if you have this same issue (I hope I'm not alone) 😀

Marcos

Userlevel 1
Badge +1

 

@furacaopr,
I’ve just tried this on a Beam2 with surrounds and Sub and I can’t reproduce the issue mentioned. It seems to have been fixed here - the Maggie Mae track is not any louder the second or third time around - it stays the same volume throughout - the pausing/restarting of the track didn’t change its volume in my test here either.

Userlevel 1
Badge +1

@furacaopr,
I’ve just tried this on a Beam2 with surrounds and Sub and I can’t reproduce the issue mentioned. It seems to have been fixed here - the Maggie Mae track is not any louder the second or third time around - it stays the same volume throughout - the pausing/restarting of the track didn’t change its volume in my test here either.

Thanks @Ken_Griffiths, would you mind removing the Sub and trying again, please?

Ahhh .. if I switch on ‘crossfade’ then the last few seconds of the Maggie Mae track next time around goes louder for me as the system ‘buffers’ the Ariana Grande Atmos track ready to play next - so that’s the issue I’m now seeing. Diagnostic: 2005418969

It’s late here, so will give it another go tomorrow without the Sub and let you know what I see - but definitely an increase in volume just for the last few seconds of the Maggie Mae track in my case, when crossfade has been enabled,  and it seems to occur as the system buffers the Ariana Grande raindrops track to play next. 

HTH for now.

Userlevel 6

@furacaopr 

I’ve tried your playlist test and with crossfade ON, the Maggie May track does go much louder during the ‘crossfade’ period.

With crossfade OFF, I don’t experience subsequent plays of Maggie May being much louder. The songs are both listenable at the set volume. Repeat playlist also active at this time.

This is using an Arc (both with and without sub)

Using the Beam2 here this morning, I removed the Sub so there was just the Beam2 and Sonos One (gen2) surrounds…

Without crossfade ’on’ I’m not seeing any problems, both tracks on repeat keep playing more or less at the same volume level and I’ve let them play a half dozen times, the volume of Maggie/Mae and Raindrops never alters.

My next test will be with crossfade ‘on’

Diagnostic from this test: 1058542414

So with no Sub in the HT setup and with crossfade ‘on’ I’m seeing the exact same issue that I mentioned in my earlier post, there’s an increase in volume just for the last few seconds of the Maggie Mae track. This only happens when crossfade has been enabled. It still appears to occur as the system buffers the Ariana Grande raindrops Atmos track and gets it ready to play next

Diagnostic: 2032427962

Userlevel 7
Badge +18

Hi @furacaopr & @Ken_Griffiths 

Could you please try creating an Amazon music playlist (not within the Sonos app) of the same mix of track types and test playback of it? This is the only workaround we know of that still allows playback of UHD tracks. Thanks.

 

Edit: Apologies, I just noticed the link showing it already is an Amazon playlist. Please disregard.

I have created a ‘shared’ playlist of the two tracks from Amazon if anyone needs it, the link is below..

https://music.amazon.co.uk/user-playlists/6d3788b9cd9d44bfa0d565646d796524engb?ref=dm_sh_a8cEdr6Z5yg5zaUW9Rmg0btQQ

Also just to add, I do see the same thing happen with the Arc, when playing the same two tracks on ‘repeat’ too (with crossfade enabled), FWIW. Diagnostic: 541451182

Userlevel 1
Badge +1

Hi, I tried everything on my system: rebooting, removing surrounds, changing Amazon account, removing HDMI, changing router, resetting the system and no help. The Maggie Mae track plays much louder the second time, even with crossfade off.

@Corry P, do you believe these diagnostics can help?

  • Maggie Mae playing louder than normal: 866467994
  • Maggie Mae paused: 1829477711
  • Maggie Mae resumed at normal volume: 478246674

Thanks everyone!

@furacaopr

If I leave crossfade disabled, it seems to all work fine - so I’ll just leave it switched off for the time being.

Userlevel 7
Badge +18

Hi @furacaopr 

 

@Corry P, do you believe these diagnostics can help?

  • Maggie Mae playing louder than normal: 866467994
  • Maggie Mae paused: 1829477711
  • Maggie Mae resumed at normal volume: 478246674

Unfortunately, because there is no actual volume change - just a perceived one - the diagnostics don’t actually help much. I’ve already passed Ken’s diagnostics on to a senior technician who was unable to discern anything. Please note that the issue/thread linked to in the original post relating to volume differences in SD and UHD tracks has not been resolved as of yet, so we’re viewing this as the original problem still.

Userlevel 1
Badge +1

Thanks @Corry P 

Reply