Answered

Volume issues - Amazon Music and Atmos

  • 5 August 2022
  • 73 replies
  • 1996 views

Userlevel 3
Badge +2

Hi @Corry P,

I've just noticed that the issue discussed in the thread below has been solved. I don't know exactly when, as I was travelling these last weeks.

But, the fix seems to have generated another bug:

  • Now it's the opposite: when playing a non-Atmos song after an Atmos one, the volume becomes very much louder. If you pause this loud song and then resumes playing it, the volume returns to its normal level.
  • Additionally, in general, all songs appear to play in a lower volume than before.
  • When listening to my Play:1 in another room, I don't have any of these issues.
  • When listening to sources other than Amazon Music, I also don't have any issues.

My setup is a Beam Gen 2 with a pair of Symfonisk bookshelf speakers as surround, no Sub.

Could you let the team that worked on this fix know, please?

c.c @Mr. T , @Jimmy C 

icon

Best answer by Jimmy C 6 August 2022, 21:44

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

73 replies

Userlevel 3
Badge +2

This bug has finally been fixed today on release 14.18 😀

Userlevel 1

@Airgetlam, @Xtreme:

Corry P (Sonos staff) has confirmed, that they are able to reproduce this issue in their lab.

“[…] and we are able to reproduce it in-house.“

I can't wait for a fix either, but the issue seems to be at least acknowledged and worked on by Sonos (@Corry P?).

I get this issue as well 😞. I use Amazon music and volume issue happens mostly after playing an Atmos content transitioning to Ultra HD. Music so loud I have to put slider down to around 1-5 or as you guys have done, toggle pause/play.

 

I logged this to support and they say it is a known issue.

 

Userlevel 7
Badge +18

Hi @furacaopr 

 

@Corry P, do you believe these diagnostics can help?

  • Maggie Mae playing louder than normal: 866467994
  • Maggie Mae paused: 1829477711
  • Maggie Mae resumed at normal volume: 478246674

Unfortunately, because there is no actual volume change - just a perceived one - the diagnostics don’t actually help much. I’ve already passed Ken’s diagnostics on to a senior technician who was unable to discern anything. Please note that the issue/thread linked to in the original post relating to volume differences in SD and UHD tracks has not been resolved as of yet, so we’re viewing this as the original problem still.

Userlevel 1

I'm having the same issue with my Arc. I just put on a random Amazon playlist through the Sonos App. Had to set the volume to 45 or so. Couple songs later the music started blasting, had to turn it to 12 for comfortable listening.

Userlevel 7
Badge +18

Hi @furacaopr 

This issue is not location-dependant, and we are able to reproduce it in-house.

Same issue on my setup: Arc + Sub (Gen. 3)

When I’m listing to a amazon music playlist, which contain some Atmos titles, my Arc tend to SCREAM the music on some cases. This is so annoying! It happen’s only when the audio format from the tracks switch from ultra/hd and Atmos. This do not happen, when I skip the songs myself.

 

Userlevel 7

@Sonos: Any update regarding this issue?

Even a workaround (deactivate Atmos somehow?) would be appreciated. Lot‘s of people have expensive systems at home which can‘t be used. :(

You can restrict the stream quality to HD/Ultra HD by grouping a non-Atmos capable speaker.

Userlevel 7
Badge +18

Hi @Lars1425 

I’ve no further information to share at this time - which is not unusual. We tend not to share progress or provide dates, as it can cause more consternation than it’s worth.

FWIW, I've had my Sonos ARC SL, One SL's and Sub 3 for 5 months. Just started having this exact issue  this week. Drives me crazy because I can't just let it run, always have to be ready to be blasted by loud music, pause and restart track.

The playlist above, with Maggie Mae and Raindrops on repeat, reproduces it.  I'm hoping a fix is found soon.

Hi.
I'm also stuck experiencing a similar issue.
I'm Japanese, but unfortunately there were no Japanese sites dealing with this issue, so I had a hard time finding this page.
Sonos is one of my favorite brands and I hope this unfortunate issue is resolved soon.

I believe only @Corry P could clarify 

This was @Corry P’s latest comment on the issue FYI… 

So I assume nothing has changed, but let’s see what the next Sonos software update may bring.

Ahhh .. if I switch on ‘crossfade’ then the last few seconds of the Maggie Mae track next time around goes louder for me as the system ‘buffers’ the Ariana Grande Atmos track ready to play next - so that’s the issue I’m now seeing. Diagnostic: 2005418969

Userlevel 7

Hi @furacaopr,

I noticed a couple of weeks ago a fix for the low Amazon Stations Atmos volume had been implemented.

My setup is Arc, Sub and Play:3 surrounds.

For me, Atmos tracks now play around 10dB louder than non-Atmos tracks, therefore, there is still some work needed to align the relative sound levels between Atmos and non-Atmos tracks. Pausing and resuming playback has no impact on volume from initial testing just now.

I have not experienced a non-Atmos track being louder after an Atmos one so it looks like the experience now differs between Arc and Beam, which could be due to the recent changes made to the Arc in 14.12.

Userlevel 7
Badge +18

Hi @furacaopr 

In quoting me, @Ken_Griffiths was entirely correct.

😁

@furacaopr

If I leave crossfade disabled, it seems to all work fine - so I’ll just leave it switched off for the time being.

@Lars1425I would not expect a “fix” for this. Why? Because imho nothing is broken. Atmos is a different format, sounding different to normal music (always will) and that's just that

It’s wildly not normal behaviour, just in case you haven’t experienced it. My system plays the track immediately after an Atmos track at max volume. The volume slider moves. I usually sit at around 20% volume if I’m just listening to music in my living room. I’m not making it up or kidding. It changes track and almost blows speakers and breaks windows. I’ve been terrified I’ll break something and I’ve woken/disturbed my kids multiple times with it. It’s absolutely broken.

Userlevel 1

So I started streaming after my last post. It just happened again. I told them yesterday that it's a software issue that they need to addressed rather than putting the blame on other things. Hopefully enough people will complain and they will try to fix it.

Userlevel 2
Badge +2

@Lars1425I would not expect a “fix” for this. Why? Because imho nothing is broken. Atmos is a different format, sounding different to normal music (always will) and that's just that

It’s wildly not normal behaviour, just in case you haven’t experienced it. My system plays the track immediately after an Atmos track at max volume. The volume slider moves. I usually sit at around 20% volume if I’m just listening to music in my living room. I’m not making it up or kidding. It changes track and almost blows speakers and breaks windows. I’ve been terrified I’ll break something and I’ve woken/disturbed my kids multiple times with it. It’s absolutely broken.

 

Sorry guys my bad... THAT much of a volume increase, I have never experienced.

I did experienced a tiny but audible volume difference with Atmos and after it annoyed me I switched to the Amazon music app and never went back.

I am also experiencing this issue or something very similar listening to Amazon Music Prime Stations on my Sonos Arc system with surrounds and sub using the Sonos app. After many months of listening, the issue started happening a few weeks ago. I’m not sure if it’s related, but I keep getting pop-up messages asking me to retune my Arc even though I’ve retuned it several times.
 

Hopefully, Sonos now has a handle on the problem and will be able to release a fix soon.

Userlevel 1

Of course we have. They blame it on everything besides themselves. I told them repeatedly that it's a software issue but they still blamed it on things I had plugged in, loudness setting, my phone somehow controlling the volume in the background, etc

If we could just stream directly from Amazon Music that would probably solve all of these issues. I guess that's too much to ask.

You can of course stream direct from Amazon Music using the mobile Apps ‘Connect’ feature, or if you use Apple products, using Airplay2 aswell.

Userlevel 3
Badge +2

Hi @Corry P,

Atmos Music on Amazon was launched by Sonos on 12/07/2021 with the 13.4.1 release. Soon this will complete 1 year. Since this launch, I've been complaining about these volume issues when transitioning between Atmos and HD/Ultra HD tracks.

It's unbelievable this hasn't been fixed yet. I'm loosing my faith in Sonos. Unfortunately ☹️

I can't add my Sonos Arc to devices in Amazon Music. I have android so no Airplay 2.

Sounds like you may have a fault there then - maybe a network discovery issue perhaps?

Our ‘Living Room’ Arc shows up here on our android tablet in the Amazon Music App ‘Connect’ list…

 

Userlevel 1

Same issue here with Arc + Amazon Music.

A non-Atmos song playing after a Atmos song is much louder. Can be reproduced with different Amazon Music playlists. Important: Skipping songs doesn‘t cause the problem. Just move manually to the last seconds of the Atmos song and wait for the next song to beginn.

A fix would be much appreciated, since I can‘t listen to Playlists and Stations anymore.