Answered

Sonos stops playing randomly


Hi. My Sonos system has worked perfectly for years, but have recently started to experience an issue whereby playback of music will suddenly stop altogether. The length of time this happens after is fairly random but it could happen a couple of minutes into the first song, or in the middle of the second or third. It happens both whilst playing music from my NAS, or from internet services like Amazon music.

This has been happening for a few weeks now and is difficult to pinpoint to a single cause, because several changes happened in my home at round about the same time: i) there was a large Sonos software update which failed several times before finally working; ii) I got a new NAS (so my music library moved); iii) I moved some of my network devices around; iv) I upgraded my main broadband router to a BT Smart Hub (although these last two were largely in response to the problem!).

So far, I have tried:
- Separating the 2.4 and 5GHz wifi frequencies
- Ensuring Sonos is on a different channel (11) to my home wifi (6)
- Checking for wireless interference from other networks in the area
- Checking for any IP address conflicts on my network (there are none)
- Replacing cable being used to connect Sonos Bridge to my network
- Moving the Sonos Bridge away from the router and other devices to a different part of the house
- Switching off my wireless IP cameras in case they were causing interference

Getting desperate now. Just done a diagnostic - 7660366 - if anybody can help!

TIA
icon

Best answer by Airgetlam 13 April 2019, 21:48

In most cases of music stopping randomly, it's caused by wifi interference.

If the solutions provided in that link, it might be helpful if you were to submit a system diagnostic within 10 minutes of replicating this issue, and either post the number here, or contact Sonos to discuss it. There may be information included in the diagnostic that will help Sonos pinpoint the issue and help you find a solution.
View original

35 replies

Thank you. We would like to move your case over to our phone team, as we can go through more detailed troubleshooting with you in live time. I am going to send you a direct message requesting more information, so I can create a case for you. 

Hello Richard,

So my Sonos system has started to play up again. It’s only my beam that’s affected. I have a Sonos one grouped with the beam. The beam stops playing while the one keeps on playing. I group the beam back with the kitchen and it’ll play for 2-3 mins and then stop again. Any help would be appreciated. My diagnostic number is: 177370424

Kind regards
Brendan

 

Thank  you for letting me know. The only thing I am seeing in this diagnostic, is insufficient bandwidth. When you are playing music to your speakers, is anything else using your internet? 

 

Also, what time of day does this happen? If this happens post rush hour, it is possible that your internet provider may be struggling to maintain the appropriate bandwidth to maintain the audio stream. 

Hi Richard, the Sonos system has been good since last time I spoke to you but it’s started playing up again. It’s cutting out using Apple Music with the iPad and also through the record player hooked up with the connect. My diagnostic number is: 111585530

 

Thanks again

Brendan

Sounds good! I look forward to your reply. 

Yes the beam cuts out while using Apple Music. I’ll see what it does tonight and if it stops I’ll run another diagnostic test. 

Thanks

Thank you for confirming that. The diagnostic did not show any errors from those services. Have you played music from Spotify, or Apple music recently? 

 

Does this only happen when the Connect is playing audio; for example, if you were to play music on just your Beam, does the audio cut out as well? 

Hello Richard, thanks for the reply. Yes it also stops when I’m using Spotify or Apple Music or any other streaming service. The turntable is a pioneer dj and has a pre amp. 

Kind regards

Brendan

Hello @bminno9, welcome to the community! 

 

I understand that you are experiencing some issues with playing music from your turntable to Sonos. Thank you for providing that diagnostic. Would you mind answering a few questions for me?

 

Does this happen with music services, such as Tunein, or does this only happen from content from the turntable? 

 

Does this turntable have pre-amp by chance? If you are not sure, would you mind providing the make and model of that turntable?

I’m having a similar problem. I’ve got my record player hooked up through my connect. I’ve tried changing the wireless channels on both the Sonos app and router. Works for a bit then cuts out. My ref number is 2033664107. 
 

Thanks

Bruce
i don’t have wireless speakers
My Connect :Amp is wired to my speakers and the amp is connected to the Google Wifi via ethernet cable and a switch
IphoneX is connected via wifi to Google Wifi
Connect:Amp has a static IP address on Google WiFi
cheers John
I have submitted my system diagnostic
1149825584

my iPhoneX.... the problem goes away when I turn the iPhone’s Auto-Lock to NEVER

Dear Mr Sonos
is this the answer to the problem?
Your comment would be appreciated
thx
But that doesn’t indicate what the strength of the signal is between your speakers and your router, and also doesn’t show you if you might have a potential IP conflict. The only indication there is that your phone sees a 3 bar signal average over time.
I’m having the same problem on my iPhoneX and my wife’s iPhoneX
the playback stops randomly
BUT the iPhone tells me that Sonos has lost connection with my iphone
That’s s fine explanation but I have 3 bars wifi signal strength on my iphone

Help
Thanks, i will try that and send the system diagnostic to sonos if i couldn't find the problems
In most cases of music stopping randomly, it's caused by wifi interference.

If the solutions provided in that link, it might be helpful if you were to submit a system diagnostic within 10 minutes of replicating this issue, and either post the number here, or contact Sonos to discuss it. There may be information included in the diagnostic that will help Sonos pinpoint the issue and help you find a solution.
My sonos one stop music randomly. It doesn't important the music source. Mostly stop playing after 10 min or more
Userlevel 7
Badge +19
Hey there, dsmoran. Thanks for posting and welcome to the Community. You may want to check out this topic where one of our users spoke to a senior technician about streaming content from your mobile device.
My music stops playing when playing music from iTunes on my phone. I submitted diagnostics, changed wifi channels and nothing seems to work. The only thing that works is switching to play music through amazon prime. I think its a bug purposely inserted by sonos with last years app update.
Userlevel 7
Badge +19
Hi there, Bubbajoegus: Thanks for the diagnostic report. I was able to take a closer look at your account and saw that you have reached out to us. Should you still need assistance, let us know.
Ok - submitted diagnostic #7914187
Userlevel 7
Badge +21
Suggest you submit a diagnostic after it happens and post the number here for a Sonos rep
Stuart - I've tried what you suggested with the iPhone. My Wi-Fi assist was actually already off. I believe it is something with the iPhone as I tried another source - my Amazon Echo - which I have on 'line-in' to a play-5. I played an amazon cloud playlist through my entire sonos system and there were no skips, jumps or stoppages in play. It is something with the iPhone/sonos interface. I wonder if my various iPhone apps' notifications are interfering...I haven't seen a pattern there yet but I do have all sorts of notifications for mail, messenger, fb, etc. Any other ideas? perhaps there is a sonos' app setting that I am missing.
Userlevel 7
Badge +21
I tried changing my standard connection to a direct connection from my wifi router to one of the play 3s; that didn't help...any ideas?

A couple of things to tr. As you say the issue happens with your iPhone try disabling the Wi-Fi assist.
Also, check to see if your phone is connecting to your router's 5GHz or 2,4GHz wireless network - Less likely this is the issue if you still get the problem wth your Sonos wired.
I tried changing my standard connection to a direct connection from my wifi router to one of the play 3s; that didn't help...any ideas?

Reply