Answered

Sonos Play 5 Gen:2 will not connect to WiFi


I forgot to add the diagnostic information, its #1488866377
icon

Best answer by Ryan S 25 July 2019, 19:42

For anyone new to this topic, if you find yourself with a Play:5 gen2 or other Sonos speaker that can't connect to the network when wireless, but it works just fine wired in, there are a number of things to check, but there's a chance that there's something wrong with the wireless on the device. Run a diagnostic in the Sonos app with the speaker connected to the network using an Ethernet cable. This is under Settings > Advanced Settings.



With the diagnostic number handy, the best thing to do is to get in contact with our support team directly. They will help identify if there's a hardware issue or something network related that can be fixed, and will assist with the next steps.
View original

63 replies

I've see a few mentions of this issue but I have not seen any resolution. I have a generation 2 play 5 that worked for about a year and now won't connect to Wifi. I believe the problem started after I did a software update but at this stage after trying everything I'm still not able to connect. However if I plug it in via an Ethernet cable it works fine. Can anyone help me to figure out how to solve this issue? Is it a hardware issue or is some software fix available that I need to install?

I forgot to add the diagnostic information, its #1488866377
Userlevel 7
Badge +20
Hi

I'm assuming that you don't have any other Sonos devices connected via an ethernet cable? Can you please reset the Wi-Fi setup in the Sonos App>Settings>Advanced>Wireless Setup and then if you don't have any other wired Sonos players reconfigure wi-fi. (If you do then your system is in Boost mode and wi-fi credentials should not be added.)
Userlevel 7
Badge +20
I forgot to add the diagnostic information, its #1488866377

Hi Laurence5,

Thanks for sending in the diagnostic report. It looks like there's something going on with the wireless card on your PLAY:5. Our phone team should be able to pick things up from here. Please give us a call, you can find our phone number and hours here.
Badge
I have the exact same issue. Can you help me?

Diagnostic Id: 356211501
Userlevel 7
Badge +20
I have the exact same issue. Can you help me?

Diagnostic Id: 356211501


Thanks for sending in the report. I see a Play:5 in your report, but it seems to be connecting to the wireless signal. If the unit in question isn't showing up in the app, please temporarily wire it in to the network with an ethernet cable, then send along a new report.
Hi there, I got the same issue, i can only connect my play 5 wired.
Diagnostic Id: 1257969747
The issue was resolved by Sono's successfully by sending me a replacement unit as it was a known issue with a defective wireless card. I'm happy again with a working system and Sonos support were very helpful. I hope you also get your issue resolved as I know the frustration of not being able to connect.
Hi, I have the same problem, diagnostics 461560896. Any chance to havea look at it?
Thanks a lot!
Userlevel 7
Badge +19
Hi there, nathan.windels. Seems like your Play 5 has the same hardware issue. As previously shared by Laurence5, the best recommendation is to get in contact with our support team. They are able to have a closer look and get this replaced. Thanks
Hi I have the same issue
Diagnostic code 1322784620
Connects via EN cable but not WiFi connection... worked fine until a few weeks ago...
Play 5 Gen 2
Please help... I posted above but realised I logged in incorrectly.... my play 5 gen 2 will not connect wirelessly and the issues is the same s as this thread....

Diagnostic code. 1322784620.
Thanks Jenny
Userlevel 7
Badge +20
Please help... I posted above but realised I logged in incorrectly.... my play 5 gen 2 will not connect wirelessly and the issues is the same s as this thread....

Diagnostic code. 1322784620.
Thanks Jenny


Hi Jenny,

I can't see any data from your Play:5 in the diagnostic report. Please reconnect it using an ethernet cable, then send in a new report and reply here with the number.
Hi, I have connect the 5 via EN cable and submitted a report No.321541215. I look forward to hearing from you. Thanks!!!
Userlevel 7
Badge +20
Hi, I have connect the 5 via EN cable and submitted a report No.321541215. I look forward to hearing from you. Thanks!!!

Thanks for wiring in the speaker. It is still not showing up in the diagnostic report though. Please follow the steps in this guide to get the Play:5 reconnected to your system while still wired in. Once it shows up in the app, send in a new diagnostic report and reply here with the number, I'll take a look.
Hi, we have the play5 working hard wired now and have done another report no. 1711957125. Thanks!
Userlevel 7
Badge +20
Hi, we have the play5 working hard wired now and have done another report no. 1711957125. Thanks!


Thanks, the Play:5 is showing up in the report now. I see that there is a hardware issue with the wireless card on your Play:5. Please reach out to our phone team who can take over from here. You can find our phone number and hours here.
Same issue here and Sonos support also found a wireless card issue in the diagnostic report I sent. They are replacing the unit. With so many mentions of a similar issue here is seem like there might be premature failure on this component. Great to see Sonos standing behind the product and replacing them even out of warranty. 😃
I have the same issue as above, diagnostic report number 487302528, speaker purchased at Dixon’s Luton airport on way to Cyprus, please advise.
Userlevel 7
Badge +20
Hi, dazzywatts. I'd recommend that you get in touch with our support team via telephone. They will be able to help you further. Many thanks, we look forward to hearing from you.
Thanks for the reply, I have contacted via email as I’m in Cyprus, many thanks.
Seems I am having the same issue. Is the only way to resolve this by contacting support? Do I need to be beside my speaker when I do so? Diagnostic Report is 1179306788
Userlevel 7
Badge +20
Seems I am having the same issue. Is the only way to resolve this by contacting support? Do I need to be beside my speaker when I do so? Diagnostic Report is 1179306788
You'll need to contact support directly: https://www.sonos.com/en-gb/contact/contact-options%23

Not sure if you need to be beside your speaker; I doubt it.
I am also having the same issue with a Gen 2 P5. My diagnostic report number is 2146725330.

Thanks
Jon
If you contact them directly they'll be able to figure out the issue. I got a replacement sent out super quickly!
In order to contact them, here's a link:

contact Sonos Support

Reply