Thanks for completely breaking £2000 worth of Sonos gear

  • 15 October 2017
  • 64 replies
  • 3407 views

Userlevel 3
Badge
Latest update has completely broken our setup and we are VERY ANGRY.

The latest update has completely shafted our perfectly working setup around the flat. We have 2 play 5's in a stereo pair in the front room, 2 play 1s in the bedroom, a play 1 in the bathroom, a new soundbar in the family room with 2 1s in surround config, a play 3 on the kitchen worktop and 2 play 3s in the dining room.

WE HAVE SPENT A FORTUNE ON THIS SETUP AND JUST BECAUSE YOU WANTED TO HAWK SOME NEW USELESS ALEXA SPYWARE CRAP IN YOUR NEW SPEAKERS, OUR SYSTEM IS COMPLETELY BROKEN.

Half of our speakers no longer work and the ones that do occasionally work drop out constantly.

If this doesn't get sorted out very quickly, I will consider legal action and judging by the number of other complaints I have read, I won't be alone. I will never buy any more Sonos products again, and I will actively dissuade anybody I know from buying them. Good lord what a shambles.

Sort this out please. And also, while you're at it, please sort out the abomination that is the new app as well, it is awful. Who on Earth did you test it on? How can a company I used to like so much get it so wrong?

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

64 replies

You have gone back to 7.4 on the app, which is just a controller. This has nothing to do with anything that happened on your system
To clarify regarding satellitie wifi, I didn't mean to imply adding wireless access points. I don't care for those either, since they don't really expand your network, they just create multiple networks in your home. I was thinking along the lines of Netgear's Orbi and similar products, as they create one large network, not multiple.
Userlevel 4
Badge +6
John B the update from v 7.4 to v 8.0 broke my system this
update made my system not usable no units found, i then
installed all units again to get it working, this never happened
before with other updates.
And then the v 8.0 controller i really really really dont like it.
Hope this is now clear for you.
Userlevel 3
Badge
Hello everyone

I ran a diagnostic and the confirmation number is 7970523.

John, I forgot about your suggestion regarding deleting the Wifi network login and password. The Surround was better, but still patchy. It's annoying because it seems OK for a couple of minutes then there will be a dropout or worse, a succession of really quick dropouts. It's got to the stage where if it's on, I'm constantly listening for them and not concentrating on what's on the gogglebox.
Hi Geoff. I wasn't really expecting that to help the immediate problem, it's more to eliminate one possible source of future instability. Now your speakers have no option but to connect over SonosNet.

Hopefully the diagnostic will reveal something. It may yet turn out to be a hardware fault, and no amount of troubleshooting will help that.
Userlevel 7
Badge +26
Hopefully the diagnostic will reveal something. It may yet turn out to be a hardware fault, and no amount of troubleshooting will help that.

It did, and it is. Looks like there's a problem with the wireless card on the PLAYBASE. Likely, the reboots from the update caused some network mayhem as whatever was allowing those PLAY:1s to connect wirelessly through another device stopped working right. You'll want to get that PLAYBASE replaced.

I'll pass the details for this on to the team and you'll be getting an email from them shortly to follow up.
Userlevel 3
Badge
Thanks Ryan. I've just replied to an email from Sonos regarding a replacement.
Geoff Simmonds,

Reserving IP addresses would be a solution to your network problems, especially if your router is prone to crashing or reboots. Once you reserve an address, it will be assigned to one and only one device, no matter the state of the router. It is not that difficult a task, if you can setup a WiFi username and password, you can reserve IP addresses. List the make/model of your router and we can help you out.

As to rebooting Sonos devices remotely, there is an undocumented feature for that. Open a browser and type the following:

http://xxx.xxx.xxx.xxx:1400/reboot

Where xxx.xxx.xxx.xxx is the IP address of the Sonos device. You can get this IP at Settings->About My Sonos System on the Sonos app. But hopefully, if you reserve IP addresses, you won't have to use this too often.


I’ve seen it mentioned in the community that occasionally, some 'old' (stopped) Amazon Sessions on Sonos Room Speakers occasionally get stuck and appear to Alexa as though the music is still playing in that room, when in fact the music was stopped sometime ago... if this happens, it can be slightly annoying for several reasons...

One is when you start music playing in another separate room and try to go to the 'next track', Alexa will try to change the track in the other playing room with the stuck Amazon Session... or if you want to change volume or start music etc. in another room, Alexa says that music is streaming on another device and starts asking which room do you want? ... and you know full well that the other room is stopped and not playing music.

Anyhow, I’ve seen some people here, suggest powering off the speakers just in the room where the stuck Amazon Session persists, or even send the command http://xxx.xxx.xxx.xxx:1400/reboot to restart the room speakers, but that sometimes (in my experience) does not always clear the stuck Amazon session.

The best way I have found so far, to clear such a stuck session, is to start another Amazon Session in a completely separate room and then temporarily group the 'stuck room' with the latest playing session. Then stop the music and ungroup the two rooms... and the stuck Amazon Session will then completely disappear.

There maybe other solutions, but this method has worked 100% of the time for me and I thought it worth sharing here.

I have had just one stuck session today since recently upgrading to v8.1 and forgetting my smart home devices and disabling and reenabing the Sonos Skill in the Amazon App, and it may have been just a left over Amazon Session prior to that recent upgrade.

I hope this information on the beta voice control may prove useful to others who may encounter this issue ...and if it happens again, I will submit a further diagnostic.

The diagnostic on this occasion is 7977405
Badge
Try connecting your newly downloaded app to your wifi, and reconnect all devices - worked fine for me
So - the latest update is creating issues - still don't like this new app AT ALL but trying to make the best of it - now only my Ipad can see all the speakers.... my android phone and laptop can only see 3 of the speakers. I have restarted devices, re-set the router, everything off and on several times - still only see 3 speakers out of 8... diag 8054758 for the laptop seeing only 3 - hope you can fix this soon as it is making our very expensive system unusable!
Connection problems which appear suddenly are often caused by network problems, not Sonos problems. The typical cause is duplicate IP addresses. These often show up after an update or power outage because a reboot requires the device to request a new IP, and the router, having lost track of current IP assignments, issues a new IP that is in use by another device. To cure this, do the following:

Reboot/power cycle your devices in the following order:

Modem
Router
Switches or hubs
Wired Sonos units
Wireless Sonos units
Computers/printers
Wireless devices - phones/tablets etc.

Allow each device to come back up before proceeding to the next. Note that you can permanently prevent duplicate IP addresses by assigning an IP to each device's MAC address in the router setup. See your router manual for details.