Apple Music - we've run into a problem

  • 17 February 2021
  • 75 replies
  • 6142 views

Userlevel 2
Badge +1

For some reason, I cannot use the ‘My Music’ function of the Apple Music Service anymore. It displays “We’ve run into a problem. Try again.”

 

I have deleted the app on all my devices, reinstalled. I’ve deleted the service and reauthorized. I’ve reset my router.

 

Apple Music works fine. It’s only within the Sonos app that the error occurs.  Please help. Family account if that matters, and both users experience this.

 


75 replies

Same thing happening to me and nothing I do helps. I bought the Sonos One for the very purpose of playing my Apple music. I find it difficult to believe Sonos can’t fix the problem. The item is no more than an expensive radio. Waste of money. Will never purchase a Sonos product again. Product is a con.

 

I’ve had this issue for around 6 months now too, started as soon as I switched back to Apple Music from Tidal.

The problem: For me, the issue is isolated to “Apple Music → My Music → Artists” and “Apple Music → My Music → Albums”. The precise error message is “We’ve run into a problem. Try again.”

SONOS TEAM: this is NOT a wifi issue. This is a software bug that needs to be raised with the appropriate product manager. The fact that Playlists and the Songs are both working perfectly fine makes this glaringly clear to anyone familiar with the Apple Music API that there is bug in the code specific to the Artists and Album routes. This is not an account issue or a broad authentication issue, since every Song in the account can be returned perfectly fine under “Apple Music → My Music → Songs”. Happy to get into more detail with the PM if you want to have them reach out to me.

There’s a few recurring themes and my guess is that they are affecting something in the code for these routes — for example, many of us have changed the country associated with our account. This could be stored incorrectly somewhere and causing an issue.

Really hoping the team at Sonos can step up to the plate and raise this issue to the product manager. It’s really frustrating that this is simply being ignored, as it’s ruining a large part of the Sonos experience for many of us.

 

While I understand that’s it’s not particularly helpful to resolving the issue, but the interface between Sonos and Apple is not Apple’s API.  Sonos isn’t using any music services API.  They have their own API and music services are required to use the Sonos API, not the other way around. The Sonos hardware simply doesn’t have the resources to use multiple APIs for every music service it works with.

That doesn’t necessarily mean that it’s Apple’s fault.  There could be an issue where the Sonos code isn’t requesting the track listing correctly, though that seems odd that it works for every other track list request for every other music service. I would guess that Apple is returning an error if the country code on the Sonos side doesn’t match the country code it sees for the Apple account.  Makes some sense if the country code restricts what music is available to due contract restrictions.  This could very well be something that Apple doesn’t recognize much as Sonos based requests are not their primary music play requests.  But I am guessing, could be way off.

Either way, Sonos could be looking into it, and trying to work with Apple to fix the problem.  It’s hard to say that you’re working on an issue if you can’t replicate it, don’t know why it’s happening, and likely don’t own the code that needs to be fixed (if it’s a software problem)

 

only solution I found after speaking to Sonos and apple for hours was to sell all my Sonos speakers and switch to HomePods - so frustrating and not worth trying to fix an issue that never should have existed 

Come on, Sonos team-something to show you care about this. Or can I get a refund on my £3000+ worth of Sonos kit to buy something that works??????

I've been having the same problem. Sonos app says my Apple Music account needs to be reauthorized, but when I click the link, nothing happens. I called Sonos for help but got none. Some sort of software glitch, they said. So my speakers are now useless, as I used them mainly with Apple Music. 

My neighbor is having the same issue after the recent Sonos update. When we tries to add the service, she logs in to Apple Music and she gets “We’ve run into a problem. Try Again.” Very frustrating for her (and me, since I talked her into buying Sonos speakers).

Same problem here, I only got the problem with My Music → Artists and Album overview. Tried everything, restart my Boost, Speakers….log out ..log in with Apple  Music, all of it doesn’t helped, looks like a bug from Sonos side.

Userlevel 2
Badge +1

Hi @Sonos - I have been extraordinarily patient waiting for you to fix this. Can you please post an update on your progress? To reiterate, I have spent lots of time with Apple support and they say this is a Sonos issue.

 

 

Hi @Sonos - I have been extraordinarily patient waiting for you to fix this. Can you please post an update on your progress? To reiterate, I have spent lots of time with Apple support and they say this is a Sonos issue.

The issue seems to be down to Apple, as it’s the authority token to share their music services via an Android App that is failing during the setup. It works absolutely fine on all iOS devices (the AM App on the device is used for the authorisation process). It appears Sonos have apparently asked them to fix this from the things I’ve read here in the community.

Apple’s own developers are responsible for the built-in AM service on Sonos anyway, which simply uses the published Sonos API, which is used by every one of the other music services that you see in the Sonos App too.

Hi @Sonos - I have been extraordinarily patient waiting for you to fix this. Can you please post an update on your progress? To reiterate, I have spent lots of time with Apple support and they say this is a Sonos issue.

The issue seems to be down to Apple, as it’s the authority token to share their music services via an Android App that is failing during the setup. It works absolutely fine on all iOS devices (the AM App on the device is used for the authorisation process). It appears Sonos have apparently asked them to fix this from the things I’ve read here in the community.

Apple’s own developers are responsible for the built-in AM service on Sonos anyway, which simply uses the published Sonos API, which is used by every one of the other music services that you see in the Sonos App too.

I am on this forum because I have the very same issues with Spotify and was considering switching to Apple Music to resolve the problem - because I thought it was a Spotify issue. However, I decided to do a search on connection issues with Apple Music and guess what - low and behold, the very same issues are being experienced by Apple Music users .. so the issue is clearly not Apple or Spotify related but Sonos related. 

I have had these issues with my Sonos for a long time and have had enough of it. Now I can see that it will not be resolved by switching from Spotify to Apple Music or presumably any other music service, I am going to look for Sonos alternatives instead. 

I wonder to what extent these “issues” are deliberate with a view to forcing people to upgrade to S2 from S1. It will now work for me because once bitten twice shy. I will look for a good Sonos alternative. Any ideas on good alternatives from anyone who has jumped ship to resolve? 

 

I am on this forum because I have the very same issues with Spotify and was considering switching to Apple Music to resolve the problem - because I thought it was a Spotify issue. However, I decided to do a search on connection issues with Apple Music and guess what - low and behold, the very same issues are being experienced by Apple Music users .. so the issue is clearly not Apple or Spotify related but Sonos related. 

I have had these issues with my Sonos for a long time and have had enough of it. Now I can see that it will not be resolved by switching from Spotify to Apple Music or presumably any other music service, I am going to look for Sonos alternatives instead. 

I wonder to what extent these “issues” are deliberate with a view to forcing people to upgrade to S2 from S1. It will now work for me because once bitten twice shy. I will look for a good Sonos alternative. Any ideas on good alternatives from anyone who has jumped ship to resolve? 

 

I don’t personally normally use either a Spotify or Apple Music subscription, but I seem to see on this forum that the Apple issue was mostly only on an android controller device and that was ‘fixed’ apparently shortly before Christmas by Apple (rather than Sonos).

Anyhow that aside I thought I would try adding the Spotify service to my Sonos App (albeit their free service) and it has installed and plays fine without any issues here. (Screenshots Attached).

And just for good measure, I managed to get a free subscription period to Apple Music - and that has also added to the Sonos App and is working well here. (screenshots attached to show that aswell).

The only issue I see with the Apple service, is I don’t have any local library uploaded via the iTunes App so that section is not populated (obviously). Everything else seems fine however.

Tried nearly all remedies referenced (apart from the ones I know are nuts!) and my Sonos One (Gen 2) speaker still cannot play the Made for You Apple playlists. Once upon a time it could, but those days are but a memory now! Everything else works, so I’m inclined to agree with other people who’ve posted here, it ain’t a Wi-Fi issue, it’s definitely a software problem! 

Writing as an owner of a non-functioning HomePod (and the victim of an Apple Genius Bar employee who alleged an electricity surge to abdicate Apple of any responsibility in remedying the situation!), I generally like the Sonos One. However (and much like the HomePod), I’d greatly appreciate a product that actually works as described. Perhaps one day in the future my appreciation will marry reality; I’m 57 and realize it may not happen within my lifetime!

Well I suppose this thread may no longer be active but thought I would chime in with the same problem, same lack of success with the fixes proposed. The frustrating thing to me is that Sonos is not even acknowledging that there is an issue. At least say you are working on it or don’t care. Clearly this is not some unique wifi interference thing. 

I’m having the same issues when I try to access anything from the Apple Music > My Music section. Recently switched to Apple Music from Spotify. Found this thread hoping it would be a quick fix but disappointing to see it’s a long term unresolved issue. Will cancel my subscription to Apple Music and go back to Spotify. Maybe if enough people do this Sonos and Apple might work together to eventually resolve this.

I’m having the same issues when I try to access anything from the Apple Music > My Music section. Recently switched to Apple Music from Spotify. Found this thread hoping it would be a quick fix but disappointing to see it’s a long term unresolved issue. Will cancel my subscription to Apple Music and go back to Spotify. Maybe if enough people do this Sonos and Apple might work together to eventually resolve this.

I would rather see Apple work on a new version of their Sonos Service instead, to include HD/UltraHD/Atmos music tracks. That’s seems to me to be the way forward to entice new customers to use their music service.

Userlevel 2
Badge +4

I’ve just moved from Spotify to Apple Music and spotted this thread. 

Browsing to Albums and Artists is playing for me but if I try and stop the song quickly I always seem to get a message “Unable to play the requested song”

I don’t seem to be able to see all of the music through the Sonos S2 app that I can through the Apple Music app either. Not sure if this is to be expected?

And although I know this isn’t a Sonos issue I’ve also noticed that trying to shuffle Apple Music through Alexa also doesn’t work.

sussed the problem

If you play music from your iPhone through airplay on speakers it then unblocks access through the sonos!!!!

Sooo, any updates? 

I upgrade my single account to AppleOne Family account. The “owner” account is still working fine, but the rest of the family can't open “My Music”… Tomorrow I will call the support, but after reading everything, I am not very confident that they can offer me a solution.

Same problem here. Cannot navigate in ‘my music’ via Sonos. App says ‘Your library is not available right now, please try again later’.

I’m using a new Apple Music account (Apple One Family). Tried and checked everything from the back to the front and back again: Wifi, LAN, network, software updates, iCloud settings, library settings: really EVERYTHING. Been on the phone with Sonos support for 45’ minutes. Been emailing with them. Nothing helped. No solution at all, but the internet is FULL OF COMPLAINTS about this topic. Really frustrating.

SERIOUSLY @Sonos , GET US OUT OF THIS !!

So the implication is that Apple changed something on their side, and are not sending the correct data back to Sonos when requested?

Today (02.06.2022) Apple Music is completely down in the Sonos app, I'm curious if everything will work after that or if the service will be cancelled completely.

Today (02.06.2022) Apple Music is completely down in the Sonos app, I'm curious if everything will work after that or if the service will be cancelled completely.

No need for melodrama.

https://status.sonos.com/

Update (09.06.2022):

🙃😍 It’s working. The first 3-5 days they fixed the problem just the main account showed up and now all family accounts shows up. And I am still in the trail phase. 
 

I had the same issue as well.  In my ecosystem I also have an Android tablet tied to Sonos and decided to try that out.  When I did Sonos app mandated that Apple Music be installed on the Android tablet first then I can add the service.  I was able to install the Apple Music app then finally add into Sonos, all is working now!   If anyone is having the issue, try on your Android device or at least install Apple Music on the Android device first.  If you’re having the issue and don’t have Android, get a cheap one off of Amazon, add, then return it :-)

Reply