Sonos Arc loud pop then audio loss



Show first post

1195 replies

Userlevel 1
Badge

So glad to finally see this get some attention, can’t believe I’m going back 2 years to page 1 when it first happened to me and has done many times since (LG c9 & Xbox SX) 

Cannot be confident it hasn’t damaged the speakers in some way, let’s see how it progresses but really should not be something that takes this long to address, come on Sonos.

Userlevel 3
Badge +2

After several days without any issues, my random loud pop followed by reduced volume is back. I was watching a show on HBO/MAX, it wasn’t even Dolby atmos.

Is this on the new 15.11 update?

Userlevel 1
Badge +3

Just Audio uncompressed. I don’t use Alexa.

😵‍💫 mine is working properly… mmm very strange issue…

Userlevel 4
Badge +3

I’m sorry if I missed this but a few thoughts. 
 

Are those experiencing issues using a wired connection or Boost? 
 

Has anyone not using TruePlay experienced this?

Badge +1

Both gunshot pops (rapid fire) and single pops, mixed and unpredictable. At times it sounded like electrical pop sounds and I did jump to the conclusion that something had blown the Arc speaker(s) until the reset and fantastic sound since. 

Even triggered some Pops while unplugging to try a reboot and accidentally touching the volume buttons on top, so even the interface sounds could generate pops instead of the intended sound. 

I didn’t notice the audio codec but it was popping for anything that we threw at it: both Sonos Radio Rock Pantheon music (and any other stations), Amazon Music, and local CBS television which was likely DD5.1 at that time.

I didn’t know about this and similar threads during the bulk of this, so I can’t say for sure that we threw any ATMOS source at it. But definitely no AppleTV, no Xbox and CEC was turned on (controlling volume up & down with TV remote) and spatial or ATMOS (whichever it is) in the S2 app was also turned on. The former two seem to be getting lots of redirection blame for triggering pops but this was direct HDMI eArc connected to a mid-brand TV. The remedy I’ve read is to turn CEC and spatial/ATMOS off but that seems like a terrible remedy given both are KEY benefits of Arc.

Again, all sounded great for a couple of hours in which I couldn’t run Trueplay due to some uncontrollable environmental noise in the area. After that was silenced, I ran it, expecting Trueplay balancing as I had done several times with another Arc and Move speakers... and that process was immediately followed by Pops (singles and rapid fire). After several restarts, it was the same.

Only sleeping on it and then trying factory reset, setting ARC back up again, linking it with the two 300s again, etc (basically everything I had done the night before EXCEPT running Trueplay) brought back excellent Arc sound with both music and television. Been pounding it all day & evening since yesterday with all kinds of sources included confirmed ATMOS stuff from Amazon app on that TV and not a single pop. Everyone is gushing how great it all sounds (as we all expect from Sonos). 

While it’s terrible to jump to any conclusions on only one instance of any cause & effect, my gut feel is that if I ran Trueplay again right now, the Pops would immediately follow and the whole process would have to be redone again to get back to the great sound I have now. While one should never pass judgment in one instance, those same guts say this problem MIGHT be centered in Trueplay, which in the setup process is something people are told to run. In my case, I bailed on the initial setup process at that point due to some noise I couldn’t control (waiting for silence before running Trueplay). And that led to this potential discovery that may prove to be helpful for others. 

Hopefully, a few with the Pops can recall running Trueplay and opt to give this a try. Resetting to factory is easy, as is setting the reset speaker back up again. When it gets to the Trueplay step, bail on the process and try playing something you know was making it pop before (and play something through AppleTVs and/or Xboxes too). If a few people can confirm this possible remedy, Sonos could dig into the Trueplay programming to find what I suspect could be some selective bugs that basically lead to the pop problem for some of us. 

Some programming bugs makes much more sense (to me anyway) than “turn off ATMOS” or “turn off CEC” for THIS speaker… and it seems doubtful that Apple, Microsoft and select TV manufacturers would ever alter their audio playback hardware or software to “fix” this problem for Sonos if it was really them.

I’ve run Trueplay on my own Sonos stuff several times and never had the problem, so perhaps it’s also linked to select combinations of Sonos speakers? In this case, I had already linked an Arc and two 300s in a single room before running Trueplay. Maybe that’s one of the combinations that can trigger this?

Userlevel 1
Badge

First post - and it’s on this thread because this happened to me tonight for the first time (and it did it three times).

Had the Arc since mid-August with no issues through any source but tonight watching a film on Apple TV (in Dolby Vision and Atmos) had the loud pop a couple of minutes in and then only surround speakers working. Went through setup again and all was fine until it did it again (twice).

Found this thread so I did a power cycle and it ran for over an hour without a problem. I’ve had no issues with other Atmos or Dolby Vision sources and it had been faultless up to this point.

Next time it does it I’ll capture a diagnostic…

 

 

Badge +1

We did have a user many pages back that was affected and had a TV that used Dolby MAT for output. No Xbox or Apple TV had ever been hooked up. 

Again, perhaps I’m onto nothing here (a good scientist would run cause & effect several times to see if- in this case- running Trueplay again now would bring those pops back without changing anything else (I suspect it would)), but we enjoyed the same CBS channel likely playing Dolby 5.1 for stretches of time before I ran Trueplay. So if Dolby MAT is at fault, it would seem Arc should have been popping before Trueplay ran too. Sounded great… right up until I ran Trueplay.

After that, every audio source made it pop, including Sonos own radio stations, which are presumably NOT Dolby MAT, nor even running through the television at all (wouldn’t Sonos radio just direct play on Arc via ethernet connection to router?). I use an Arc in another room for music only- no TV connected at all- and listen to Sonos radio on it frequently (has been trueplayed several times over the years and never had any pops).

And again, since the reset early yesterday, the otherwise exact same setup, cables, TV, etc has been playing near non-stop- including more of those local TV stations- with not a single pop. So if Dolby MAT is at fault, it seems there would have been lots of pops when running stations playing Dolby Digital. What’s different since yesterday? The ONLY thing: Trueplay has not been applied.

Userlevel 1

I was playing on my Xbox when the arc suddenly made an extremely loud pop sound and then lost audio completely. The app wouldn’t let me adjust the volume and Alexa wake up didn’t emit its usual tone. I had to remove the power from the arc and reapply which resumed the audio. I’m concerned that one of the speakers in the arc may have been damaged when this happened. Has anyone had this issue?

We have had no issues with the arc since purchasing it earlier this year.

 

Hi All

 

Unfortunately I’m also experiecing this exact same problem and it appears to be getting more frequent.

  • Arc + 2x One SLs
  • Sony A80J
  • Xbox One Series X
  • Using HDMI cable the Arc came with.

 

First time it happened whilst playing MS Flight Simulator and it was so loud I jumped out of my seat. Then it didn’t happen again for a few weeks, then I found this thread and tried a few things suggested like disabling Dolby Atmos, Auto HDR, but it didn’t make any difference. Also I want Dolby Atmos as thats why I bought the Arc.

Now it pops loudly without fail when playing other games too such as Forza Horizon 5. I have to power cycle to get it back (although i can select music through the app and this plays without need for cycle). So far it doesn’t appear to have degraded the sound but I am worried its only a matter of time.

I have submitted 3 diagnostic reports right after it has happened today - 1286287503, 664679292 & 1164353300.

Can someone please advise what I can do? I don’t see any acknowledgement of the issue from Sonos unless I missed it?

 

Kind regards

 

Chris

 

I’m of the apparently minority opinion that the ‘pop’ is being generated upstream from the Sonos device, and the Sonos device is merely playing what it is handed. That being said, I’ve seen no compelling evidence in particular, other than it appears to be associated with Apple TV and Microsoft XBoxes. 

@Corry P it appears disabling CEC might resolve the issue for most. Does Sonos know why this is happening and can it be fixed? 

 

Thanks 

 

Userlevel 6
Badge +5

Yup LPCM option still there . I been doing some test , when I’m playing final fantasy 16 on VRR which is 48-60hz then no pop at all but when I switch back to god of war Ragnarok running VRR 48-120hz then loud pop occurs . Now we know 120hz is the problem that causing the pop . Just like the Xbox series X

I, and many others, have experienced the pop at 60 Hz on Apple TV. I have also experienced the pop at 60 Hz on Xbox. The Sony 900H has an issue with 120 Hz where it lowers the vertical resolution to 1080, not the only TV model to do this, so I would play at 4K60 with VRR without Dolby Vision. Still pops when enabling Atmos. 

It happen to me couple time and it just happen right now watching Disney+ on Dolby Atmos.. please get this fix with a update or something!

 

Userlevel 2
Badge

Sonos just say something, Please! 

There was a response from Sonos Staff here on this issue…

Presumably there’s nothing further to report at this stage, other than Sonos appear to be aware of other manufacturer brands experiencing the same problem and the matter is being investigated. The suggestion is to ‘perhaps’ switch off Atmos audio, just for the time being, until further information is forthcoming.

Not ideal, but hope that assists for now at least.

 

 

>>>You are brave and doing your job. But Sonos where are you? Must Ken_Girrifhs do what you should be doing.

 

Turn it off? Is that the solution?

I’m going to stop investing anymore in Sonos products and stop recommending them to my friends and family. This issue is easily reproducible by the patterns of hardware described in this thread and only occurs with Sonos products; no other soundbar. Support isn’t a priority for Sonos, which is a shame considering how expensive their products are.

Userlevel 6
Badge +5

Somehow all the other soundbars can handle it.

I am amused that a generative AI can make such a plausible-sounding explanation. Mind you, I can reliably produce the pop on Apple TV screensaver with no audio playing. But that of course doesn’t preclude some control signals still being transmitted.

Badge

Experienced that "pop" for the first time last night playing FIFA23 on my XBox X...An hour later had my second experience... All seemed to be normal after I repowered the ARC

Userlevel 4
Badge +3

Also had my first reoccurrence of this issue last night with a Series X and Sonos Arc with a Sony x900h TV

 

I was watching videos from the Dolby App and as soon as I prematurely closed a video by pressing the back key I got the pop sound, Arc stopped working at that point until reset 

 

Worth noting that the surrounds were still working fine afterwards only the ARC wasn’t.  
 

Obviously I don’t want to do damage to the Arc, so if it is in fact just garbage playing at highest volume I feel a little more at ease, would be nice to see a true diagnosis and a fix though

Userlevel 3
Badge +3

Hi all,

 

To throw my 2¢ in here, as I've read the entire thread after experiencing issues (daily) myself, I'm running a very similar set-up to many of you:

Sony Bravia X90H

Xbox S, Switch, Arc, PS5 (in order of HDMI 1-4 slots)

 

The popping noise has only come about when playing Xbox, and was happening 2-3 times each evening. I opened a ticket with support during the day, and after getting home power cycled the Arc as well as swapping out the HDMI cable (just in case) before submitting a diagnostic.

Support said things looked good on their end, but I imagine what did the trick more so was disabling Auto HDR on the Xbox. After turning that feature off I had no sound disruption at all last night, even after ~4 hours of gaming. I'll post an edit/update if they come back, but compared to the last few weeks that's already a vast improvement. 

One thing I'd like to note is the rep stated I may want to remove all other HDMI devices plugged in to the TV when using the Arc, which was an... interesting suggestion. Not sure I'm willing to use the Arc only when using streaming services via my TV. 

 

Similarly, kinda, is that I changed from 4k50 SDR to 4k50 Dolby Vision in my Apple TV video settings last night.  Made it through The Book of Boba Fett without issue, but will report back if anything *does* happen in the near future.

Mainly because it seems that whilst the Apple TV 4K (2nd Gen) is advertised at supporting DV over AirPlay for Photos, it only seems to work if the video output is DV by default—it won’t “upgrade” SDR to DV when starting an AirPlay stream (as it would everything else).

Whilst I can’t comprehend why video settings would affect audio; AV stuff, tracing all way back to good ol’ RF signals, is a tricky beast.

I won’t claim to be knowledgable enough to know why it seems like so many of these issues are more tied to video output than audio, but it does seem to be the case, doesn’t it? Just theorizing but maybe something to do with how the information translates over the eArc channel? I have no real idea, just spitballing.

 

Tangentially, since my first post I’ve played… a lot of Xbox (new purchase for me and loving Game Pass). I haven’t had any issues at all since turning off Auto HDR. Still curious to know what the real underlying reason is, but given how much I played over the past week I’m ready to consider the problem settled for now.

Made it through another episode of Book of Boba Fett — so testing continues.

Out of curiosity, of those with Apple TV, what is your current video output setting?
Additionally, for those experiencing on Xbox, do you have “Auto HDR” enabled?

I’m of the apparently minority opinion that the ‘pop’ is being generated upstream from the Sonos device, and the Sonos device is merely playing what it is handed. That being said, I’ve seen no compelling evidence in particular, other than it appears to be associated with Apple TV and Microsoft XBoxes. 

 

Happens with my Roku Ultra as well.  It has now happened to me 3 or four times in the last few weeks.  Very annoying and I hope Sonos fixes the issue soon.

 

Userlevel 4
Badge +3

Come on Sonos !!!! This problem existed for years since ARC came out . Fix the damn thing already . I want to enjoy my Resident evil 4 remake with 4k120hz VRR ATMOS without worrying when the loud pop going to occur! 

I haven’t even picked up Resident Evil 4 yet. I do have a set of SteelSeries headphones that likely work better for a game such as Resident Evil though. Either way, I ordered a pair of ERA 300s as I wanted some sort of surrounds but this issue needs to be fixed. It shouldn’t take this long to do so. 

Reply