playbar not powering on, blown regulator TPS54226, Replace does not fix it



I have an sonos playbar which do not power on, i saw this topic:

i checked the mainboard inside and it has the same blown chip as on the photo's on the forum.

So i replaced it, and turn it on again but the same chip blow again.

Do someone know what the problem is?

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

10 replies

In general a burned component has been killed by another component’s failure. You need to replace the killer(s) and its victim(s).


yes i measure at the output of the SMPS 0 ohm between the coil and gnd. There is something shorting. it looks like the whole power rail after the regulator is shorting to ground. So maybe the microprocessor is bad.

Suspect a bad capacitor. However, if the regulator is burnt again, I’d remove it, then check between the rail and ground again.


Yes i thought also, in that case i have to buy a thermal camera to find out where the bad cap is, i could not find a bad cap up to now, because the board have a lot of capacitors.

A careful visual inspection is worth many hours of troubleshooting. I’m not sure that a thermal camera would be helpful because the regulator will likely blow again before anything else heats enough to show on the camera.



All the measurements are done without the regulator ic, i measure short at the output but the vin(input) rail has no short.


i monitored the board under a thermal camera when injecting 1v at the output power rail. 

i saw that no capacitor is heating up. The only thing that heats a little bit up is the cpu.

the cpu is the NXP p1014nsn5hha

I’m on the same boat - blown regulator TPS54226. Have not tried replacing yet.

I’m considering - desolder it, and then try injecting 1V-1.2V on the output to see if something heats up.


okay, let me know what the solution is if you can fix it.

I already gave up.

No solution.

I tried injecting 1V by my lab power supply, it went over 2A, and one of the crystal was heating up, the rest of components were reasonable. After removing the crystal, I was able to push 5A, everything was heating up a little bit, but no a single item.


Gave up too.