Answered

S1/11.6.1/Mac Catalina/MacOS Extended SSD: Can add Music Lib but I see no music listed

  • 22 January 2023
  • 4 replies
  • 28 views

Hi.  I have a pretty old Sonos S1 system with a bridge, which has the latest 11.6.1 software.  Works great with all streaming services.  I have an old iTunes Music Library on a newly formatted Mac OS Extended (Journaled) external hard drive.  I am able to see this library directory when I select to mount a Music Library from the Sonos app, and it tells me it’s pulling my songs in (“SonosMusicLibrary” is now set up on your Sonos system.  Your music is now being added to your Sonos system.  This may take several minutes to complete), but that never happens and I see no songs at all in the Sonos app (running on a MacOS laptop with Catalina, a pretty new iPad or my Android phone).

This is a Music Library directory that I used to have mapped to Sonos before S2 came out, so it was working great at one time.

The original library is very large, so I created another directory with just a few MP3 directories in it and that still does not work.

I submitted Diagnostics 989657620.

Please recommend what I can try next to get my Music Library working.  Thanks

icon

Best answer by Corry P 25 January 2023, 17:26

View original

4 replies

Userlevel 7
Badge +21

Make sure you have SMB version 1 configured on your Mac.

Maybe hook an Ethernet to one of your speakers (not Sub or Surrounds) and pull the power from the Bridge. They can be problematic in their old age, usually the power supply, but seeing the problem is difficult, swapping the Ethernet is the easy test.

Thanks Stanley.  This may be the right track but still not working yet.  I created an nsmb.conf file in my /etc directory and set it to support versions 1, 2 or 3.  I also realized I did not have these folders in my Mac Sharing list so I added them.  When I did that I saw that the SonosMusicLibrary that I set in Sonos had a SonosDMS User in the list (did Sonos put it there by trying to access the folder?), with “Custom” access.  Maybe that’s a good sign, BUT I am still not seeing anything in the Sonos Music Library in the app.

This is my /etc/nsmb.conf file:

[default]

signing_required=no

streams=yes

protocol_vers_map=7

minauth=ntlmv2

I am out of time for today but I next can try and trace SMB actions with come command line stats or something.

Any other suggestions appreciated.  Thanks!

Userlevel 7
Badge +21

No Mac here but this is a snip of my smb.conf, the SMB 1 settings are still there but commented out. Yours seems to also be in a different spot, maybe Apple oddness?

 

pi@pi-3b-2:/etc/samba $ pwd
/etc/samba


pi@pi-3b-2:/etc/samba $ cat smb.conf
#
# Sample configuration file for the Samba suite for Debian GNU/Linux.
#
#
[global]

# enable v1 authentication for Sonos S1 access
#ntlm auth=yes

# enable v2 authentication
min protocol = SMB2
# Do not use, limits S2 to SMB2_10
#protocol = SMB2
[music]                                                                                 
Comment = Pi shared folder                                                              
Path = /mnt/ssd-music                                                                   
Browseable = yes                                                                        
Writeable = Yes                                                                         
only guest = no                                                                         
create mask = 0555                                                                      
directory mask = 0555                                                                   
Public = yes                                                                            
Guest ok = yes 

 

Pulled up my v1 settings from a backup, just use this for global?

[global]

# enable v1 authentication for Sonos S1 access
ntlm auth=yes

 

Userlevel 7
Badge +18

Hi @CapeCodGregH

Welcome to the Sonos Community!

Please try the following steps:

  • Open System Preferences on your Mac.
  • Click on Security > Privacy.
  • Under the Privacy tab, click on Full Disk Access.
  • Check the box next to Sonos Library Server.
  • Open the Sonos app.
  • Update your music library by going to Manage > Update Music Library Now.

I hope this helps.

Reply