Music from my iMac keeps skipping

I have five Sonos speakers and everything worked beautifully until about a month or so ago.  Anytime I want to play any of the music on my iMac hard drive I will get a message that either “music is not encoded properly”, access to music is denied, or if I am able to get something to play it now skips like crazy and is not listenable.  I spent two hours with Sonos tech support rebooting routers, computers, and reconfiguring settings only to get to the point where they will look into it and e-mail me if they come up with a solution.  I reloaded the app and re-indexed the music library and that didn’t fix anything.  BTW, when I play the music from the JRiver software on my computer it has no problems.  Also, when I play music from SiriusXM or Pandora through Sonos there are no problems.

I have over 300GB of music on my computer and would love to have the flexibility to play it wherever I want in my house.  Sonos gave me that flexibility until recently.  I really hope this can be resolved as I have invested a lot of money in this system but I am very close to throwing it all in the trash!  Can you tell I’m very frustrated here?!


Best answer by Jsorbello 12 May 2021, 06:08

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

9 replies

Userlevel 6
Badge +15

Hi @Jsorbello, that does sound very frustrating indeed!

I took a quick look at some recent diagnostics from your system, and it looks like when trying to connect to the music stored on your iMac, Sonos is instead being directed to the routers IP address.

There are also reports of an IP address conflict in the system, with another device (which I wasn’t able to identify I’m afraid) sharing the same IP address as the Bedroom speaker.

I also noticed it looks like you’re using a Netgear router, is this the only router in use, or does it connect via another ISP provided router?

A full network reboot, though you’ve already tried this, should help here (Modem, router, Sonos - all powered off for about 10 seconds before powering back on in order), and it certainly seems that the issue is with the connection from the iMac, to the router, and then to Sonos.

The Netgear router is connected to a Gateway from AT&T.

I rebooted everything yesterday like you had suggested and that didn’t seem to correct the problem.

Userlevel 6
Badge +15

Understood, thanks for trying that. I also noticed that there were no details regarding the controller in the diagnostics, possibly pointing toward a firewall issue - are you using the Sonos app on the iMac?

If so, do you have any firewall software active on the iMac? Would it be possible to test disabling the firewall temporarily, re-indexing the Music Library, and then testing playback?

I turned off the firewalls from Norton and re-indexed.  That may have done the trick!  No skipping!  I ran another diagnostic (1585261738).  Can you look at it when you get a chance to see if the Sonos controller is seen now?

So to follow up, the music is all playing fine now but as soon as i turned the Norton firewall back it had problems so that looks to be the root cause of the problem.  Turned the firewall back off and everything is fine.  My faith in Sonos has been restored!!  Now I need to see if the Norton firewall can be adjusted or if I should just leave it off.


Thanks for all your help!!!!!

Userlevel 6
Badge +15

Hi @Jsorbello, thanks for updating us - the controller information was indeed shown in that diagnostic, looks like we’ve found our culprit!

You can find here our recommended firewall settings for Norton 360 - if you’re using a different version of Norton, or those settings don’t help, then let us know and I’ll check in with the engineers to see if they can give us some clues :)

It looks like a have a newer or older version of Norton than what is described.  I don’t have access to the settings in the upper right corner and I can’t seem to find the described settings under the “Advanced” tab.  I currently have version 8.6.3 of Norton.

[Moderator edit: removed personal information from image]

Userlevel 6
Badge +15

Hi @Jsorbello, understood - if you’re not able to locate the Traffic Rules section anywhere, then it may be worth getting in touch with Norton directly regarding this. 

I did have a look around the internet, and it seems that quite a few people having been having general issues with Norton ignoring/not properly applying some choices, and blocking access to programs that should be allowed. 

Hopefully they will be able to assist you further with this :)

Got it.  I’ll see what I can do.  Thanks again for all your help!!