Question

Moved - Now I cannot add Sonos Devices - Says Login as System Owner... I am!


Userlevel 3

I moved and now I cannot access any of my devices. When I hard reset them to add them it says I have to do a software update but I have to sign in as the system owner. I am the system owner?! This has been a very frustrating experience and based on messaged I have found online no one has an answer. Not sure why such a hefty price tag if the app is so difficult, especially for moving to a new house.


98 replies

Userlevel 2

Did you get anywhere with support? There really needs to be an official acknowledgement of this problem now and an ETA on when we will see a fix. I have four Sonos products all offline at the moment and one which is stuck with the update loop. Lots of users appear impacted and yet there’s been no app rollback and no announcements on their website. 

Userlevel 2

I haven’t even moved house though, just changed WiFi provider requiring a reboot of the speakers but still have this issue.

i can actually add a speaker but as soon as it is added it says “update required” and this is when the loop begins of I try to login but it keeps asking for “owner to login”.

 

called Sonos, current wait time 65 minutes….

Userlevel 1

exactly the same. new app cant do anything as saying i’m not the system owner.  Trying to get any help is a complete waste of time. Current wait time is 105 minutes. Chatbot is a piece of garbage, along with the new app!.   give us a rollback NOW until problems are fixed

Userlevel 1

Same here. You can’t do anything as the software is hidden behind the owner login pop up

Userlevel 1

Exactly the same problem. If there has been an update of the app, it hasn’t cured the log in loop problem for me on IoS.

Just wasted three hours getting nowhere.

Userlevel 1

I also have this problem.  Pop up says I’m not the owner, but there is nowhere to make any changes/updates.  I just bought the Move 2 and disappointed I can’t get it to work.

 

Where are the Sonos people?!

Userlevel 1

I changed Wifi networks and now when I try to use the Sonos it tells me that I need to update, but that I need to login as System Owner.  I am system owner and the devices show up on my profile.

Now I can’t use any of the devices.  This is ridiculous.

Userlevel 1

I had the same issue, also with the iPhone connect issue but I have managed to solve it by using the Sonos Mac OS app. I guess also the Windows app will work. 

Got the system up and running in 5 minutes after 2 hours struggle with the mobile app.

I am having the same problem. It is telling me to log out and have owner sign in. 😡

Userlevel 1

Same problem for me… new app

I am having the same issue - sign in as owner!

Now I’m getting this error too. So many errors. Different one every day it seems. 

Same is happening to me 

Same problem 

Userlevel 1

This is a absolute disgrace. Same problem. Installed a new router today. Had Sonos since 2013 but this is the final straw. Have Beam G2 x 2, Mini Sub x 2, 4 x Era 100 and move 2. Tried the support helpline….75 min wait estimate. New app is also utter sh***. So Angry.

 

Moderator Note: Modified in accordance with the Community Code of Conduct.

Userlevel 2

Same issue. So frustrating.

Hi I have the same problem with Sonos saying I’m not the owner and ask the owner to log in. I am the owner and I’m going round in circles. 
Would you suggest starting again going back to factory settings with a new email ? 

Same issue, not sure what’s going on

I’ve just got off a live chat with Sonos and managed to get my speakers connected after several reset and app install/uninstalls with the same device owner message. Here is what I had to do.

  1. Reset the speaker (it was flashing green when I managed to connect it.)
  2. Open the sonos app
  3. Go to the user account (little person icon, top right)
  4. Click app preferences
  5. Click Reset App (this is what I hadn’t done previously)
  6. App reset and you get the option to add Add speaker or component
  7. Find your speaker
  8. Accept t’s & c’s
  9. Add it to your Wifi
  10. Speaker connected.

That worked!!!

Even after deleting the app multiple times and re-downloading I was having the same result but by resetting the app it seemed to fix the problem.

Userlevel 3

I’m using the new app. 

same issue - tried to get my Moves reconnected to a wifi network, then was asked to update software, then tried to login - then repeatedly received message:  “the system owner must be logged in.  Please log out and have the owner login.”.  I am the owner and using the same email address and password.  just gives me the same message over and over again on app.

 

On line chat was not helpful at all….

 

Sonos or community, please respond ahd support your customers

 

Same problem. Seriously annoying. Can’t use my speakers at all at this point. 

What is going on with Sonos? I had to change my WiFi and now I have thousands of dollars in products useless!!! Fix this now Sonos!!!!

pd: Mac OS app and web app are death too, what is going on with this company?

Same problem. Moved house and wifi provider. Now I can’t set up my Sonos products as “an update is required”, only to be hit with a “sign in as the system owner” error. Stuck in a loop 🫠

Same problem after upgrade to the new version. Not able to add an extra speaker. Asking for an owner account but there is just one account.. What is happening?

Reply