9.0 Version App Keeps Freezing

Userlevel 2
Since updating my controllers to 9.0, the app keeps freezing up on my iOS devices. I have to close the app and stop it from running in the background before starting it up again. It will briefly work again before freezing again. I have deleted the app, shut down my device and reinstalled it. Still have the same issue. Anyone else having the same experience? And will this be fixed?

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

99 replies

done all these things time and time again , on both ipad and iphone , restarted , zones , nas drive , changed wifi channel , it always appears fixed for a short time as a simple closing of the app and re opening it resolves the issue , but the problem always comes back at some point , hopefully the more others post the issue it may get recognized and seen as a bug that was introduced in the latest release
Userlevel 1
Badge +1
If someone does find a solution after speaking to Sonos please post it here (or somewhere). Thanks.
I had the same problem with an Iphone 6 running latest hardware. It started 1 week ago. I realized that also 1 week ago, I had switched my phone to the 5G network on my home wifi. At first, network things were running faster and smoother, but then the Sonos controller started hanging up anytime I left the app and then returned. Since I couldn't easily figure out how to change the Sonos connection to the 5G (that's another issue!), I moved the phone back to the original network. All of my problems disappeared. After more than 1 day, I haven't had a single freeze episode and I've repeatedly jumped in and out of the Sonos app trying simulate a freeze. So far so good. Kind of a simplistic fix if it holds, but maybe of some help to others with similar issues.
I have the same problem. Have submitted a system diagnostic. Hope it helps.
Userlevel 1
Badge +1
Same issue here. Very frustrating.
Userlevel 1
Same issue with 9.0. App freezes when phone sleeps, after switching to a different app then back to Sonos, and while doing something in the app itself without switching or sleeping. Submitted diagnostics: Your confirmation number is: 915440005.
Using iPhone 8 with 209GB available memory.
Userlevel 1
The phone is not switching networks. I have both 2.4GHz and 5GHz from the same router. I have tried using the Sonos app on both and the same this happens. Nothing has changed with my network setup. I have had Sonos devices for years and have never had this issue, not until update 9.0.
Userlevel 7
Badge +20
Hi folks,

If you're having app freezes, please reach out to our phone team who will investigate the issue and escalate your case if needed. You can find our phone number and hours in your region here.
Userlevel 2
Today's 9.1 update seems to have fixed the freezing problems.
I'd been experiencing this issue for a few weeks, so thought I'd post what's seemingly solved it for me...
After upgrading the Android app to version 9.0 / 9.1, it would constantly lock up / freeze, as has been described by many on this thread. I'd either have to forcibly close the app or restart the phone, but upon restarting the app, I'd be faced with the same issue. It was virtually unusable. It's worth noting that the Windows app had no issues throughout.

I started off trying to solve the issue by first shortening the name of the shared Windows folder on my network where my collection of FLAC files live. The share is housed on a Seagate 2TB Backup Plus drive, connected via USB 3.0 to my router (a workaround, until I get around to buying a new NAS).
This was then added as the music library location in the SONOS app, but the issue still persisted.

Next, within my router settings (ASUS RT-AC68U running ASUSWRT-Merlin Firmware) I disabled the 'Airtime Fairness' setting as this has seemed to help other ASUS users.
Unfortunately the issue still persisted for me.

What seems to have stabilised it, is outlined by 'Airgetlam' in the thread above...
I assigned my two Play 1 speakers reserved IP addresses, from my router interface and then powered off both the router and the two speakers.
Once everything was powered back on, the two speakers has been assigned their IPs and I can report that the SONOS app has been working normally for around 4/5 days now.

Hopefully this may assist others having the same problem. Cheers.
Userlevel 7
Badge +20
Diagnostics 849269557

Thanks for sending in the report. I'd recommend uninstalling the app completely from your Android, then downloading it fresh from the app store.

I see a good amount of wireless interference causing communiaction erroprs between your speakers. This could lead to errors which would case the app to crash. Please start by changing the wireless channel your Sonos system is using.

Also, make sure your Bridge is not too close to any third party electronics which could cause interference. Common sources of interference include cordless phone bases, wireless cameras, wireless baby monitors and wireless printers.
Phone tech support is useless, and this Sonos staff keeps on asking us to call support. I started having the same issue last year but ignored it until now. I can replicate this issue almost every time. I have an iPhone Xs Max with the latest IOS and Sonos app, so don't say that I have an old phone blah blah blah. I have a simple plain vanilla setup: playbar+subwoofer+two Sonos play 1 in my living room and one Sonos One in my bedroom.

1. Launch the sonos app on my iphone and start playing some music
2. Minimize the sonos app (and keep it in the background) and then launch another app
3. Try to return to the sonos app and the app freezes but the music is still playing without any issues
4. Manually force the app to close doesn't work and I had to wait the sonos app to restart itself

This thread started like 5+ months ago, and there is still no resolution. Sonos really needs to get their app right before thinking about adding new useless features into it. If the app fundamentally doesn't work as expected, what is the point of all those added features. Get your core right before thinking about something else. Are the programmers at Sonos just amateurs? Do they just have the "get it working" attitude and not bother thinking about optimizing the codes?

Also, the sonos support staff are like typical support just saying "I don't have this kind of issue." Sure you don't. This issue has nothing to do with our home network configuration, not our sonos setup but the buggy sonos application. This issue, like what everyone had said, did not occur back then.

Sonos, do what you're supposed to do and not blaming on us, the customers who already spent thousands of dollars on the system.
The next time you have it freeze, kill it, and restart it, you might submit a system diagnostic . There would likely be data in that diagnostic that might help Sonos help you, and you'd just need to post the number here, or perhaps contact Sonos to discuss it.

Have you attempted rebooting your iOS device before restarting the app? Which version of iOS are you running?
Userlevel 2
Thank you for the reply. Yes, I did reboot my devices before restarting the app. I'm running iOS 11.4.1 on all of my devices.
I will do as you suggest the next time I have a chance. Thanks again.
Userlevel 7
Badge +22
Jo C - If you only submitted the diagnostic it will just set in the queue at Sonos, you have to tell Sonos you submitted it and give them the number it showed you so someone will know to pull it out and look at it. You can Twitter it in, post it here or call it in.
Oh, OK. thanks.
Have submitted another one to get the number.

Your confirmation number is: 1864273813.
Userlevel 7
Badge +22
That should do it, someone from the sonos forum staff should get back to you on that.
Userlevel 2
I have submitted a diagnostics, the number is 1206233040.
HI , same thing is happening for me since the upgrade to 9 , been on to sonos for over a week regarding this , but dont seem to be getting anywhere, they seem to be mentioning inteference and now saying one of my connect boxes doesnt work properly , but it plays music fine, i've trtied everything , restarting all sonos components , re installing the app , but the preblem seems to come back again ,
Just wondering here if the Sonos App is freezing because of a lack of space on the controller device?... it might be worth checking that. Another few things to try are switching off the 'WiFi Assist' feature on iOS and perhaps see what happens when you change the WiFi channel on your router and/or SonosNet in the Sonos App Advanced Settings.

Note the SonosNet WiFi channel and routers 2.4ghz channel are best if they are set at least 5 channels apart. In my case my neighbours seem to use channel 6, so I have set my own router to channel 11 and my SonosNet channel to 1.

See if these things help stop the App from freezing on screen.

Is it a particular model of iPhone, or iPad, perhaps? ...only the app seems to be working fine on my iPhone 6 and the wife's iPad Air v2?

I've only seen a few folk here complain and thought there would be much more complaints about this, if it was a more widespread issue.

Anyhow I hope you find the answer to it soon.
thanks , hope so too , never seen anything like this when using the app until version 9 and my set up hasn't changed in years
so cant believe it is not related to the upgrade, prior to this the app was flawless and never froze / crashed , have you tried it over a period of time , i.e. play a song , click home , browse a web site , come back to sonos , etc , for me it fails pretty quickly each time , ?
I have not noticed it (at all) myself on the iPhone, personally speaking. The wife doesn’t use the Sonos App all that much, to be able to judge it perhaps, but I will try her iPad and see. It doesn’t seem a problem though so far.

I should say that I do turn off lots of stuff on our devices, like location services and notifications, suggestions etc. Also I don’t allow apps to run in the background so maybe I’m not the best person to comment.

I would have thought though that far more users would have commented by now and complained about it freezing... I would have expected dozens of posts from users, rather than just the few we are seeing here so far. In your case the App sounds almost unusable, whereas I’m using it lots, everyday.

That’s why I was wondering if this was down to a particular model of iPhone? I can get access to both an iPhone 5, 7 and 8 in the coming days, when our children pop in to see us and could test those, if any are applicable in this case... the kids phones usually have lots of stuff left running in the background on their devices, so I’m happy to try those and see.
thanks , it would be interesting to see if you can see the issue also , i've never really posted on here before , so i'm wondering if others are experiencing the issue but because a simple close and re open sorts the issue people are just putting up with it , and maybe blaming in on their phone ??
Userlevel 5
Badge +8
Whilst the app on my iPad isn’t freezing, it has been temperamental for the last couple of months. Tonight I went to my ipad and as the Sonos app was still full screen from the last time I used it about 30 minutes ago (Playback was stopped 30 minutes previous by me) I pressed play and the radio station started to play OK.

But then I pressed stop on the app and it didn’t stop the radio station from playing. The stop/play button kept changing as if it was accepting my commands but nothing was happening, the radio station carried on playing. It was definitely set on the right room. I closed and opened the app and then the buttons started working properly again.

On previous occasions recently it has mysteriously changed rooms to another one and the button presses were being carried out for the wrong zone. This time though, the correct zone was selected.

Until a couple of months ago I’ve not had any problems at all with the iPad app (apart from it being worse to use that previous versions 😉 ) but since then it occasionally gets itself in a mess and is unreliable until the app is stopped and started again.

I think all these problems are coinciding with the introduction of the Alexa stuff, it seems less stable that before.