ZenWifi XT8 (1-19-21) Firmware Update Causes Sonos System to Stop Working

  • 24 January 2021
  • 40 replies

Userlevel 1

The most recent Zenwifi firmware update caused all my Sonos products (except MOVE) to stop working.  I had to roll back to previous firmware.  Once I rolled back, everything is working fine.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

40 replies



I posted a similar thread over at XT8 Potential Issue | SmallNetBuilder Forums (snbforums.com).


I did not get total failure of the Sonos, but the Beam kept dropping off the network, wiring it in seems to have fixed the issue.  FYI  The Beam has 2 x One SL as surrounds and was using on of those devices to create the Sonos Network.


All worked perfectly on 25790.


Can you post details of how you rolled back please?  I believe it will be manual process, so some steps especially around order for both nodes would be much appreciated







Userlevel 5
Badge +10

I was having an issue even before the new firmware whereby my XT8 would drop my wired Sonos Boost and as all my units are on SonosNet everything would also drop off the network. Immediately power cycling the Boost would bring the whole system back up. Doing nothing eventually the Boost would re connect and back up would come the rest of the system using their reserved IP addresses. This would happen maybe once a day or every other day. I could understand a WiFi connected device dropping off but not a wired connection.

Its certainly a weird one.  Are you on 25790, and have you done a factory reset the last time you did a firmware upgrade?  Over at SNB if you don’t do a factory reset each firmware change they call it a dirty flash and has caused issues for users.

I’ve rolled back now (did the Node first then the router), issues are gone.

I also had issues with 2 Xbox Ones not allowing access to some online games, going back to 25790 has fixed that issue as well.


Userlevel 1

Minimos it looks like you were able to roll back.  But in case others need help.  Go to https://www.asus.com/us/Networking/ZenWiFi-AX-XT8/HelpDesk_BIOS/ then download the “25790” driver and save it on you computer.  After that: 1) login into your router; 2) go to administration 3) go to the firmware upgrade tab 4) for your router click “upload”, and 5) upload the driver you saved.  If you are rolling back a node, a separate sign in tab may open; log in (like you did your router) and then follow upload prompts.

This is my 1st time giving instructions like this and I’m no computer expert, but this should work if you have had the SONOS issues I did after the last firmware update (i.e. 26044). FYI, its a little frustrating that this issue developed and I’m a bit surprise at ASUS as I have used their routers for the last 10 years without issue(s). I was very frustrated (and a bit worried) trying to troubleshoot the issue.

Userlevel 2

Check if Quality of Service (QoS) feature is enabled in the router. My system started working seamlessly when I disabled QoS feature. With QoS enabled, I couldn’t add a new speaker to the system, couldn’t play music on speakers, speakers keep on dropping, etc.

Userlevel 1

The QoS feature was not enabled and I had the issues.

Userlevel 2

@conceptk - Disappointedly, I later learned that disabling QoS did not fully resolve the connection issues. I also resorted to workaround of connecting one speaker via ethernet cable and the rest started using “SonosNet” network that the hardwired speaker creates.

Userlevel 1

FYI, I’m had the same issues with the 2-1-21 update (i.e. 41793) and had to roll back again.  I hope they fix this soon because I really like some of the new features of this update (e.g. device binding).

I’m waiting for a positive sign before updating the system. 

As an update to this (I’m in a ‘me too’ situation), I updated to the latest firmware (2nd February release) version and this issue is not resolved. The last known good firmware appears to be 41793. I’m running a 3 node mesh.


.26044 messed up my Sonos too.  Rolled back to .25790 and everything is back to normal again.  Like others, waiting for something positive about current or future build (.41793?) before touching anything.

As an update to this (I’m in a ‘me too’ situation), I updated to the latest firmware (2nd February release) version and this issue is not resolved. The last known good firmware appears to be 41793. I’m running a 3 node mesh.


do you mean, 25790 seems to be the last known good firmware?

25790… I clearly can’t cut and paste! Yes, this is the last known good release. Thanks for the correction.

I downgraded my Firmware to 25790, my ZenWiFi Ax connects to the internet but all the wireless devices connect to the ZenWiFi but no internet connection. Can somebody help me?

I would start with unplugging your modem and nodes, and letting them cycle back up in order.  Plug the modem back in first, after it is up and running, start up the XT8 nodes and give them time to cycle up.  

Thanks, I will try it.

Have a friend with XT8 and older Sonos equipment.   He upgraded to .41793 and all was working.  I tried the upgrade to .41793 last night and Sonos once again disappeared.  Rolled back (again) to .25790 and Sonos came back immediately.  Waiting on Asus I guess…

So I guess my big question is why does stuff run on 2.4Ghz?  Don’t tell me you tried to keep the cost down by using 2.4Ghz instead of 5Ghz.  I tried to get stuff running yesterday on the XT8 system.  Had nothing but problems. I downgraded to 25790 and not dice still no connections.  Everything happens except connect to 2.4Ghz.

I went on Asus chat yesterday to let them know of these issues. They opened a case and then sent me instructions to rename the router, change the password to a generic one, run a system log and then send it to them. My system is working under 25790 right now and I am not going down that path. Since you are not have any success maybe reach out to Asus directly - they may be able to help you. 

This was originally confirmed in another post about the XT8 and Qos, but it’s relevant to share here as well.  Firmware version does work after you perform a factory reset.  See below.

“I can confirm what @Naveed.Ahmad originally posted that firmware version does work with my Sonos system after performing a factory reset as outlined HERE. This includes all streaming services and speakers.  I’m WiFi-only and have everything from amps to subs, playbase, beam, move, play 5,3,1’s.  

Thanks, @Naveed.Ahmad for going through the factory reset!”

Followed your steps and all seems to be running now (2 hours in) on 41793. Took a long while for router to find second node after reset but now working. Hopefully for future upgrades we don’t have to set up our network from scratch each time. Will keep you posted. Thanks sean-a-thon!

Just tried it out and it works for me. Will report if it still works after few hours. 

One day and still working well for me!

Hi all

Has anyone else noticed that since upgrading to firmware Version that the SSID “ASUS_C0“ remains available and open for anyone to connect to and use - no password required.

Is this normal? I have tried various factory resets and used both the webGUI and the app to set the network up.

I don’t see that on mine...