ZenWifi XT8 (1-19-21) Firmware Update Causes Sonos System to Stop Working

  • 24 January 2021
  • 40 replies
  • 5667 views


Show first post
This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

40 replies

Just upgraded to 41973 and sonos is working . Having issues with an older play 1 but 6 other speakers all working ok..Sonos network has always been a bit hit or miss no matter what router or mesh I have used 

This was originally confirmed in another post about the XT8 and Qos, but it’s relevant to share here as well.  Firmware version 3.0.0.4.386_41793 does work after you perform a factory reset.  See below.

“I can confirm what @Naveed.Ahmad originally posted that firmware version 3.0.0.4.386_41793 does work with my Sonos system after performing a factory reset as outlined HERE. This includes all streaming services and speakers.  I’m WiFi-only and have everything from amps to subs, playbase, beam, move, play 5,3,1’s.  

Thanks, @Naveed.Ahmad for going through the factory reset!”

 

I’ve got similar problem. Just wanted to make sure: do you mean factory reseting the router or the Sonos system?

factory resetting the router worked for me

@conceptk Thanks for the post. Did the 41793 update and Sonos stopped working. Knew it was the firmware update because that was the ONLY thing that changed in my environment. Glad you posted the steps to revert back! Was about to do factory reset on router… 

Userlevel 1

Allan371, the 41793 update does work with my Sonos system.  Thank you @Naveed for the instructions (see above).  After a downloading the driver and installing it on my router and 2 nodes, I was able to get it to work.  The key is you have to do a factory reset of your router and nodes AFTER you download the driver.

HOWEVER, having to do a factory reset was a BIG pain in the *%$ for me.  I have a smart home with approximately 50 devices on my system (excluding my Sonos System).  Once I did my factory reset I had to redo all my settings and rename all my devices.  This took about 2 hours.  The also is a small problem now with the web router login/interface (but it doesn’t effect anything and the app works fine).  I know ASUS allows you to save your setting, but I was worried importing my saved settings would cause the same issues with my SONOS, so I started from scratch.  I love the coverage of my ZenWifi AX xt8 system so I figure this is what I’ll have to live with for some updates.

Userlevel 2
Badge +3

Anyone, just set up the ZenFi xt8 last night and issues and I understand the firmware issue.

Is it also necessary to have a separate 2.4 only band to connect Sonos to?  I set up a single SmartConnect blended 2.4/5 and I am half convinced instability lies there as much as with the firmware iteration. (My Move latched onto a 5 band, and most of even my S2 system can’t roll with 5.)

I would love feedback on how to use this router with Sonos stability — before I redo it again soon.

I don’t know this particular router, but it sounds like SmartConnect is basically band steering.  Having a single SSID for the two bands is different fro having band steering.  Can you disable the band steering element without separating the SSIDs?  If not, it would be a good idea to try separating the SSIDs.

A better idea in most cases is to get Sonos off your WiFi by wiring a single Sonos device to your router and shifting all the Sonos traffic off WiFi and onto SonosNet.  (Note: the Move cannot join SonosNet, but that doesn’t change the advice.)

I hit the same problem this week after upgrading. I did not have time to factory reset the router (I have a three XT8 Mesh) as the internet is critical nowadays for WFH. I rolled back to firmware 25790 for now as the rollback process is quick and painless. Sonos is working fine now.

I will either wait for a fix or for a “maintenance window” where I have the 2hrs or so I’d need to get everything setup again after a factory reset.  

Hi,

 

This also worked for me. I am using two xt8 in ap mode, and my sonos speakers could get ip, but they were still not reachable by other network clients (although they were reachable from the xt8 node itself).

 

Factory resetting and reconfiguring network from scratch solved everything.

I’d actually chalked all this up to a Sonos problem rather than correlating it with the firmware upgrade on my three-node Asus ZenWifi AX XT8 network, and spent a while faffing around trying to see if binding the Sonos devices to different nodes helped, but then found this thread.

Decided to do a hard factory reset on the mesh wifi nodes before trying the downgrade, and touch wood it looks like it’s resolved all the annoying unreliability issues, but QoS still causes issues if I turn it on. 

This is with a Sonos Five, One, and Roam.

Actually, it looks like I spoke too soon. Still flaking out and getting sporadic Sonos errors.

Anyone had a successful outcome on this one, other than using firmware 25790? I have tried all the ones since and no luck, some of my speakers show up and some don’t.

Did not have this issue with my previous router setup, AX88U with Lyra mesh, all on the latest firmware.

After the latest firmware update _43181 I lost connection with my Sonos system in the S2 app. Tried to follow the built-in wizard to reconnect, but it kept failing when trying to connect to the “Sonos” network. 
 

Same conclusion as Naveed. After connecting one of my speakers (Playbase) to an Ethernet cable from the ASUS router the system reappeared in the S2 app. 
 

Seems to be an issue with the temporary “Sonos” network being rejected by the router. 

Thanks for the response. Here is what I found…

I have a mix of Sonos, Ikea, Ones and Arc/Sub. The Ones are a mix of gen 1 and gen 2. The only way I could get the whole system to come online was using 41793 and wiring one of the gen 1 speakers. As soon as I did this the other gen 1 and gen 2 were online.

I tried upgrading to the latest XT8 firmware but if just says ‘speakers need configuring’ in the Sonos app so reverted back to 41793.

It’s a step in the right direction and points to a Sonos issue IMO. I’ll leave my firmware as it is now as it works!!!

BTW, has anyone tried fixing the issue using a Sonos Boost and latest XT8 firmware?

Hope this helps someone.

I downgraded to 25790 and while Sonos worked perfectly, I started having all sorts of issues with other devices like my Android TV projector as soon as I turned on QoS, which I need due to my 5G network bufferbloat issues.

 

This seems to have fixed it for me with QoS on:

 

Upgrade all three XT8’s to the latest firmware

Go to Asus admin page, Wireless → Professional

Make sure Airtime Fairness is off

Keep Roaming Assistant on, but drop the -70db to -80.

 

This has worked for me, Sonos no longer disconnects. If I turned off Roaming Assistant entirely, everything was fine with Sonos, but as my phone moved around the house it would stay connected to APs with a poor connection rather than reconnecting to the nearby ones.

 

At -70 Sonos kept having issues. At -80 for me, everything is fine.