S1 controller unable to add linkstation NAS with error: Reason: The Computer "SONOSZP80_1TB" cannot be found

  • 2 December 2022
  • 32 replies

Show first post
This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

32 replies

Userlevel 1

Just to reiterate what Corry is saying a 169….. network address gets assigned by the device itself when it cannot reach a DHCP server, this needs to be fixed as in its current state is not fully routable without having the gateway and DNS entries. 


Thanks Belly M.  This could indeed be a routing issue caused by the NAS not being able to obtain a valid IP from the router DHCP server.  But having said that the NAS is on the local network and I’m able to log into it from windows.  S1 controller  also sees the NAS share and allows me to select the relevant share but then encounters the error.  I’m able to ping the NAS and arp also lists it.


C:\Windows\System32>arp -a

Interface: --- 0x9
  Internet Address      Physical Address      Type        00-XX-XX-XX-XX-cc     dynamic       ff-ff-ff-ff-ff-ff     static

The connectivity is as follows 

NAS is connected via ethernet cable to ZP80. Second port from ZP80 is connected via cable to PC.  If the DHCP server on the router is enabled, then, I would be able to bridge the ethernet and Wi Fi adapters. 

Userlevel 7
Badge +18

Hi @lab1301 

Welcome to the Sonos Community!

Unfortunately, if you reply to yourself, your topic is no longer “in need of a reply”.

If I manually add the NAS via IP I get the error:

Reason: The Computer "169.XXX.XXX.28" is not responding


4) Via IP address of NAS the error message is different!


The missing screenshots from above are as below:


An IP address starting with the number 169 is one that a device will assign to itself when it doesn’t get supplied one by the router, as should happen. No device will ever respond when it’s IP starts with that number - it’s not connected.

Why this is happening, I don’t know for sure, but I would assume that the DHCP server on your router has been disabled, or the router is in Bridge mode (which amounts to the same thing). If you don’t know why this is, I recommend you contact your Internet Service Provider for assistance - our ability to assist will be limited, and hampered by our need to connect remotely.

I hope this helps.

all becomes clear… but it’s totally the incorrect way. 

The ZP80 needs to connect to the Router by Ethernet and NOT the PC (NAS can then stay connected to the ZP80) BUT you have said no Ethernet connection available.

You need to know how to create a bridge between the Wi-Fi card and the Ethernet card in the PC.

Userlevel 1

The missing screenshots from above are as below:



Userlevel 7
Badge +18

Hi @lab1301 

NAS is connected via ethernet cable to ZP80. Second port from ZP80 is connected via cable to PC.  If the DHCP server on the router is enabled, then, I would be able to bridge the ethernet and Wi Fi adapters. 

I was about to look at your diagnostics when I saw this.

I agree, in part, with @Belly M - we don’t recommend you connect your NAS to a Sonos device, but it should work without issue (a Sonos device with 2 ethernet ports will act as a switch, in part). However, connecting a Sonos device to a PC via ethernet is a definite no-no.

Rather than create a bridge between WiFi and ethernet on the PC, however, I recommend you simply do not wire Sonos to your PC with an ethernet cable - both Sonos and the NAS should have their own ethernet connections directly (or via a switch) to the router. If, after doing this, you still have access issues, by all means please submit another diagnostic and I’ll take a look for you, but with the current, unsupported configuration, there’s not much point in me doing so - it’s not actually expected to work.

If the NAS stores nothing but music, connecting it to a router-connected Sonos device is acceptable. I still don’t recommend it though. If you have, for example, movies stored there too, please connect it directly to the router.

This does explain why you have a 169 IP address though - the DHCP server on the router has no idea the NAS drive exists. The PC is an effective firewall.

The OP has stated he has no physical access to the Router’s Ethernet ports which is a requirement to get the NAS working correctly.

In the current config the PC would need to be a DHCP server and some form of bridge or network sharing enabled. As it stands the the Wi-Fi card in the PC does not pass anything to the Ethernet NIC. The ZP80 has no means of routing IP back to the NAS but the PC can see the devices on the Ethernet interface due to self assigned IP addressing.

Edit, I have not done any routing on a desktop PC between interfaces for about 25 years. There must have been something configured to enable this before the updates but in all honesty as @Corry P says it’s unsupported.