Answered

Sonos One Not Responding to Alexa Comands

  • 30 October 2017
  • 35 replies
  • 59126 views

Userlevel 2
Badge
Just setup the Sonos One. All steps were followed and setup went smoothly, However it is not responding to any commands. It does acknowledge the command where I ask to play music, but doesn't complete the action.

Diag:8022698
icon

Best answer by UKMedia 31 October 2017, 22:58

Hi Gazzstevens

Can you please try these actions:

- In the Alexa app, select 'Skills' and disable the Sonos Skill;
- In the Alexa app (PC version), select 'Smart Home' then 'Devices';
- Select 'Forget All' at the bottom of the screen;
- In the Sonos app, select 'Settings' and for each of the Sonos 1's remove 'Voice Recognition';
- If you have a Connect, please power down and then switch on and wait for it to boot;
- Power down the two Sonos 1's and then switch them back on and wait for them to boot;
- In the Sonos app, Select 'Manage' and then select 'Add a player or sub' and add the two Sonos 1's again. This will complete the set-up process again;
- In the Alexa app, select 'Skills' and ensure the Sonos skill is enabled, if not please 'Enable';
- In the Alexa app (PC version), select 'Smart Home' then 'Devices'
- Select 'Discover' at the bottom of the screen. Ensure that your Sonos 1's are displayed correctly and not shown as 'Off Line'. Also ensure that there are no devices with the same name (To ensure my Sonos devices are not duplicated, I've added Sonos to the end of each of my players within the Sonos App. Remember, if you want to do this, rename before selecting 'Discover';

Please retest and let me know the result.
View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

35 replies

Alexa is a IT cloud-based service wherefore resetting the Sonos devices to factory settings is pointless.
DO NOT FACTORY RESET! It is not necessary unless instructed by a Sonos rep, and giving this advice to people can cause then to delete all their settings and playlists from their system.
Here are the steps I used to configure a different Amazon / Alexa account for my Sonos speaker. This should work for both iOS and Android.

1. On your Alexa app forget the Sonos skill and delete the Sonos speaker.
Then on your Sonos app go to Advanced Settings and choose Reset Controller. This will disconnect the app from the speaker.
2. Do a factory reset on your Sonos speaker
3. Open your Amazon shopping app and logout of your old Account and login to your new Account.
4. Reopen your Sonos app and setup the "new" speaker. Then when you set up voice services choose Alexa. It should then connect to your new Amazon account.
5. Go to your Alexa app and enable the Sonos skill then search for new devices.

You're done!
Userlevel 7
Badge +20
Yes, sorry that was what I meant. ( https://alexa.amazon.co.uk or https://alexa.amazon.com )
Badge
Hi Gazzstevens

Can you please try these actions:

- In the Alexa app, select 'Skills' and disable the Sonos Skill;
- In the Alexa app (PC version), select 'Smart Home' then 'Devices';
- Select 'Forget All' at the bottom of the screen;
- In the Sonos app, select 'Settings' and for each of the Sonos 1's remove 'Voice Recognition';
- If you have a Connect, please power down and then switch on and wait for it to boot;
- Power down the two Sonos 1's and then switch them back on and wait for them to boot;
- In the Sonos app, Select 'Manage' and then select 'Add a player or sub' and add the two Sonos 1's again. This will complete the set-up process again;
- In the Alexa app, select 'Skills' and ensure the Sonos skill is enabled, if not please 'Enable';
- In the Alexa app (PC version), select 'Smart Home' then 'Devices'
- Select 'Discover' at the bottom of the screen. Ensure that your Sonos 1's are displayed correctly and not shown as 'Off Line'. Also ensure that there are no devices with the same name (To ensure my Sonos devices are not duplicated, I've added Sonos to the end of each of my players within the Sonos App. Remember, if you want to do this, rename before selecting 'Discover';

Please retest and let me know the result.


Attempting to run through this process. Couple of things.
The Alexa PC Version doesn't seem to be available for PC Download. Do i use the Web Browser version instead?

Thanks in advance..
Badge
Just setup the Sonos One. All steps were followed and setup went smoothly, However it is not responding to any commands. It does acknowledge the command where I ask to play music, but doesn't complete the action.

Diag:8022698


Thank you for posting this. I had my Sonos One up and running then Spectrum Cable/Internet delivered a new router and I had to reset everything and for some reason I was unable to get my Sonos One to be on and respond to Alexa. I followed your instructions and now all is good.
And the solution was so simple. On going through the posts I too checked whether the microphone light on my Sonos One was on or not .... and it was not just a matter of touching it to light up and Alexa was back in the business. As somebody else remarked, “ made me feel
like an idiot”.
Userlevel 7
Badge +20
Thank you for that. Totally didn’t realise that the mic was touch button as well...complete blonde moment! ?
Very much appreciated for you prompt reply. X

Your not the first and you won't be the last! (Blond or not!) 🙂
Thank you for that. Totally didn’t realise that the mic was touch button as well...complete blonde moment! ?
Very much appreciated for you prompt reply. X
Userlevel 7
Badge +20
Hi

First the obvious one, sorry! 🙂 Can you just check that the Mic hasn't been turned off by accident, just touch the Mic symbol to toggle back on.
Thanks for the details above. I tried the steps detailed and it worked...for one time ?
After asking Alexa to pause all. When I came back later that day, the mic light was no longer lit and Alexa was not responding again...any further suggestions? TIA
Thanks UK Media! your solution worked.

Happy Holidays
Userlevel 7
Badge +20
One wonders if Amazon isn't fully enthusiastic about supporting their app on Sonos, as it cannibalizes their Echo sales.
I don't think you should view it as a Sonos slight, I suspect it is because Amazon have just released Routines in the Alexa App which whilst it is a great way to reset your Smart Devices, 'Remove All' deletes all actions defined in all Routines.
One wonders if Amazon isn't fully enthusiastic about supporting their app on Sonos, as it cannibalizes their Echo sales.
Userlevel 7
Badge +20
SOMEONE PLEASE PROVIDE INSTRUCTIONS FOR TROUBLESHOOTING ON APPLE DEVICES.

You need to raise this on the Amazon Alexa forum, as it was Amazon that removed the 'Forget All' command from the iOS app.
SOMEONE PLEASE PROVIDE INSTRUCTIONS FOR TROUBLESHOOTING ON APPLE DEVICES.
Badge
Thank you so much, UKMedia. These steps worked perfectly for me!
If your device is having trouble playing iTunes stations, I would submit a diagnostic after the problem happens and post the reference number here. This will allow the Sonos techs to diagnose what is happening.
Thanks jgatie. I assume I need to keep these names distinctly different as mine currently are. In the main it seems to work. Amazon music requests all seem to work fine...im just struggling with Radio. The verbal requests are 'heard' and show in Alexa app...but often its just silence. Think there must be a bug in the system somewhere...
Each Sonos one will have two Smart device names. One is the Sonos name, which will show up on the Sonos app and handles the Sonos functions, the other is the Alexa name, which handles the Alexa functions.
I have attempted the above, however I seem to be getting a very odd result. My Sonos ONE is playing on 'TheKitchen' through Alexa...however weirdly although this name is listed correctly in the Alexa app...there is also 'KitchenOne' which is listed as ONLINE. 'TheKitchen' is not Online. See attached screenshot of both Apps side be side. Any ideas.

(I only have one Sonos One, and one Play:1 called 'Portable')
Userlevel 2
Badge
Additional thing to note. When I was having the issues earlier of not being able to save changes, Alexa was also not playing songs when requested, now it seems to be working...
Userlevel 2
Badge
So, the strangest thing. I have been using alexa website all the time. However this time when I went there and I selected country it put the postcode box underneath the country, instead of at the bottom, however the main thing, it saved the changes this time, so time and weather are both working. Who knows....

Thanks for the support
Userlevel 7
Badge +26
Have you tried going into the Amazon website to change the country location instead? alexa.amazon.co.uk would be the site for the UK.
Userlevel 7
Badge +20
You may need to factory reset it it re add.