Question

Sonos One not playing TuneIn Radio

  • 28 October 2017
  • 31 replies
  • 9866 views

I’ve got the Sonos One all set up but it won’t play radio stations via TuneIn.

Alexa acknowledges the request stating “Playing TuneIn xxxxx radio” but then doesn’t play anything. I’ve disabled and re-enabled the Sonos skill in the Alexa App but still doesn’t work.

Any suggestions?

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

31 replies

Userlevel 3
Badge +4
This happens a lot with my Sonos Ones. Sometimes I can get the radio sound to come out by saying, Alexa discover my devices, or by telling it to increase the volume, or by issuing the command again several times. Other times even shouting at it and throwing books or anything at it makes no difference. Although, often after all this if I go and sit in another, darkened room the radio sound will start coming out of the Sonos One. Just to wind me up more!
Badge
This is the current thread for this:

https://en.community.sonos.com/amazon-alexa-and-sonos-229102/tunein-radio-stations-won-t-play-6802976/index1.html#post16209657
Same problem. Limited to radio as Spotify/Amazon worked.
Problem was app-related, limitations of Sonos hardware interoperability with Alexa
Fixed as follows.
1. Factory reset on Sonos One
2. Delete Alexa app from phone and any other app
3. Reboot phone
3. Reboot Sonos
4. Complete set-up via 'phone using Sonos app only.

Voice control perfectly, Sonos app controls device seamlessly- problem coming from "app confusion"
Alexa app not re-installed, Alexa works flawlessly. But you cannot add 'skills' so basic Alexa - pretty poor for price charged -but you get a voice controlled Sonos music player.
Check the Smart devices in your Alexa app. Make sure there are no duplicates. If there are, name them something unique. See other troubleshooting tips here:

https://sonos.custhelp.com/app/answers/detail/a_id/4345
Thanks for the reply.

There definitely no duplicates and it’s all set up as in the troubleshooting tips. Alexa acknowledges the request and says playing the radio station, just nothing comes out.
Userlevel 4
Badge +8
I have a similar issue. Have a read of this thread

https://en.community.sonos.com/amazon-alexa-and-sonos-229102/public-beta-my-feedback-6792177/index1.html#post16155062

Cheers
Userlevel 7
Badge +26
That discover devices trick should do it. If that fails, I'd suggest removing the voice control from the system temporarily and then adding it back in. You go to Sonos Settings and toggle off Voice Control. Then disable and re-enable the Alexa app. Then back on in Sonos. Finally, discover again.

If that's giving you trouble, or this keeps coming up, I'd suggest giving us a call on our support line.
Userlevel 3
Badge +4
Today it took 4 attempts to get sound to come out of the Sonos Ones when asking it to Play Radio Four. Here is the diagnostic while it was saying it was playing: 8033823. When this happens there is no difficulty getting the Sonos One to play tracks from Amazon Music so there doesn't seem to be anything wrong with the way the Sonos One is set up.

I hope Sonos can get to the bottom of this soon.
Userlevel 3
Badge +4
Just to add, here is what the Sonos Windows app shows when it says it's playing Radio 4 but isn't.
Userlevel 7
Badge +20
Are you able to select radio via the Sonos app okay?
Userlevel 3
Badge +4
Yes, plays without any problems when done from the Sonos app.
Userlevel 7
Badge +20
Hi Try following these steps I suggested in a previous post:

https://en.community.sonos.com/amazon-alexa-and-sonos-229102/sonos-one-not-responding-to-alexa-comands-6793239
Userlevel 3
Badge +4
Hi Try following these steps I suggested in a previous post:

https://en.community.sonos.com/amazon-alexa-and-sonos-229102/sonos-one-not-responding-to-alexa-comands-6793239

Thanks, but I had to go through these steps 4 times with my 3 Sonos Ones to get them to work at all in the first place. I really haven't the time to jump through these hoops again, and I doubt if it would make any difference.
Userlevel 7
Badge +20
Mine are all working great if you follow these steps.
Userlevel 3
Badge +4
Mine are all working great if you follow these steps.
OK, I suppose it's worth a final try. Might also finally convince them I'm in UK and not Seattle.
Userlevel 7
Badge +20
Might be worth unplugging 2 of your play 1's and getting one to work first. 🙂 One final thing to check; are you using the same email address for Sonos and Amazon accounts?
Userlevel 3
Badge +4
Might be worth unplugging 2 of your play 1's and getting one to work first. 🙂 One final thing to check; are you using the same email address for Sonos and Amazon accounts?
I tried it again, setting up one of the Sonos Ones and then the other two (which are in a stereo pair). Unfortunately, no difference. Still takes more than 20 seconds for Radio 2 or 4 to play - in some cases it takes so long I have to ask several times after waiting for more than 40 seconds. And they still think I'm in Seattle. I've got a ticket with Sonos support on the latter and they want me to phone, so will try that, but I'm not hopeful they can do anything else.
Userlevel 7
Badge +20
That's weird 😞
Exactly the same problem. Works with Spotify but not via Alexa yet (when?). Alexa confirms instruction for raisin stations and after 20-40 secs will connect on some occasions but usually then cuts out after 1-2 minutes. I’m reluctant to buy a second Sonos One until this is sorte. I”ll try the earlier suggested actions.
I'm struggling with the same issue right now. I'll try the above hints and report back if it's works or not.
Badge
Hi Try following these steps I suggested in a previous post:

https://en.community.sonos.com/amazon-alexa-and-sonos-229102/sonos-one-not-responding-to-alexa-comands-6793239


The issue is back after sonos app and firmware update.
Userlevel 7
Badge +20
Hi tunafanatic

The default position when this happens is to disable the Sonos skill and then re-Enable again from within the Alexa app>Skills - Can you retest after you've done that? (I had this issue every time an update was sent out in the Private beta but since general release it's not re-occurred.) Might be worth submitting a diag as well.
Badge
Hi tunafanatic

The default position when this happens is to disable the Sonos skill and then re-Enable again from within the Alexa app>Skills - Can you retest after you've done that? (I had this issue every time an update was sent out in the Private beta but since general release it's not re-occurred.) Might be worth submitting a diag as well.


Retested it. Disabled the skill forget the device and redo everything.

Tunein started playing 40 secs later just when i am giving up. Tried switching to another tunein channel and it took a long time to play. Not sure if this the tunein issue or what, coz echo dots plays almost instantly.
Userlevel 7
Badge +20
Have you tried booting your router and when it online, powering off your Sonos 1 for 10 secs and then powering back on?
Badge
Have you tried booting your router and when it online, powering off your Sonos 1 for 10 secs and then powering back on?

yes i did but this is only the short term workaround. It seems like the sonos goes to sleep mode or something.

I usually gets home at 9pm and ask alexa to play some stations on the sonos1. Alexa acknowledges it but nothing happens. I then would get sonos to play the tunein from the sonos controller as a workaround. The next time round, stations switching via alexa will work. The first command to alexa usually dont work.