Have to ask twice to play Spotify music



Show first post

86 replies

Badge

This has recently happened for us (SONOS One G1, Alexa, Spotify).

I ask for something like, “Alexa, play Yellow Submarine”,

Alexa replies “Yellow Submarine Remastered 2009 by The Beatles on Spotify” but then silence.

If I repeat the command, I get the same response but the music starts.

I have had this problem the whole summer, it appeared right after that other Sonos-GA bug that the Sonos unit was suddenly not aware of its room anymore, (ref. this thread). As with that bug, I was hoping this issue also would eventually go away with an SW update, which it has not. 

Below is my situation which has lasted some months now:

When issuing a voice command (GA) to Sonos in any room I have the following situation:

  • If SONOS is playing or has recently played via voice command (GA): No problem.
  • If SONOS is playing or has recently played from Spotify Connect: No problem.
  • If SONOS is playing or has recently played from its native app: I will have to ask twice. The first time it will confirm the command, but nothing will happen. The second time it will work. (asking again will always work)
    • This is so predictable that I have grown accustomed to just issue the command twice in a go, which sounds really stupid. 
    • The song will go on to play without fail after the second time, subsequent commands will work as expected.

Now, you Paul A speaks of “stream limit” (the link within that thread is broken, Paul), my issue is not whilst Spotify is streaming anywhere else outside of Sonos, and as I have stated: The error also occurs while Spotify is not streaming anywhere at all. If idle-streams are accounted for in this “limit”, I would reply that Sonos is an expert on multi-room system which by its very nature should be able to handle one service (Spotify) throughout its whole system (my Sonos multi-room setup).

Thank you! 

Userlevel 1
Badge +1

I have the same issue. After playing Spotify through the Sonos app, I then have to try twice to get it to play via Alexa or Spotify Connect: https://en.community.sonos.com/music-services-and-sources-228994/playing-spotify-through-the-sonos-app-causes-issues-for-alexa-and-spotify-connect-6847787

Userlevel 6
Badge +17

Hi @godkatt.

Thanks for the detailed and immediate response.

 I would like to recommend contacting our technical support team for further troubleshooting so they can take a look at what might be causing these issues.

Please let us know if you still have further questions or concerns. We are always here to help.

Thanks,

Userlevel 6
Badge +17

Hi @jamie72.

Welcome to the Sonos community and thanks for bringing this to our attention and for trying to do perform the basic troubleshooting steps and researching here in the community to find answers. I understand where you’re coming from especially if we have tried some possible tips and tricks but nothing helped.

Allow me to recommend the following guides and please do follow accordingly.

  1. Log out of ALL Amazon-related apps which are and not limited to the following. (Amazon Prime, Amazon Shopping, Amazon Alexa, etc.) 
  2. Open the Amazon Alexa app and disable the Sonos Skill.
  3. De-register any Sonos product on the Alexa App.
  4. Open the Sonos App.
  5. Remove the Alexa Voice service.
  6. Force close Sonos app.
  7. Force close the Alexa App.
  8. Reopen the Sonos App. Add Alexa as a voice service.
  9. Open Alexa app Add Sonos as skill
  10. Register Sonos speaker
  11. Add music service.
  12. Test to check if it works.
  13. Submit a diagnostic to capture all information performed on the Sonos devices.

Please let me know how it goes. We are always here to help.

Thanks,

Userlevel 1
Badge +1

Hi @jamie72.

Welcome to the Sonos community and thanks for bringing this to our attention and for trying to do perform the basic troubleshooting steps and researching here in the community to find answers. I understand where you’re coming from especially if we have tried some possible tips and tricks but nothing helped.

Allow me to recommend the following guides and please do follow accordingly.

  1. Log out of ALL Amazon-related apps which are and not limited to the following. (Amazon Prime, Amazon Shopping, Amazon Alexa, etc.) 
  2. Open the Amazon Alexa app and disable the Sonos Skill.
  3. De-register any Sonos product on the Alexa App.
  4. Open the Sonos App.
  5. Remove the Alexa Voice service.
  6. Force close Sonos app.
  7. Force close the Alexa App.
  8. Reopen the Sonos App. Add Alexa as a voice service.
  9. Open Alexa app Add Sonos as skill
  10. Register Sonos speaker
  11. Add music service.
  12. Test to check if it works.
  13. Submit a diagnostic to capture all information performed on the Sonos devices.

Please let me know how it goes. We are always here to help.

Thanks,

 

Thanks @Paul A.

Followed these steps. But still getting the same issue.

Diagnostic is 396863185.

Userlevel 6
Badge +17

Hi @jamie72.

Thanks for submitting a diagnostic and for your immediate response.

The diagnostic submitted shows your Sonos Beam ( Living Room ) shows no active Voice added which means Amazon Alexa has not been activated on the Sonos Beam. Aside from that detail, everything seems normal. I would recommend contacting our technical support team so they can further investigate what is going on and may also check via a screen sharing session (with your permission) what may be causing the issue.

Please let us know how it goes. We are always here to help.

Thanks,

Badge

I’m suffering from this issue as well. It’s clearly a big with the new Sonos app because I had no issues before updating to that. 
 

Userlevel 1
Badge +1

I have the exact same issue as described by godkatt. 

 

Very good description mate. 

Userlevel 1
Badge +1

If someone were to look in this forum for this issue he would have found a lot of the same posts with the same behavior. 

Userlevel 6
Badge +17

Hi @03397 and @Rascal23 .

Welcome to the Sonos community and thanks for reaching out to us. I understand it can be quite annoying to have to repeat a command twice which gives the indication that there might be a problem. I would like to help you out with that.

Allow me to recommend the following guides and please do follow accordingly.

  • Log out of ALL Amazon-related apps which are and not limited to the following. (Amazon Prime, Amazon Shopping, Amazon Alexa, etc.) 
  • Open the Amazon Alexa app and disable the Sonos Skill.
  • De-register any Sonos product on the Alexa App.
  • Open the Sonos App.
  • Remove the Alexa Voice service.
  • Force close Sonos app.
  • Force close the Alexa App.
  • Reopen the Sonos App. Add Alexa as a voice service.
  • Open Alexa app Add Sonos as skill
  • Register Sonos speaker
  • Add music service.
  • Test to check if it works.
  • Submit a diagnostic to capture all information performed on the Sonos devices.

Please let me know how it goes. We are always here to help.

Thanks,

Userlevel 1
Badge +1

 @Paul A 

I followed your exact instructions. After finishing, I tried again and I was lucky!! The problem was there from the first and I did not have to try to replicate this

Diagnostics sent 1370901664

Userlevel 6
Badge +17

Hi @03397.

Thanks for the update and immediate response and for submitting a diagnostic.

Based on the submitted diagnostic, Sonos detected multiple routers with the same Wifi name. The Sonos One has also recorded multiple connection failures to the internet. I would like to suggest contacting our technical support team so they can provide more in-depth troubleshooting steps and also take a look within your network what would be the best and shortest router in connecting Sonos to the internet and they can also check if these routers were configured accordingly. This topic discusses multiple routers and what needs to be done for them to work with Sonos seamlessly.

Please let us know how it goes. We are always here to help.

Thanks,

 

Userlevel 1
Badge +1

@Paul A 

Thanks Paul.

I just want to let you know that the  multiple routers seen with the same wifi name at the different wifi repeaters that have the exact same wifi name as the initial wifi. I also, have connected the Sonos with an ethernet cable bypassing the wifi and the problem is still there. 

 

In addition, the multiple connection failures should be when i did not have any internet because of the router restart. 

 

But To be sure can you please tell me the exact date/time that this connection failures occurred so I can cross-reference these with my router restart?

 

 

 

 

Userlevel 6
Badge +17

Hi @03397.

Thanks for your immediate response.

Here are some logs of your Sonos devices that showed failures to communicate with the internet which is also an indication of failing to communicate with the Sonos Server, Amazon Server, and the music services Server.

 

  • 21 seconds before the diagnostic was submitted.
  • 35 seconds before the diagnostic was submitted.
  • 53 mins and 9 seconds before the diagnostic was submitted.
  • 54 mins and 30 seconds before the diagnostic was submitted.
  • ! hour and 35 minutes before the diagnostic was submitted.
  • 2 hours and 6 minutes before the diagnostic was submitted.
  • 11 hours and 7 minutes before the diagnostic was submitted.

I would also like to add, at the time the diagnostic was submitted, there is no indication that the Sonos device has an ethernet means of connection.

Please let us know if you still have further questions or concerns. We are always here to help.

Thanks,

Userlevel 1
Badge +1

@Paul A 

Thanks for the info.

This is very weird since I not have any issue with my Sonos apart from that. If there were disconnections I would have interruptions during the playing of the music. 

 

In addition, I did not say that during the diagnostic the device was connected with ethernet, I did say that I have replicated the issue even when Sonos was connected to ethernet. 

 

I also have tried a different adsl router. The problem is the same. 

Userlevel 6
Badge +17

Hi @03397.

Thanks for the update and immediate response.

I would suggest submitting a diagnostic after 3-5 minutes of the issue happening, then please take note of the confirmation number and contact our technical support team for a more in-depth troubleshooting step and a thorough investigation on what seems to be happening.

Please let us know how it goes. We are always here to help.

Thanks,

Userlevel 1
Badge +1

@Paul A 

Just to add more to the posts here and I suggest in replicating that in your lab.

If I start the playlist on Spotify from Sonos app then music starts fine.

Then I pause this and I use Alexa to start music. It fails and Sonos goes to idle.

 

If Sonos is in idle then music can start successfully every time from Alexa.

 

Can someone confirm this if this is the same.for every one?

Userlevel 1
Badge +1

@03397 Exact same behaviour I get. I was advised to call support, but haven’t had chance yet.

 

I also get a similar issue if I try and play to my Sonos speakers using the Spotify app. So if I play Spotify from the Sonos app (works fine), pause and then try and connect to a speaker from the Spotify app the connection immediately drops out. If I try and connect from the Spotify app whilst Sonos is idle it works fine. Do you get that same behaviour as well?

Userlevel 1
Badge +1

@jamie72 

Yes I am.

Any solution? Have you contacted Sonos technical support?

Userlevel 1
Badge +1

@jamie72

Yes I am.

Any solution? Have you contacted Sonos technical support?

No I’ve not contacted them yet. Not found any solution yet myself either.

Userlevel 2

I have this exact same issue, any help would be great.

 

I am also experiencing this same issue.

@Paul A  Are Sonos working on this?

I get the same problem here with the scenario of after playing music from new Sonos app using Spotify. As I tell google assistant to play a song it will reply ok play that song but nothing happened. I check the Spotify app that song will show on the now playing song but didn’t start playing. Please check the problem and fix the app which is very annoying. Thank you. @Paul A 

Userlevel 6
Badge +17

 Hi @Tony W..

Welcome to the Sonos community and thanks for reaching out to us. I understand it can really be annoying that it shows it is playing something but no audio is coming out of your Sonos. Let me help you out with that.

I would like to recommend my suggested troubleshooting steps above which I quoted below and please follow accordingly.

 

Hi @03397 and @Rascal23 .

Welcome to the Sonos community and thanks for reaching out to us. I understand it can be quite annoying to have to repeat a command twice which gives the indication that there might be a problem. I would like to help you out with that.

 

Allow me to recommend the following guides and please do follow accordingly.

  • Log out of ALL Amazon-related apps which are and not limited to the following. (Amazon Prime, Amazon Shopping, Amazon Alexa, etc.) 
  • Open the Amazon Alexa app and disable the Sonos Skill.
  • De-register any Sonos product on the Alexa App.
  • Open the Sonos App.
  • Remove the Alexa Voice service.
  • Force close Sonos app.
  • Force close the Alexa App.
  • Reopen the Sonos App. Add Alexa as a voice service.
  • Open Alexa app Add Sonos as skill
  • Register Sonos speaker
  • Add music service.
  • Test to check if it works.
  • Submit a diagnostic to capture all information performed on the Sonos devices.

Please let me know how it goes. We are always here to help.

Thanks,

Please let me know how it goes. We are always here to help.

Thanks,

I have the same problem with GA. Currently in contact with support. They do not seem to have a decent solution . Getting pretty tired of doing troubleshooting for weeks with the support who has no idea what's going on.

/P

Reply