Amazon Dot and Play 5 line in going quiet when replying from Alexa

  • 5 October 2017
  • 72 replies
  • 15227 views


Show first post
This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

72 replies

It drives me nuts that Sonos engineers refer to the audio jack on the Amazon Echo as a "Line In". It is no such thing. It is a audio line OUT - meaning the Echo is the source of audio and instead of audio playing through it's built-in speaker, it goes OUT to whatever speaker is attached to the LINE OUT!
Any update on this, it is making some of my Alexas unusable and as you never know which one is going to answer it is a real pain!
I know I make this sound easy, but why can't there be a tick-box setting somewhere that simply says "Hear Alexa responses from this speaker" which when selected would stop the ducking on the Alexa response part (i.e.after it has finished listening, which would still be ducked).
this is THE MOST annoying feature. i disabled the skill. excuse me, it's not a feature - it's a DEAL BREAKER!!!
Userlevel 2
Badge +5
This issue is so annoying it making the skill useless so I disable the skill, what genius think this is the way it should work ? Have they test this thing with users in home with multiple echo devices and everyone using Elexa in different room listen to different musics then we all go ducking when anyone say Alexa ...

Hello real genius I say -:)
I went mental today in the garden listen to my music then my kids start using Elexa and ducking stop ducking play play ducking arggg hahah
Any updates on Echo Dot responses played thru aux ca le line in and Alexa skills ena led for every Sonos on the network? This is 3 months old. I just got a Dot, and using a hardwired connection disables the Alexa response. Would like to have full voice control of streaming music as well as Alexa responses over the Play5.
Can a room association/pairing between Sonos and Alexa be set up? I have a Sonos device named ‘Kitchen’ and an Alexa device also named ’Kitchen’. When I speak the wake-word I only want an associated Sonos player to duck - not every player. Along the same lines when I ask Alexa to play music I’d like it to assume I mean on the paired Sonos device unless I specify otherwise (but guessing this one at least is an Amazon issue?)
I have the same issue and have submitted a query and am awaiting a response
Userlevel 2
Yes, same here. I have Dot hooked up via line-in to Sonos Connect. I thought playing music sets the the Connect to receive stream from Sonos and away from line in: audio component - but when I ask it a question, it returns to audio component but still no sound. So a bit more complicated...
I have exactly the same issue and pretty much rendered my Echo dot useless as I simply can't hear it anymore. I can't understand why this even changed with the latest Sonos update. I really have an issue if this isn't fixed soon especially as there is no way to downgrade Sonos to the previous version from what I understand.

I have been looking at hooking a pre-amp between the Echo dot line out and the Sonos Connect but I'm not sure if this would solve the issue...
Same problem here
Can someone from the Sonos support please confirm that this is a recognised issue that is being worked on? Thanks!
There's no need to use the analog connection anymore for Dot.
Userlevel 2
Badge
There's no need to use the analog connection anymore for Dot.
I don’t get home till tomorrow so have not tried this out but not sure this is correct. What if you want to play Audible for instance?
So just to be clear if I was to remove the line out/in connection I currently have setup with my Sonos Connect will all voice commands still be played via Sonos? I understand it's fine for playing music but what about any question I throw at Alexa? Will it then still be delivered through Sonos or the tiny internal Echo dot speakers (which is something I don't want)? As I have my Echo Dot build into the kitchen wall it's not something I can easily try out 🙂
Userlevel 3
Badge +1
As Stephen G says, by removing my P5 from the Alexa skill I have regained the volume of the dot through the P5 and also regained control over my Spotify account through the Dot . I can once again play Spotify through Sonos controlled by the dot , if I could control my music collection stored on my NAS then that would be perfect !
Badge
Oh wow! I just spent over 20 minutes with Sonos support (who claimed no knowledge of the problem and told me to call Amazon) and 45 minutes with Amazon support (who had me switch echo dots and audio cables and then credited me for $5 and had me buy an Amazon branded audio cable (arriving Sunday) and they will call me back on Monday to continue troubleshooting!

Both Sonos and Amazon Alexa support need to update their support staff with this info pronto.
Badge
BTW, thank you Stephen G! That's a great workaround!
Userlevel 2
Hmmm...well my echo dot (hard-line in to P:connect) ducked and stayed ducked, even after I rebooted it. I have now disabled Alexa skill and everything back to normal. Once Spotify is added, I'll re-enable and disconnect the dot so it can be Alexa voice. Though it would be good if all Alexa sound could go through sonos, I get that it's not that simple...

Good luck with development, Sonos, this could be great.
Userlevel 6
Badge +8
Wow! I have a Dot connected to one of my Play:5s and two dots connected to two Connects. I am not happy about them ducking.
Badge
Something else I'm noticing. My DOT sits only 2 feet away from a Play:5 because they were physically connected to each other by the audio cable. Even so the DOT didn't have too much trouble hearing me when music was playing. When I used the wake word the blue ring would light up and the music would duck.I could then make my request and Alexa wouod respond.

Now that I have removed the audio cable tethering the DOT to the Play:5 the DOT seems to have trouble hearing the wake word. It's blue ring doesn't light and the music doesn't duck. If I speak quiet loudly then some other Echo device in another room usually responds instead. I guess I'll try moving the DOT further away from the speakers tomorrow to see if that helps.
Ryan, thank you for your response. Like others, I have a Dot hardwired to a Play 5 and ran into the same problem with Alexa's responses. I'm happy Sonos is aware so I'm confident a solution will be coming. It's not the cheapest solution, but if I replaced the Dot with a new Sonos One and didn't hardwire it to the Play 5, would Alexa's response from the Sonos One also be muted? (I'm aways justifying buying audio equipment I don't really need!)
I experienced the same, even though I've moved the now unconnected Dot to a seemingly better position in the room.
Thanks Ryan, I was being a little facetious, I hope you can work out a solution soon! BTW, love the Sonos system!
Thanks Ryan for explaining the "ducking" process. I too have noticed that the volume drops momentarily on ALL Sonos speakers in the house when a command is issued to the Echo Dot (in my kitchen). I agree with mwiseman that this might be an irritation to those listening to music on a Sonos speaker at the other end of the house . As I wrote in an earlier post, I have connected my Echo Dot to the line-in of a Play-5 in my Kitchen. When the Play-5 was registered in the Alexa app as a Smart Home device, the Alexa responses were inaudible on the Play-5. By "forgetting" the Play-5 speaker in the Alexa app, audibility is restored (and I can still issue commands to Alexa to play music in other Sonos "rooms" in the house. HOWEVER, somehow, without my prompting, Alexa has rediscovered the Play-5 in the Kitchen and Alexa responses have become inaudible again. So I have decided to disable the Sonos skill in the Alexa app and will watch with interest as the Sonos/Alexa is refined and developed.

I too have this problem and have to get Alexa to 'forget device' on a daily basis for the sound to work. It simply finds the Play:5 and adds it into it's device list.
Userlevel 2
Badge +3
Many thanks to @Stephen G for the workaround of removing recalcitrant Sonos speaker from the skill setup as I too had connected an Echo Dot to the line-in of a Play-5 in my Kitchen - seems a popular setup! :)

Perhaps Community Manager @Ryan S could amend the 'Best Answer' to include Stephen G's workaround although if @Tangochile is correct and Alexa keeps adding it back then maybe the best thing is to remove the long awaited and keenly anticipated Sonos Skill until it better integrates. :(

As others have said the 'naming' conflicts are also a frustration and the ability to 'link' Dot with specific Sonos speaker without cable and without the need to specify which room to play music unless asking for a room other than the one you're in or asking for a system wide play would also be great.

Feeling ever so slightly underwhelmed by this iteration of Sonos skill. :?