Amazon Dot and Play 5 line in going quiet when replying from Alexa

  • 5 October 2017
  • 72 replies
  • 15226 views

Userlevel 2
Badge
I have an Amazon Dot connected to my play5 using the line in option.

Until today Alexa speech volume and the music volume were fine. I have now updated my speakers, but now I can hardly hear Alexa speaking. (Weather reports etc)

If I ask her to play music the volume is fine. I have set the line in volume to 10 for the speaker in the options, but this makes no difference. Anyone else having this issue.?

Thanks
Marc

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

72 replies

Userlevel 7
Badge +26
Hi guys, I can speak to what you're experiencing. It's part of a feature that's called "ducking". What this means is that when you say Alexa, the audio playing on all Sonos and Alexa devices "ducks" down, or lowers, so that the microphones can properly hear you. If you have the Alexa skill enabled for Sonos, the players will all do this when you issue a command.

The problem you're running into is that the line-in on the player is ducking too. So Alexa is responding appropriately, out to the line-in, to a player that has the audio "ducked", so you can barely hear it.

This is an interesting situation since everything is technically working exactly as it's supposed to.

There isn't a way to prevent the "ducking" at the moment, but we've heard this from others and I'm making sure to spread the feedback on to the team for you.

For now, there are 2 ways to go:
1. Disable the Alexa skill for Sonos, your player will be working the way it was before the update.
2. Disconnect the line in from the Dot, and you'll have the responses for your Alexa commands playing out of the Dot itself, and not over the line in.
Hi Ryan,

many thanks for your reply. Unfortunately for now I had to disable the Sonos skill and I can confirm it is indeed working as before. I really do hope this is something the team will address though.
Userlevel 6
Badge +8
I understand why ducking was implemented. The current implementation is lacking. I'm listening to a Sonos at one end of my house and my wife asks an Alexa on the far end of the house and my Sonos ducks. We are so far apart I can't hear my wife. If I had not read about ducking I still be wondering why the volume on Sonos was going up and down.
Userlevel 1
I had same issue and I removed the Play 5 from the list of Alexa SMART HOME devices (found in the Alexa app). This restored the Alexa voice to its normal volume. Obviously, it means that I can't ask Alexa to play music in the Kitchen (the Sonos name for the room where the Play 5 is located) but Alexa accepts requests to play music in the other Sonos rooms. It is still possible to ask Alexa to play music etc on the Echo Dot which is connected to the Play 5 speaker as I could before this latest update from Sonos/Amazon.
Userlevel 7
Badge +26
I can't speak to the testing specifically, but there's definitely a lot that would have gone into the decision. For instance, if the line-in on your PLAY:5 was any other device, like a record player, you'd probably want this volume drop to happen so that the Alexa in the room can hear your command properly, and you the response.

From the PLAY:5's perspective, since it doesn't know what's connected to the line-in, something is connected to the line-in and playing.

The skill and integration is going to improve. It's still in beta right now, and we'll continue to work on it even after it's no longer in beta.
Let me add my support for a change in this area... Ducking devices in the room that the Echo is in, is fine; ducking all the registered devices when someone talks to Alexa, is not. We have a fair number of Sonos' around the house and we're starting to roll out Dots in the major rooms as well, so "Global Ducking" would very quickly lead to all-out war!

If I were formulating the change request on this, I would allow for an Echo to be paired with a selected Sonos device and to take its name. For example, we have a Dot in the kitchen and the Sonos for the room is called "Kitchen", so we've had to name the Dot "Kitchen Dot". When someone speaks to that Echo, the pairing would indicate which Sonos to duck and avoid ducking the others. The name pairing also means that user confusion would be reduced when using the message or drop-in function... (We currently have to "drop in on the kitchen dot" 😞 )
Userlevel 7
Badge +26
I'm intrigued to see that the question is marked as answered - only a work around has been given, this is like going to the doctor with an arm which is falling off, to be told that "it's ok, you can just use the other one".
In this case "Answered" is just a way of getting the confirmation of the problem in an easily visible place. The flag isn't calling the problem solved, just putting confirmation and a workaround up there. We're still looking into it on our side, the state of the thread itself doesn't relate to our status internally.
I hope the desired outcome is clear for the eng team?
Whether Dot is physically plugged into a Sonos System (pre-skill, this is why Sonos users bought just a dot, we have the speakers set up in every room alreadyt) in a room OR wirelessly integrated (via the new skill, BETA....), the desired behavior is to have ALL audio output (music streaming and Alexa answers) from the Dot come through the Sonos system IN THAT ROOM (and only in that room).

That means no ducking in other rooms (nicely labeled 'Global Ducking' above - the only edge scenario I could imagine where that's useful would be to use the Dot in one room to make a house-wide 'PA' style announcement 🙂 )
It also means no ducking for non-music output in the current room.
And of course no one wants to have to repeat the name of the room one is in all the time.

Conclusion: Sonos 'zones' and Alexa ‘room’ concepts have to be aware of each other (and unless you want to implement some magic, users will have to pair them up manually).
Net result: Talking to the Kitchen Dot affects the Kitchen Sonos like it should and leaves the other Sonos zones alone.

Coupling things just via the name seems a bit fragile. For Hue lights, Alexa seems to have imported the Hue-side definitions - a bit kludgy but maybe there is a path similar to that to teach the systems about each other if there is no clean way.

Previously, the line out wire physically connected one Dot to one Sonos speaker, now that has to be done in software.
Piping that input to speakers other than the one in the same room would still be done via Zones...
I think more importantly than enabling or disabling for most people if the sticking only happened to the Sonos in the group that the Amazon echo is assigned this would resolve most people's issues with the speaker being ducked down when an activating command is issued in a different room to the Sonos
Userlevel 2
Badge
The Dot speaker is not very good, so having it play via the play5 is a great improvement for weather, new flashes, etc.
Userlevel 3
Badge +1
Ryan thank you for the explanation this seems to be something that Sonos/Amazon could ,and should have sorted out from the start? Is it unreasonable to assume that at some point the technicians must have hooked a speaker and an echo or a dot up like this and got the same results ? And yet they didn't think it a problem ?
Userlevel 3
Badge +1
Ryan I understand that improvement will happen and skills will be refined and updated ,it just seems that a basic problem that affects users expectations of the new system has been overlooked . By reverting back to my original set up and taking out the Alexa skill, I now get a better user experience with Sonos and an Amazon dot than the new update gives me, that's hardly a step forward .
Userlevel 1
Thanks Ryan for explaining the "ducking" process. I too have noticed that the volume drops momentarily on ALL Sonos speakers in the house when a command is issued to the Echo Dot (in my kitchen). I agree with mwiseman that this might be an irritation to those listening to music on a Sonos speaker at the other end of the house . As I wrote in an earlier post, I have connected my Echo Dot to the line-in of a Play-5 in my Kitchen. When the Play-5 was registered in the Alexa app as a Smart Home device, the Alexa responses were inaudible on the Play-5. By "forgetting" the Play-5 speaker in the Alexa app, audibility is restored (and I can still issue commands to Alexa to play music in other Sonos "rooms" in the house. HOWEVER, somehow, without my prompting, Alexa has rediscovered the Play-5 in the Kitchen and Alexa responses have become inaudible again. So I have decided to disable the Sonos skill in the Alexa app and will watch with interest as the Sonos/Alexa is refined and developed.
Started happening to me today after installing Sonos One. Must be related to the required software update. How has this not been solved 21 days later? And the Sonos One installation is terribly complicated and doesn't support Spotify. WTF
I can see where there would be confusion, technically speaking, if you had the P:5 (or whatever) setup with a Dot as a line source, and your P:5 was setup as a speaker in Alexa. It would make sense to chose one method or the other.

I suppose if you really want Alexa to speak through your P:5 and only use the music sources Amazon likes, then the direction connection is the way to go. If you only want the P:5 to play music and use the music sources Sonos likes, then use the new integration.
Userlevel 1
Badge +1
Same problems. In fact, my volume was going up and down a lot, and seemingly randomly. My use case for the line in is that Alexa doesn’t use the Sonos as an external speaker without the line in. We play Jeopardy on the dot, for example, and I’ve enjoyed using the sonos speaker for that. After all, the dot can use external speakers and Bluetooth speakers. But this was just weird.
Badge
Wait -- so if someone in an upstairs bedroom asks their local echo device for the time, then the sonos surround sound setup playing a movie for someone else in the living room will 'duck' for a bit?

Really?
Badge
Yep. My solution was to disconnect the hard-line between the DOT and the Play:5. Everything is working beautifully now that I have done this. I don't mind non-music requests being answered on the Echo's internal speaker, but the DOT speaker is pretty poor. I previously had switched out an original Echo with a DOT so that I could use the line-out to the Play:5. I'll probably switch that back to the standard Echo now that I don't need the line-out and because the built-in speaker is so much better.
Userlevel 7
Badge +26
Oh wow! I just spent over 20 minutes with Sonos support (who claimed no knowledge of the problem and told me to call Amazon) and 45 minutes with Amazon support (who had me switch echo dots and audio cables and then credited me for $5 and had me buy an Amazon branded audio cable (arriving Sunday) and they will call me back on Monday to continue troubleshooting!

Both Sonos and Amazon Alexa support need to update their support staff with this info pronto.

I've let the technician you spoke with know about this one. It's actually a pretty unusual issue to come up, partially because everything is technically working as it should. There are just a few dots to connect to understand what's happening. My apologies for the runaround.
Userlevel 7
Badge +26
Sonos One will function almost exactly like your Dot does right now in those regards. The music playing on that speaker would duck, and it would play whatever audio response, the request you asked of it would have, at normal volume.
Userlevel 3
Badge +1
Well I have given up on it ! Removed the Alexa skill all together and have gone back to a line in from the dot to a P5 in each room, it's not perfect but it works for me. I get voice control over selection of music from Spotify account in my zones, once again I can walk into a room and ask for the artist/track/Genre of music and it plays . Would love to have library integration of my music collection from my NAS, but this seems to be beyond the capabilities of both Sonos or Amazon, the cynic in me says this will never be a feature because Amazon will want to sale it's streaming service as the premier service on Sonos. I suspect that Spotify integration will be a long drawn out affair and ultimately be an unsatisfactory service when it does arrive. I can see Sonos being bought out by Amazon in the future and that will be a sad day .
I experienced the same, even though I've moved the now unconnected Dot to a seemingly better position in the room.

It is by design. Sonos "ducks" the volume so Alexa can hear.
Another one with the problem here! I got an Echo Dot as I could connect it to the Sonos system and not need the more expensive Echo, but as I can only use Spotify through the Dot, if I want to start it from the Dot, it needs to be wired to get any decent sound. It appear that what is needed is a greater set up for the Sonos skill, asking if the Dot is wired to a Sonos station, and which Sonos stations should duck if Alexa is woken. It seems that ducking is not perfect either, as if I have a long weather forecast or news report, then the music cuts back in before it is finished. Hopefully these problems, which I would not consider too tricky, will be sorted soon 😉 I'm intrigued to see that the question is marked as answered - only a work around has been given, this is like going to the doctor with an arm which is falling off, to be told that "it's ok, you can just use the other one".
I just enabled this new skill today and am generally very pleased with the features. The ducking issue is a disappointment. I suggest giving users the ability to disable ducking. My Dots don't really have much trouble hearing me with the music up anyway. I'd be very happy with the ducking feature disabled as a user choice, or just gone if making it optional isn't as easy as I assume it is.
Just adding that I too have had the problem. Hopefully it'll be fixed soon in a fix/update but in the meantime I've disabled the Skill.