Answered

2 Issues with Alexa and Sonos, Can you help?

  • 4 October 2017
  • 33 replies
  • 16162 views

Userlevel 1
Hi,
I was able to set up my connection with Alexa and Sonos, and I can use Alexa to start playing music without any issues.
However, once the music starts, I have two issues: 1. I cannot stop the music. 2. the music stops playing after a single song.

For example, if I say "Alexa, play the Beatles in the living room", music will start up on the Sonos system. However, if I ask her to stop the music ("Alexa, stop the music in the living room," "Alexa, pause the music in the living room"), she dims the sound of the Sonos speakers, responds with "I can change the playback mode only when music is playing" and then raises the volume of the living room again.

When first requested to play music, Alexa responds with something like, "Shuffling popular songs by the Beatles in the Living Room." However, she stops playing after a single song, every time, no matter what the playlist. If I play the same playlist through the sonos app, it keeps playing.

I'm not sure what the issue is, since clearly she is connected (she can start playing music) but then she seems to forget that she is playing music, thus disabling the ability to stop music playback or continue listening past a single song.

In case it is helpful, here is a bit about the setup:
Alexa device is an Echo Dot, connected to Wifi
Sonos Living Room speakers include: Playbar, Sub, and 2 Play 1 speakers, connected to the Sonos Bridge wireless network.
No Echo devices are linked via line in to any Sonos devices.

I would appreciate some help in getting these two issues resolved. After waiting so long for Alexa integration, it's sad to see it launched but not really working. Thanks in advance for any constructive help you may have to offer.
icon

Best answer by MusicListenerSonos 4 October 2017, 23:04

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

33 replies

I was successful disabling the Sonos Skill in the Alexa software, and then ehabling it again. These are two of the weakest clunkiest pieces of software I have ever used.
I finally figured out my issue yesterday. The issue was that I have multiple echos in my house and they were on 2 separate Amazon accounts. Even though I only set up the Sonos skill on the echo dot that is linked to one of my Amazon accounts, apparently there is still a conflict within the Echo/Sonos software environment that causes the music to stop at one song. Once I reset my Echo Dot and removed the 2nd account and put the Echo on the other Amazon account (where both Echos were now on the same account that I added the Sonos skill), the voice service is working exactly the way it was intended to. Hopefully, this helps somebody else out there.
Badge
I had exactly the same issues, and contacted SONOS support, The diagnostics showed some anomalies with my ethernet connection. I played around with it, and my Alexa functionality is now nearly perfect.

Basically, I had a wired ethernet connection into my Player speaker from my router, I also had an ethernet cable running OUT of the Playbar into my Sky TV box - I was effectively using the Playbar as a hub. I unplugged the OUT cable so my Sky box wasn't using the ethernet run through he Playbar. Instantly, all was working with Alexa and Sonos (except my bedroom Play 1, which worked fine after a power down cycle). When I plugged the Sky box back into the ethernet on the Playbar, there was no detrimental effect on the Alexa/Sonos functionality.

Very happy camper now. Hope this might help some of the others.
Thank you for your advice. Unfortunately, it did not work for me. I did however set up Alexa with my father in laws home today with his Sonos system and Alexa Voice worked perfectly with his system. At least I know it's not me 🙂.
lloyd21...useful suggestion, but can you control the echo after it starts playing on the Sonos...I find it will start, but generally will ignore all further commands.
Having exactly the same issues— Amazon says it is a known problem so wondering what Sonos and Amazon are doing. No reply from update but 2 from Amazon—is it because it is Beta. Need to get it sorted whatever the issue!
Badge
been having exact same problems as above. Came back to it a few days later after being initially frustrated. Its fixed for me and this is how:

1. You can not have any 2 devices the same name. I had office sonos and echo dot named same. Renamed to Office Dot in alexa app.
2. Forget the sonos office device.
3. reboot the dot.
4. rescan the devices in alexa and get office sonos back.
5. Alexa play 'song' from 'artist' in 'NAME OF YOUR SONOS'.
6. alexa says playing....above and it starts playing
7. tested by leaving out office and it plays on the dot I am speaking to
8. add in office and it starts on the sonos

hope this helps.
I am having as much trouble as everybody else..tried to repower all the speakers, reset all the devices in the Alexa App..My issue is that I can get it to work but like others, it can only play 1 track at a time. Is this working for anybody? Using 2 Play 3's in my office with an original Echo. I know this is a "public beta" but this is very unusable at this point in time.
Good Suggestion jgatie....have submitted Diagnostic and will see what happens..thanks
I would submit a diagnostic and then post your issues and the reference number to the beta feedback page here:

https://sonos.custhelp.com/app/beta
I tried all the above with limited success. I only currently have a PLAY:1 with plans to expand when integration is rather more reliable.

My single Sonos links just fine to an echo dot, and I can ask Alexa to play a track or the radio...in 'the Kitchen' in my case....this starts playback...and then the echo fails to respond to ANY further commands. No blue lights... It has only twice accepted a further command...but usually the only way of stopping a track is manually on the Sonos itself. The echo will then respond once again. Seems to be a bug somewhere... I also want to know if you can set the echo to play on 'kitchen' by default...if you leave out the word it then plays on the tiny echo dot speaker. Seems a pain to have to constantly add kitchen to every command. ..any further ideas welcome.
Ok update from me - it works! I had to combine two of the suggestions from above to make it happen.

First, I renamed all of the Echos in the house to make sure they aren't named the same thing (cwintermeyer posted his comment above). Basically I put "Echo" in front of each Echo device (e.g. "Echo Kitchen", "Echo Bedroom", etc.). Next I "forgot" each Sonos device in the Alexa app; then immediately disabled the Sonos skill. I then re-enabled the Sonos skill and rediscovered all of the Sonos devices. Once I did this, most of the Sonos devices worked, just with this one renaming change alone but one Sonos Play 1 had to be unplugged and plugged back in. For this one device, after unplugging it, I "forgot" this device within the App, then rediscovered it (actually all of them) again. With this sequence it fixed this one Sonos device. The other Sonos devices which are paired to create a surround sound system worked right away after the re-naming.

Bottom line, it was a bit of trial-and-error but everything works, which is fantastic! This will seriously make my wife happy as she thinks Sonos is difficult to control (still can't believe she thinks this, but whatever).

One thing I did catch was the volume on a couple of the Sonos players. I had asked Alexa to play music on each of them and I thought it wasn't working but it turns out the volume was just super low. So before you think it's not working you may want to open your Sonos controller on your phone, ipad or other device to see if the player is actually playing music but just at a low volume. You can then adjust the volume on the controller. Next time you call for music on the player, it should default to the last volume used. IMO, Sonos should make the default Level 2 or 3 volume when first requesting music so you have this issue.

Hope this helps others, and nice work Sonos!
Thanks for the post Ryan S. but I have twelve devices in my home, some of them paired together to make surround sound systems. Powering them off, then back on again is not only time consuming but I run the risk of having to re-pair them again (I've spent hours on the phone with Sonos tech support on this very topic). Basically it's not worth it with a hit-or-miss result. Hopefully it works for others though.
Userlevel 7
Badge +26
I have some suggestions as well. If you're having trouble where Alexa can play one song, then it stops playing after that track is finished. These are some great steps to start with:

  1. Power off all Sonos Players (you may only need to power off the Player that was targeted for playback, so if you have a bunch of players, maybe just start with the one.)
  2. Disable and then re-enable the Sonos Skill in the Alexa App.
  3. Power on the Player(s).
  4. After the Player(s) are powered back on they MAY need to be re-discovered in the Alexa app if they do not show up.
  5. Attempt to playback the tracks and see if it continues to play after the first track.
Badge
I've tried this. I've renamed all the Echo Dot devices so there is no conflict with the Sonos speakers or Hue lights. Now the only device I have called 'Kitchen' is my Sonos Play 1, but the issue still persists. I did forget all the devices and rediscover after renaming them.
Userlevel 2
Badge +3
My experience has improved after renaming everything [Echo, Sonos, and other devices] so there's no conflicts and every name is a single word. I've also found that Alexa is more reliable with Sonos if you add "music" to some of the commands - "Alexa pause music on Basement"
I had the same problem. It turns out both the "Echo Device" and the "Sonos Device" were both named the same thing. I've got 3 Echos in the house, and I renamed all of them with "Echo" appended to the front of the name, ("Echo Living Room"). Then forget all devices, and rediscover. Works like a champ now.
Badge
Same issue for me. I've tried the 'fix' suggested. When I ask Alexa to 'Play some Pink Floyd in the living room', the Sonos speakers kick in just fine, but only plays one song then stops. If I ask to skip track/next song or whatever I just get 'I am only able to change the playback mode when music is playing' - it IS playing - I can hear it!

This happens on all the speakers in my house (one player and six Play 1). I'm using Amazon Music Unlimited as the

Diagnostic submitted under reference 7918595.
I'm having all sorts of trouble with this as well and agree it doesn't seem to be public beta quality.
Sure did notice the word "beta" but it's really an "alpha" at this point. If people are having so many issues, it should be a "closed beta." And, with a major software release like this, one where they are actually promoting a new product to the broad community with this integrated technology (Sonos Play 1), the app should mostly work.
Silver/Wakey,

Did you happen to notice the word “beta” when you activated the Alexa Sonos skill?
Userlevel 1
Unfortunately it is laughably bad. At first it would not play anything, then seemed to start working. But when I say play Queen in Living Room, it just plays the last song open on the Sonos App. It says it does not recognise the kitchen (even though it is working in Sonos App and showing in Alexa). Alexa generally I have found to be buggy useless crap, which half the time does not recognise your command. Sonos should go with Google instead.
I was so excited about this upgrade but unfortunately this skill is a piece of garbage. I'm having the exact same issue and tried all of the suggestions within this thread except for one, which is to power down all of my devices. I have 12 devices in various rooms and it would take me forever to power down each one and get it back online. I can't imagine SONOS requires this anyway. Hopefully they'll get this fixed soon as I would like to continue recommending their products.
Badge
I actually encountered this same problem, but approached the solution differently. My Sonos Playbar is named "Living Room" and the Echo in my living room was also named "Living Room". I renamed my Echo to "Living Room Echo" and the problem of controlling playback on the Sonos disappeared.
Having the exact same problem here. Only playing one song and then stopping. Have tried unpluging all devices and forgetting in Alexa app/disabling skill. No luck. Hope it gets figured out soon.