ZP100 not booting

Show first post
This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

197 replies

Userlevel 2
use 'internet information services' to setup a pc to host web site- google it there are plenty of site to explain how to set this up. Its also easier the rename the file as a .txt file to download it.
Userlevel 2
Thx, I'll do that.
Userlevel 2
Assuming I get the buspirate connector, how do you get into the zp100? What console app do I run to get into terminal?
Userlevel 2
Can I get some detail on bus pirate kit? What kind of cable/pin need to insert into the 4 UART ports?

Would something like this work?
Userlevel 2
it looks like it should work but I brought a slightly different version:

I use hyper terminal to access it
Userlevel 2
OK...I think I understand but I want to confirm my understanding along with more questions

  • System will be booted, but IP Address cannot be acquired due to diagnostic firmware.
  • Unit will have default IP address of Can get to it via http: to see the system log
  • But cannot change or upload firmware via HTTP. Must use UART adaptor to access as console [list]
  • use the 4-pin UART port on motherboard
  • get a UART TTL interface, prefer buspirate. This basically provide console interface using USB port on PC
  • Connect UART card to USB on PC
  • UART will emulate a COM port. Run Hyper Terminal to access through the COM port

  • download the latest firmware. Save on local computer
  • rename the file to .txt for easy upload
  • set up pc as file server.
  • upload the firmware from file server
    1. once I have access via HT, I will have remote shell like other linux shell?
    2. I can run some command to download the firmware from the file server? it's it wget? or the 'grabupdate' script?
  • Userlevel 2
    Got the Silicon Lab CP210x USB to UART bridge. Supposedly work the same as Bus Pirate.
    got the pin to map as below:

    Driver install and COM4 is enable in my PC.

    Launch Hyper Terminal and set COM4 to as follow 38400/8/None/1/Hardware

    Then connect. Hyper Terminal show sucessful connection status.
    The ZP100 is on. Can access via default

    But I'm staring at blank screen on Hyper Terminal.
    What should I see if everything work? Is there some command to send/received between Hyper Terminal and ZP100?

    Also tried telnet. Got Rincon login screen. But obviously can't get in since no root passwd.
    Userlevel 2
    My experience with the console has been through Linux, so I can't speak to any windows specific issues. First things first, just try hitting enter in the hyperterm window, IIRC the ZP doesn't send anything automatically when you plug in the UART. If you still don't get a command prompt power cycle the ZP100 while the UART is connected. When the ZP powers on it should send a bunch of stuff to the terminal about the bootloader, if you see that (and it doesn't look like gibberish) your connection setting are are correct, otherwise check to make sure you have a good connection to the UART header.
    I picked up a bus pirate but this is my first experience with it and I'm having trouble getting anything out of it. I'm not sure if the connections and settings are correct. Can someone confirm the steps and connections from the bus pirate?

    Thank you for all the help so far...
    Userlevel 2
    @tbearrows: PMed
    Userlevel 2
    At the OS level, the UART device is detect and enable. But nothing show up when connecting through either cu on linux or Hyper Terminal on Window.

    Its hard to get the pin to snuggly fit onto the port. Seem like the port a bit bigger than the standard IC chip pin, like this one: https://c1.staticflickr.com/3/2774/4149942841_209b609977.jpg

    What kind of connector are you using?
    had to get my post up to 5

    Userlevel 2
    I used to be able to get to the default But that appears to be broken as well. Can't ping it either.
    Probably as result of twiddling with UART hearder/ports that may short something else. Now the ZP100 is a brick.
    Userlevel 2
    Firstly might be worth checking the upgrade log files, this should tell you what version of firmware is loaded. Others on this forum have commented its only diag software that will allow you to access via the uart port to enable you to upgrade the software.
    Userlevel 2
    @soyuppy, I'd be suprised if you managed to brick it from the UART connector. I know the one I learned on took waay more abuse (including hooking the UART up to RS232 voltage) without dying. Have you tried unplugging the UART and rebooting the device? It's possible that your UART connection is shorting something. When you reboot the device, take a look at the lights on the ethernet ports. If they flash when you plug in the power the board is (probably) not fried.

    I'm just using this sort of cable http://amzn.com/B00A6SOGC4 .

    My exprience has been on linux: use minicom to attach to your ttyUSB device and setting up the speed and flow control settings there (check out http://www.wiki.xilinx.com/Setup+a+Serial+Console for a rough explanation).
    Userlevel 2

    I connected my ZP100 (with white blinking led) to a bus pirate (v2, SparkFun with cable) as follows:

    On the ZP100 there is a J1000 port with pins 1 to 4 numbered. Connect:
    Pin 1: white
    Pin 2: brown
    Pin 3: orange
    Pin 4: black

    Then use PuTTY (windows) and connect to Serial COM3 with speed 115200.
    Use the following options
    m (switch mode)
    3 (UART)
    7 (38400 speed)
    1 (8, NONE bits/parity)
    1 (stop bits)
    1 (idle 1 receive polarity)
    2 (3.3V)
    (1) (UART bridge)

    I then got:
    Rincon boot loader version 0.16-11080(ZP) (32M SDRAM). Press 'h' for help.
    SDRAM test...
    Memory test iteration 0
    Memory test fail @ 8C4F25D4 - D90A7081 != D91A7081
    SDRAM test complete
    SDRAM test failed, autoboot aborted

    After pressing 'h':
    > h
    Rincon boot loader version 0.16-11080(ZP) (32M SDRAM). Press 'h' for help.
    h - help
    m - SDRAM test
    i - print NAND device ID
    n - NAND device scan
    x - NAND device destructive test
    y - NAND device dump first page
    p - Program NAND device
    b - Boot the Linux kernel from NAND device
    d - Boot diagnostics from NAND device

    After pressing 'b':
    > NAND ID is EC:75
    32M NAND flash (Samsung K9F5608U0C) detected
    Section 0 is provisionally good, kernel on partition 1, generation 7
    Section 1 is provisionally good, kernel on partition 4, generation 6
    Attempting to boot kernel from partition 1

    And hurray! The zoneplayer booted and showed up the Sonos controller! I then could update the firmware.

    I'm now going to attempt to replace the memory chip.
    Userlevel 2
    thanks for the word of encourage. I tried most of things that you suggest. Yes, when reconnecting the power, the ether port LED flash. And when connection cat-5 and link it up with PC, LED on ether port lit up. But since I can't see anything from UART console or ping/http to default IP address, it was just frustration that lead me to say that I brick it.

    I'm not giving up on it yet. The key now is to get it up with UART console. Will try it again when I get bus pirate card.

    Thanks for all the info. The cable that you show from Amazon, does it fit into the port snuggly?
    Userlevel 2
    Firstly might be worth checking the upgrade log files, this should tell you what version of firmware is loaded. Others on this forum have commented its only diag software that will allow you to access via the uart port to enable you to upgrade the software.

    This is what the log shows:

    Upgrade url is-F --sonosid 109XXXXXX --householdid HHID_xxxxxxxxxxxxxxx^3.2-29243 URL is®=1&serial=000EXXXXXXXXX&sonosid=109XXXXXX&
    Userlevel 2
    @soyuppy, not especially snugly, but the pins are close enough to the right size that I can hang the buspirate off the side of the ZP and get a good connection, I am pretty sure that you could solder the connector in if you wanted a better guarantee.

    @sdekock I have a unit that has a similar issue (fails RAM test from cold boot, but succeeds later), my non electrical engineer guess is that there is a bad solder joint on one of the RAM chips that works once the board warms up.
    Userlevel 2
    Following @sdekock instruction.
    Stuck at the UART> prompt in putty
    amber led show up on the bus pirate card. If I wiggle the pin, the led flash back and forth.
    But still nothing showing on putty.
    Userlevel 2
    @soyuppy, have you entered UART bridge mode? You need to type the command "(2)" and then hit "y" to enter bridge mode.
    Userlevel 2

    Yes, you need to type (1) to enter bridge mode (my post was incorrect, edited):
    It will show you this:

    UART bridge
    Reset to exit
    Are you sure? y

    On the Bus Pirate 2 red lights are illuminated, the amber led turns on when I turn on the Sonos unit.
    Userlevel 1
    I just ordered a BusPirate and cables. I have 2 ZP100 waiting for salvation. I hate to ask this in public but where can I get Boot loader 0.16-11080? I'd PM someone but I am so new to this forum, and need 5 posts to PM. :rolleyes:

    Thanks in advance.
    Userlevel 2
    I also have two zp100's in same state. Where did you order BusPirate and cables?

    Userlevel 1
    Sparkfun, also bought the ic hooks with pig tails to grab on to p1000 ports holes on the PCB.