Sonos, Unifi, VLANs, and RSTP still not working

  • 13 November 2022
  • 2 replies
  • 1216 views

I started using Ubiquiti Unifi Network Products (1xRouter, 1xSwitch, 2xAccess Points) in my Environment for Security reasons the Sonos Products were moved to a separate VLAN (IoT), since then I have problems controlling the Equipment.

My Sonos system is working well and reliably in a VLAN (IoT) when the Controller (Android or Windows) is one the same LAN (IoT).

When I move my controller devices to the Main LAN, then for the most of the time the Sonos cannot be controlled from the main LAN via Android or Windows. It works one some devices and not on others.

At the moment I am controling the speakers with temporarily moving to IOT network to control SONOS, but that will get old quick. I shouldn’t have to redo my entire firewall config, and risk security, just to make these devices work.

 

There are some strange Problems when the controller is on the Main LAN, see below:

  1. It works on:

-Android OnePlus 10 device (latest versions of Android and Controller App)

  1. It does NOT work on:

-Android Google Pixel 7 Pro device (latest versions of Android and Controller App)

-Android Sony XPERIA device (latest versions of Android and Controller App)

-Windows OS 10 PCs

-Amazon Fire HD 10th gen


I am trying to get this to work for at least 12-Months and I can still NOT control my Sonos speakers. I wanted to buy additional speakers, but will ditch Sonos completely if I don’t get this solved. I have an IT background and have good understanding how the Network works.

 

Any assistance, and time saving, SONOS can provide would be GREATLY appreciated.

 

 

 

 

Additional Info bellow:

 

My Sonos (5 spkrs) system consists of:

-Playbar (Gen 1 )

-Sonos Move

-Sonos One (Gen 2)

-Sonos Ikea Symfonisk (Gen 1)

-Sonos Ikea Symfonisk (Gen 1)

 

The Network Matrix can be seen here:

NW Matrix

I am aware of the Sonos Problems with RSTP and studied and tried everything described in the bellowed threads:

https://en.community.sonos.com/advanced-setups-229000/sonos-unifi-vlans-and-rstp-clarification-6850552

https://en.community.sonos.com/advanced-setups-229000/sonos-and-unifi-gear-vlans-rstp-update-6830571?postid=16364580#post16364580

https://en.community.sonos.com/advanced-setups-229000/sonos-on-segregated-vlan-iot-and-app-on-another-again-6820358?postid=16311253#post16311253

https://en.community.sonos.com/troubleshooting-228999/multiple-subnets-vlans-and-sonos-workable-clavister-solution-30950

https://en.community.sonos.com/advanced-setups-229000/sonos-on-segregated-vlan-iot-and-app-on-another-again-6820358

https://bsteiner.info/articles/hidden-sonos-interface

https://github.com/IngmarStein/unifi-sonos-doc
https://support.sonos.com/en-us/article/configure-your-firewall-to-work-with-sonos


2 replies

Userlevel 7
Badge +23

If I read this correctly, when your Sonos controller is on a different VLAN to your Sonos speakers it wont work. Well yes, Sonos require them all on the same subnet so that SSDP, Broadcasts, Multicasts and mDNS work.

You are doing this in the name of “security”, and it is working. Your config is blocking data between the VLANs. Be careful what you ask for.

Some Ubiquiti users have figured out how to get this to work (in other posts), but its not easy, same as everything else on Ubiquiti. Good luck.

@quharinho, Why are you asking about RSTP, your system is running on WiFi.

 

FYI: The matrix is unhelpful in WiFi mode. It is designed to display the SonosNet’s STP path, when the system is on WiFi there is no STP (Spanning Tree Protocol).

Reply