Answered

Music stops mid song and skips to next track

  • 4 August 2022
  • 9 replies
  • 75 views

Badge

Another variation on what appears to be a very persistent and annoying complaint. (Diagnostics confirmation number: 938688458)

 

When I first start listening to my Sonos system, songs in a Sonos playlist will play for a while (around two minutes) and then skip to the next song. After 10 or 15 songs have played, the skipping stops and everything seems fine. This is very reproducible but only happens after my Sonos system has been idle for more than 12 hours or so. It doesn't seem to matter if I use the iOS or Windows app. 

 

I’m running a Sonos BOOST wireless network for the various Sonos products, everything else is hardwired on a GE IPV4 LAN. Music is hosted on my Synology NAS, but I had exactly the same problem when my library was on a local Windows machine.

For what it’s worth, this problem only cropped up sometime early his year. Absolutely nothing has changed with my network setup and it’s the same NAS hardware. If I had to guess, it sounds like some kind of network buffering issue to me, but then I didn't write the Sonos code. 

Guidance would be appreciated, a fix would be wonderful.

icon

Best answer by Corry P 9 August 2022, 10:00

View original

9 replies

I have Synology NAS and don’t normally have any issues, however, a disk failure at one point caused some trouble.

If you submit a diagnostic immediately after one of these failures, you can follow-up with SONOS support.

Userlevel 7
Badge +18

Hi @Bohemian 

Welcome to the Sonos Community!

Your Boost seems to have a lot of interference near it causing a high packet error rate - in 99% of cases, this is because the Boost is too close to the router. Please separate them by 1m at least.

The errors reported were transport errors (there were issues getting the data to the speaker), so it seems likely that moving the Boost or router will indeed improve things for you.

I hope this helps.

Badge

Hi @Bohemian 

Welcome to the Sonos Community!

Your Boost seems to have a lot of interference near it causing a high packet error rate - in 99% of cases, this is because the Boost is too close to the router. Please separate them by 1m at least.

The errors reported were transport errors (there were issues getting the data to the speaker), so it seems likely that moving the Boost or router will indeed improve things for you.

I hope this helps.

 

I’m not clear if you really mean “router” or actually “wireless access point”. The two terms are not synonymous in my case. The nearest wireless access point is at least 10m away from my BOOST.

If the BOOST won’t play nicely with my WLAN, then maybe it was a bad purchase since it would hardly live up to the advertised claim of “Simply connect Boost to your router, and it will create a separate network free of any potential interference from other devices.”

And, while I appreciate the feedback, I don't see how this explains why/if my packet loss gets suddenly better after attempting to play several songs (assuming that this is even the cause). It seems beyond coincidence that the packet error late would suddenly drop to an acceptable so consistently. 

The errors I see in the app are “Unable to play [song] - file cannot be found” after playing some of the song. I can try creating a diagnostic log after several of these if that would be helpful.

I’m not clear if you really mean “router” or actually “wireless access point”. The two terms are not synonymous in my case. The nearest wireless access point is at least 10m away from my BOOST.

If the BOOST won’t play nicely with my WLAN, then maybe it was a bad purchase since it would hardly live up to the advertised claim of “Simply connect Boost to your router, and it will create a separate network free of any potential interference from other devices.”

And, while I appreciate the feedback, I don't see how this explains why/if my packet loss gets suddenly better after attempting to play several songs (assuming that this is even the cause). It seems beyond coincidence that the packet error late would suddenly drop to an acceptable so consistently. 

The errors I see in the app are “Unable to play [song] - file cannot be found” after playing some of the song. I can try creating a diagnostic log after several of these if that would be helpful.

 

It may help if you can perhaps provide the Staff with some further detail about your local setup. Example:

  • What router channel and channel-width are you using for your WLAN 2.4Ghz band and what channel is SonosNet set to in the Apps network settings?
  • Maybe briefly describe your network and each of it’s wireless access points, extenders, switches (managed/unmanaged) etc.
  • Do you have any Sonos portable devices Roam/Move and are your WiFi credentials presently stored in the Sonos App network settings?
  • Is there anything else near your Boost that might cause issues with its 2.4Ghz signal…Bluetooth, Zigbee devices, baby monitors etc?
Userlevel 7
Badge +18

Hi @Bohemian 

I was playing the numbers - generally, it’s the router that is the source of interference.

In your case, if no router or AP is near the Boost, then something else is causing the interference, as @Ken_Griffiths suggested. You’ll need to find out what it is and move either it or the Boost. Our reducing wireless interference help page may be of assistance in identifying the source. Interference may not be the only problem, but reducing it is certainly the first step to take.

The packet loss is constant - the Boost is reporting several counts of 5,000 dropped packets every 500ms, sometimes more than 10,000. Other issues cannot be identified until this has been reduced, but I suspect there probably isn’t any.

You may have some success in changing the WiFi channel that the Boost broadcasts on. It’s currently on channel 6, but you can change it to 1 or 11 by selecting Settings » System » Network » Change SonosNet Channel. The change is instant and not reported in the app. Please make sure all your rooms are visible in the app before performing this step. Your Sonos system has not performed any WiFi scans recently, so I cannot tell you which channel to use, but please experiment. You may want to check which channels you and your neighbours are using before selecting a different, non-overlapping channel for Sonos (only channels 1, 6 & 11 do not overlap) first.

I hope this helps.

 

Badge

I’m not clear if you really mean “router” or actually “wireless access point”. The two terms are not synonymous in my case. The nearest wireless access point is at least 10m away from my BOOST.

If the BOOST won’t play nicely with my WLAN, then maybe it was a bad purchase since it would hardly live up to the advertised claim of “Simply connect Boost to your router, and it will create a separate network free of any potential interference from other devices.”

And, while I appreciate the feedback, I don't see how this explains why/if my packet loss gets suddenly better after attempting to play several songs (assuming that this is even the cause). It seems beyond coincidence that the packet error late would suddenly drop to an acceptable so consistently. 

The errors I see in the app are “Unable to play [song] - file cannot be found” after playing some of the song. I can try creating a diagnostic log after several of these if that would be helpful.

 

It may help if you can perhaps provide the Staff with some further detail about your local setup. Example:

  • What router channel and channel-width are you using for your WLAN 2.4Ghz band and what channel is SonosNet set to in the Apps network settings?
  • Maybe briefly describe your network and each of it’s wireless access points, extenders, switches (managed/unmanaged) etc.
  • Do you have any Sonos portable devices Roam/Move and are your WiFi credentials presently stored in the Sonos App network settings?
  • Is there anything else near your Boost that might cause issues with its 2.4Ghz signal…Bluetooth, Zigbee devices, baby monitors etc?

I’m running a UnIFi LAN/WLAN using their security gateway, 24 port managed switch and six Dual Band WAPs. Most traffic is on the 5 GHz band, but there are some 2.4 GHz legacy devices.

There is most definitely Zigbee and Bluetooth transceivers that are part of my home automation system. But their presence preexists the problems that I am having.

Since SONOS only works on 2.4 GHZ, I will try scanning with with my UniFi controller and see if I can find a better channel band for my SONOS BOOST.

@Bohemian,

I don’t personally know much about your Unify system, but I did find this in another forum thread. So posting it just in case it may also assist you, that’s if the dropout issue might, in part, be related to an SSDP multicast/broadcast ‘device discovery’ issue...

  • Log into the UniFi controller.
  • In the Settings tab, click Wireless Networks.
  • Click Edit next to the network SSID.
  • Expand Advanced Options.
  • Uncheck Block LAN to WLAN Multicast and Broadcast Data.
  • In the Settings tab, click Sites.
  • Disable Auto-Optimize Network.

Also enable IGMP Snooping (which is on the Networks settings page).

——————————————————-

Also here is a chart that shows the Zigbee channels that coincide with the non-overlapping 2.4Ghz channels 1, 6 and 11.

Hope that some of the things mentioned above, help you to get your issue resolved.

Badge

You may have some success in changing the WiFi channel that the Boost broadcasts on. It’s currently on channel 6, but you can change it to 1 or 11 by selecting Settings » System » Network » Change SonosNet Channel. The change is instant and not reported in the app. Please make sure all your rooms are visible in the app before performing this step. Your Sonos system has not performed any WiFi scans recently, so I cannot tell you which channel to use, but please experiment. You may want to check which channels you and your neighbours are using before selecting a different, non-overlapping channel for Sonos (only channels 1, 6 & 11 do not overlap) first.

I hope this helps.

 

I will trying changing channels as you have suggested and will see what happens.

Badge

@Ken_Griffiths - thanks for the info.

The UniFi Controller networking changes suggested have been in place for a while, but I did verify that these WLAN /  Network settings were still intact. And I reset my Sonos BOOST to Channel 1.

My Zigbee coordinator channel is currently set to Channel 15, which is generally considered as non-interfering with the 802.11g Channel 1 spectrum, as it is near the upper frequency ‘tail’ that’s at least 50 dB down from the Channel 1 centre peak.

So I’ll let the system run for a couple of weeks and see if this resolves the issue. 

This situation has me thinking about a feature request for Sonos, given the apparent fragility of its networking (to be fair, judged only by the numerous posts on this forum), and the growing ubiquity of wireless home automation products.
 

As an end user, I would like to be able to get a rough health check (green, yellow, red traffic lights?)  of how my network is performing when attempting to troubleshoot issues. Maybe an ‘advanced’ capability in the app under System Settings?

This might minimize the frequency and complexity of having to contact Support with debug logs. For me, that would be a better UX. Just a thought.
 

Reply