Answered

Connection to Spotify was lost

  • 3 June 2021
  • 63 replies
  • 11672 views

Hello,

I am having an issue playing Spotify through my Sonos app. I keep getting an error message saying "Unable to play (song) the connection to Spotify was lost." After spending some time searching for a solution online, it became apparent that this is a widespread problem with no definitive solution. Nevertheless, I am determined to find an answer.

Additional information:

• Diagnostic: 2024196285

• Internet connection is stable.

• Issue just occured today during playback. Sonos system was installed a few weeks ago, and everything was working fine until today.

• Spotify app works fine by itself, and I can play Sonos Radio through the speakers. The issue only seems to be when I try to play Spotify through Sonos.

• I have tried powering the Sonos amps off and on. No fix.

• I have removed my Spotify account in the Sonos app, and then reconnected it. No fix.

• I have tried clearing my queue in the Sonos app. No fix.

• I checked for updates on both apps after the problem occured. No update for Spotify, but I did update Sonos. No fix.

I believe that is all the relevant information that I can provide at this time. I look forward to a response and hopefully a fix.

Thanks in advance!

 

icon

Best answer by Corry P 7 June 2021, 13:47

View original

63 replies

Userlevel 7

Try resetting the Sonos app under App Preferences and rebooting your phone. If that doesn’t work, try re-installing the Sonos app.

Try resetting the Sonos app under App Preferences and rebooting your phone. If that doesn’t work, try re-installing the Sonos app.

Thank you for your advice, unfortunately I tried this and still the problem persists.

Userlevel 7
Badge +17

Hi @KBeaumont 

Welcome to the Sonos Community!

And thanks for the diagnostics - I was able to confirm that you’re being affected by a known issue that we are currently investigating.

Other than you perhaps needing to install a future update, this is up either Spotify or ourselves to fix - there’s nothing you’ll be able to do to fix the issue permanently. Some users have noticed an improvement after rebooting their entire Sonos system, however. I recommend taking the opportunity to reboot your router by removing power for 30 seconds too.

 

Edit: Or as you have already mentioned, play Spotify on Sonos from the Spotify app.

I have the same issue and I cant connect to the sonos speakers using spotify app as well, it’s stuck on connecting. Please help.

Userlevel 7
Badge +17

Hi @Indrasentosa 

Welcome to the Sonos Community!

I recommend you make sure both the Sonos and Spotify apps are up-to-date, then reboot your phone/tablet and switch off your router and Sonos speaker(s). Once the router has been off for 30 seconds or more, switch it on and wait for WiFi to return before switching on Sonos again.

If you then still can’t connect Spotify to Sonos, try removing Spotify from Sonos and add it again:

Remove a music service account from Sonos

Add a music service to Sonos

If that doesn’t help either, I recommend you get in touch with our technical support team, who have tools at their disposal that will allow them to give you advice specific to your Sonos system and network.

Connection to Spotify was lost - “And thanks for the diagnostics - I was able to confirm that you’re being affected by a known issue that we are currently investigating.” Has this issue been resolved?

There’s been no indication at this point that Spotify’s engineers have been able to resolve the issue, despite the assistance of Sonos’ engineers. There would like be a lot of various threads that have a response from Sonos when it occurs, since there are over a dozen separate threads currently discussing it as an issue. 

Connection to Spotify was lost - “And thanks for the diagnostics - I was able to confirm that you’re being affected by a known issue that we are currently investigating.” Has this issue been resolved?

i’m looking for an update - anything yet?

thanks, as i';m also experiencing this issue

Userlevel 7
Badge +17

Hi @alan278 

We consider this issue closed, so you may be experiencing issues due to something else going on. I recommend you get in touch with our technical support team, who have tools at their disposal that will allow them to give you advice specific to your Sonos system.

This crap happens all the time. It’s temporary and usually resolves itself. FWIW, the problem doesn’t happen when you try to play music from Amazon; only Spotify. I don’t know who’s fault it is but it’s insanely annoying. 

I had the same issue, reset everything multiple times in multiple orders, nothing worked. 
 

Fixed it by playing a sonos radio playlist then switching back. Id say its a Spotify Authenticator issue, no issues since!

Easy fix for devs would be if the error code appears then it automatically plays a silent song on sonos radio for a few seconds then switches back and retries. 
 

You’re welcome…

This is happening to me too!!!

 

1768319446

Userlevel 7
Badge +17

Hi @Hp202190 

Your Sonos system seems to have a few problems. First, your WiFi seems to have both frequencies on the same credentials and is “band steering” your devices to connect to 5GHz, which they will refuse to do. Additionally, Sonos devices talk to each other directly, using the same channel as your WiFi. As your WiFi access points are on channels 6 and 11, they aren’t always able to do this. There is also some multicast flooding affecting your Sonos system. I think you may possibly have too many WiFi access points - a lot of frequency congestion is reported.

To remedy all this, I recommend you connect at least one Sonos device to ethernet and test the whole system’s performance. This will make the unit(s) transmit a private WiFi for Sonos, much like your old Bridges used to do and bypass the WiFi you have, and the problems Sonos is having with it. Please change the channel they use to 1 (Settings » System » Network » Change SonosNet Channel » 1). Please also set your UniFi system to only use one channel (6 or 11, not both).

If that’s an improvement, make the wired connection(s) permanent. Ideally, you’d have a wired Sonos device to cover each half of your home.

To filter the multicast flooding out, I recommend checking your router’s network settings for IGMP Snooping/Filtering and enable it.

If the wiring of Sonos to the network does not help (it looks like you have some thick interior walls), or even if it does, disabling QoS (Quality of Service) and Airtime Fairness on your UniFi system should help. So should following these steps:

  • Log into the UniFi controller.
  • In the Settings tab, click Wireless Networks.
  • Click Edit next to the network SSID.
  • Expand Advanced Options.
  • Uncheck Block LAN to WLAN Multicast and Broadcast Data.
  • In the Settings tab, click Sites.
  • Disable Auto-Optimize Network.

Finally, using an ethernet-wired unit as the first room selected when creating a group will make the network path that the data follows the most efficient. If you remain on WiFi, I recommend experimenting with different rooms in charge. Those likely to have the better WiFi connection are the best choices.

I hope this helps. If it doesn’t, I recommend you get in touch with our technical support team for some in-depth and real-time troubleshooting of your Sonos system.

 

 

There must be a proper fix for this, most frustrating thing ever , I have done everything mentioned above thread and still the same , plays a few songs then just stops. I did t know you could add the app on Spotify, so did this .. still after a few songs it will just stop . Same on my phone or if I play from PC … what is the answer Sonos Team ???  

 If it doesn’t, I recommend you get in touch with our technical support team for some in-depth and real-time troubleshooting of your Sonos system.

 

Hello all, I have just set up a Sonos one in my kitchen on wifi and have an Arc in the living room that is hard wired into my router. I play Spotify through Sonos S2 app and …you guessed it ! the Sonos one looses connection and stops playing music. Where do I go from here if all above instructions fail to sort this issue out?

Thank you.

Seems a lot like a network issue, with the speaker in the kitchen not communicating properly with the wired Arc. Have you gotten in touch with the technical support team, as mentioned previously in this thread?

Hello Thanks for the reply. I have not contacted technical support as yet. I know you can link 2 rear speakers to the arc to add surround, but did not know you can link a single Sonos one to the arc or did you mean just to play music on both the lounge arc and kitchen one at the same time? Sorry, but I’m new to this and just finding my feet.
Things were stable today.

Depends on really what you mean….

You can always “group” speakers while playing music. They’ll play in sync.

In order to have surround speakers, it requires two speakers properly set up. 

It’s OK to be new, and ask questions. And there are specific definitions of certain words in the Sonos lexicon that have very specific meanings, such as “pair” “group”, “bond” and “room”. Probably some others I’m not remembering, but when these words are used in a Sonos forum, they do have very specific meanings. 

Hi,

 

Same problem. Have contacted technical team but not useful. Can you please explain how the Sonos is having an issue only with Spotify, but not my own music library, Amazon music or so is radio? It is a single app (and generally the best for music streaming which explains the annoyance of the compatibility failure) that is failing.

I have factory reset my entire system. Everything works. Except Spotify. It also continues to try to play music long after you have given up and moved to Amazon music or another service. Halfway through playing a track on the same speaker it failed to play a Spotify track, the stupid error code comes up again. This is a bug. Or more specifically, your bug.

Everyone here has done all of the troubleshooting, resetting and assorted non-fixes. You cannot “consider this closed”. Not is it our wifi. We all have (I’m guessing) a normal amount (high) or devices on the wifi, because we aren’t luddites and we are in the 21st century. You cannot market a highly expensive set of speakers which cannot work if you and you partner and children have a normal amount of wifi devices for a modern house. Plus, that argument holds no water when all non-Spotify traffic works fine with the same traffic on wifi channels.

Could we have a fix, please?

 

It certainly suggests that the issue is on the Spotify end of things. If it was a Sonos problem, all other services would be equally impacted, as you point out.

Assuming that Sonos has received your diagnostics, and has identified the issue, I’m convinced that they have communicated the issue to Spotify. It would likely help if you were to also contact Spotify and complain. 

It’s unfortunate that Sonos doesn’t have any control over Spotify’s servers, and can’t work directly on them. Spotify has to do that work. All Sonos can do is point their service to the access point/server provided by Spotify.

I have also now started experiencing this issue after years of problem free use.

This seems to be a problem playing Spotify from within the Sonos app. 

I find it difficult to take it seriously that you point the customer to make a complaint with Spotify. This should be handled by Sonos and Spotify, not the customer.

Apparently it has been going on for quite some time.

Is Sonos actively working on resolving this?

If so when do you expect a resolution?

December 11, 2021, months after the “case closed” notice posted above, and for the very first time in years of Sonos use with Spotify…. I, too got the “unable to play, cannot connect” error, and Googling it brought me here. 

Interestingly, it cannot connect and then skips to the next song, sometimes it will start playing it and then stop connecting.

FYI: Using Fios 1GB fiber optic connection through an Amazon eero Wifi router connected directly to the fiber modem (not through the Fios router - that one was sent back).

Also FYI: Playing through Sonos app on my MacBook. All apps and speakers fully updated. 

Pretty frustrating. 

Also having this problem. All my speakers are wired. Seems to go in and out, although it seems more reliable if I play to Sonos FROM Spotify instead of using the Sonos app. I’ve tried reconnecting the services, reauthing before I try playing, etc. nothing seems to help. Happing on my and my wife’s devices.

Just switched to Apple Music, and… zero connection issues. 

Reply