ASUS Router firmware update 2020/11/26

  • 3 December 2020
  • 71 replies
  • 7590 views

Userlevel 1

Hi, I just want to inform others that the latest firmware for ASUS RT-AX58U, released on the 26th of
November, will make the Sonos speakers stop working (Confirmed on Play:1 and Play3).

I have tried to factory reset the speakers and reconfigure them but without success.
I don’t exactly know what is causing this, but a roll back to previous firmware resolved the issue. 
 

bthart 1 year ago

Confirm the same issue with an ASUS RT AX86U, Play3 and Play1. Oddly, the Move unit was not affected. Same symptoms after updating the firmware in early January, each Play unit would drop in and out. Rebooting either the router or the Play would bring it back for a little bit, then it would drop out again. 

Rolling back the firmware (using Method 2 from this page: https://www.asus.com/support/FAQ/1008000/) from Version:3.0.0.4.386.41535 back to Version 3.0.0.4.384_9318 solved the issue. 

I submitted a help request via e.mail to ASUS, and pointed them to this page. I’d encourage anyone else with this issue to do the same, to raise awareness.

View original

71 replies

Badge

As of 4/29/21, there is a new version 3.0.0.4.386.42840 (at least for the RT-AX86U). Has anyone tried it?

My current version (which I think is the last confirmed working one) is 3.0.0.4.384_9318 and is now several updates behind...

What worked for me with the problematic Asus mesh setups as even the latest 386_xxxx firmware for my models did not work.
 
I have 2 surround sonos setups that I had to bind to my mesh node. They did not like when I had them connecting though the main node. It is also worth mentioning that I have non-matching mesh setup (RT-AX92U for main router and RT-AX11000 for mesh node).
Firmware versions currently being run:
RT-AX92U: 3.0.0.4.386_43084-g728dd24
RT-AX11000: 3.0.0.4.386_43129-g60defb2
 
I tried everything, resetting to factory settings after a firmware update, removing and re-adding the mesh node, making sure all the recommended settings were disabled (QoS, Airtime Fairness, etc), rejoining the sonos units and nothing worked. There is something amiss with the Asus firmware for sure.

I just bought the RT-AX86U and having some serious issues with my older SONOS system. It keeps dropping connection after a few hours. It connects with no problems but after a few hours I’m no longer able to control SONOS even though it shows connected in my ASUS router software. I have tried all the above without success. I’m on the latest firmware as well 2840. Please any help would be appreciated as I never had any issues with my Netgear Router that I replaced after 8 years of solid use. I thought I was upgrading to newer and better technology only to have my SONOS system malfunction now. 

As of 4/29/21, there is a new version 3.0.0.4.386.42840 (at least for the RT-AX86U). Has anyone tried it?

My current version (which I think is the last confirmed working one) is 3.0.0.4.384_9318 and is now several updates behind...

 

I’m in the same situation and wondering the same thing.  Or does anyone know what improvements there are in the latest firmware?  For now, I’m taking the “if it ain’t broke, don’t fix it” approach by not updating. 

I installed 386_43406 today. It seems fine. 

 

Greetings Xirtam2K

Badge

I installed 386_43406 today. It seems fine. 

 

Greetings Xirtam2K

NO, IT DOES NOT!!

It actually still does… on the  ax58u (2x) and 12 sonos/ikea devices.

 

Xirtam

I only have 2 Sonos ones, a gen 1 and a gen 2. And it’s the Gen1 that doesn’t work when connected to an RT AX92U, it connects OK but it fails to register to my account. I’m running 3.0.0.4.386_43084-g728dd24 firmware,

My workaround was to use an old Airport Extreme (4th gen) i was just using as a switch, as a second wireless endpoint. Which I can live with.

They both worked fine at one point, but stopped at the time the Sonos update came out that enabled 5Ghz WiFi on the gen 2. So I’m speculating that having a mix of devices that support different WiFi protocols is the issue (clearly that’s a guess on my part).

I had similar experience and had no luck with the recent Asus Xt8 firmware (ikea symonfisk speakers). Did no want to connect to 2.4ghz wifi. Tried checking for airtime fairness etc.

In the end I had to add one speaker to a satellite xt8 mesh unit via ethernet cable which then made it create a dedicated sonos wifi network which the other speakers could connect to. Luckily for me all the speaker locations I want are nearby.

I got my ASUS RT-AX88U running latest firmware working with Sonos. 
 

1. Make sure "airtime fairness" is turned off.

2. Make sure IGMP snooping is turned on. 

3.Make sure the Roaming assistant is disabled. (this was last bit I changed and seemed to fix!)

the third bit does make sense from what I was seeing. Before disabling it, the Sonos would work for a bit, then the network or Sonos needed to have a kick. I guessed something was turning off the network connection after a time. Roaming assistant seemed like a likely suspect.

Another thing to check is make sure you don’t have QOS enabled. The Sonos doesn’t seem to like it as I made that mistake too.

so far it’s been solid for a while now, so hopefully this helps people

Sadly, I had to downgrade my ASUS router from the latest right now, back to 3.0.0.4.384_9918.

I have an older Sonos One with hardware version 1.21.1.8-2.1 and it could not work. It could connect to the router, but it would not appear within the Sonos System :(

Am frustrated because it looks like a lot of vulnerabilities were fixed in the last few versions.

I’m on firmware 3.0.0.4.386_45375 on my RT-AX88U ASUS router and all my sonos kit has been stable since my last post :)

Thanks. I’m using RT-AX58U. Do you have older Sonos hardware speakers or are they the latest hardware versions? Before I reverted my firmware, I followed your recommended settings as well.

I’m running an Arc, a Sub 3 & 2 x IKEA sonos book speakers at the rear. They are all at the latest firmware from Sonos. Everything needed a reboot after changing the settings, but it’s all been good since 

I thought it may help to show my settings. My Sonos is on the 2.4ghz network

 

Make sure you reboot the router last! That is important 

Sounds awesome. Looks like they have the latest hardware, or at least Gen2. My Gen2 speakers can work fine with the latest router. But my Gen1 Sonos One can’t. Maybe time for a trade-in/upgrade:)

I’m having the same issue with an ASUS RT-AX58U router. I made the changes that Colin suggested above and still have issues. I’ve also been on the phone with Sonos and ASUS. Ready to throw this router in the bush. 

Userlevel 1

Checking back to this thread over a year since I started it and am amazed over how many that have had the same issue, some people seem to have resolved it and some not.


Anyhow, I decided to give it a new try with latest firmware, installed it and hoping for the best. But it didn’t took long before the the disappointment, the Sonos deviced immediately dropped out from the network.

I tried the different tricks with Airtime, IGMP and roaming settings mentioned in this thread. but all without success. 

Don’t know why, but this time I decided to do a factory reset on the Asus router instead of the Sonos speakers and wow that resolved the issue!!  The Sonos speakers are back and still working, it also seems to have resolved an issue with my XBOX where I previously couldn’t get download speeds over 20Mbps, now I have 200+. 

I couldn’t see any settings to be different from before. 

 

I tried the factory reset this morning and it worked! I had done everything else including a reboot but it took the factory reset for the setting changes to take effect!

Hi Everyone

I experienced these same problems with my ASUS RT-AX58U router. It also happened last year, where i ended up fixing it with reuploading a working firmware. I wondered if this would work still, AND IT DID!

I ended up using the firmware-upgrade: 3.0.0.4.384_9918, which solved the problem. I am interested to know whether there are newer versions of firmware which works with Sonos, but for now this is working.

Thank you for the help guys!

Reply