Answered

Era 300 cuts in and out when configured as surround speaker


Userlevel 2
Badge

Hi everyone,

I just received my pair of era 300 to replace my ones.

When sending music on just one of them, audio is perfectly fine.

When sending music on both of them, although not configured as a stereo pair, audio is perfectly fine.

When sending music on both of them, when configured as a stereo pair, audio is perfectly fine.

When configured as surround speakers, and sending music to the whole system (Arc + Sub + 2x era 300), the sound is fine on the Arc and Sub (RJ45 wired), and cuts in and out on both of the era 300.

More precisely, it’s as if the sound is fading out, fading in, bouncing between the two era 300 a couple of times, then stabilizing for 3-5s, and then doing it all over again.

I tried restarting my router, unplugging/plugging back both era 300, changing WiFi channel on the sonos APP, and I still have this weird behaviour.

At this point, I don’t have any clue on what to do next… 😔 

Any idea on how I could fix this?

icon

Best answer by Sebkulu 6 April 2023, 10:55

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

22 replies

Userlevel 2
Badge

Thanks to everyone for clarification.

I’ll set this thread as solved, and put the quick answer.

WiFi on arc and sub must be enabled

Userlevel 7

Hi @Sebkulu 

I’ll try to explain why Sonos Tech Support may give advice that doesn’t appear to make sense.  Especially to those like yourself who have joined Sonos within the last 2-3 years. No offense intended...it’s all about history.

When I first jumped on the Sonos bandwagon Home Wifi was not an option. You had to purchase a “Bridge “ which is now called a “Boost”. Sonos back then was always on the SonosNet from the git go! The SonosNet (IMO) while not perfect was and is still more stable than Home Wifi.

Sonos resisted allowing its speakers to be put on home Wi-Fi for years. People in general typically purchased any router just to get wi-fi capability in their homes. Wifi was mainly for laptop computers and their portability. It was an early form of “cutting the cord”

The early days of Wi-Fi were very iffy with 802.11a and 802.11b. 802.11 throughput and signal strength really didn’t improve until 802.11g. Devices cable of running on the 802.11g proliferated over night.

I remember when 802.11n was introduced. The problem was that most routers that provided 802.11n were not backwards compatible to 802.11a/b/g. Sonos to this day doesn’t like 802.11n dedicated networks.

When Sonos finally allowed its speakers to operate over home Wi-Fi the flood gate of problems started. This community owes a lot of it’s longevity to issues stemming from home Wi-Fi.

Everyone who thinks they are a network “guru” isn’t. Add to that those who want to engage range extenders and access points on their networks; not realizing that only the main router should have DHCP capability. Let’s add ISP’s who provide their proprietary modem/router equipment to the mix. Oh...lets not forget the latest wifi setup...Mesh Networks. 

Speaking of network “guru’s (you are probably the exception)...most people don’t know the difference between a “dumb” versus a “managed” switch. The latter which can interfere with Sonos updates; if not configured properly. Therefore, Sonos tech support gave advice to connect a speaker directly to a router rather than through a switch. Also the advice to connect directly to the router from time to time to ensure updates are received.

Having worked in tech support when doling out advice more is typically given than needed. The reason being is that the tech support person doesn’t know the clients level of knowledge. Therefore  “CYA” answers are given to hopefully cover as many scenarios possible.

The client (individuals like yourself) hopefully can decide what advice is relevant to their situation; and what advice is given as a “BTW”. 

You may recall my comment in an earlier post which alluded to the problem being associated with Wi-Fi...

“However, since surrounds use the 5 Ghz channel between the Arc/Beam to receive their information; I'm not sure that wiring an Era 300/100 would make a difference. I guess I’m leaving toward some type wireless interference as the culprit 🤔’

At the time I didn’t know it was because the WiFi on the Arc had been switched off. That said my answer may not be as “scientific” as you would desire. Suffice it to say, that Wifi can be friend or foe as it relates to Sonos.

Edit: Wifi must be turned on for all devices in a home theater setup. The 5Ghz is used by the Arc/Beam to send the appropriate material to the the sub(s) and surrounds. No exception.

You were forcing the connection to go a path not designed/intended, by forcing the connection through your router. The system is designed for surrounds to connect to the wifi signal on the sound bar. Sonos has poorly labeled the “turn off wifi” function on the sound bars, it really turns off all radio, which is used by the Sub and Surrounds, normally speaking. 

Putting all on the wireless worked for me.

Thanks to everyone for clarification.

I’ll set this thread as solved, and put the quick answer.

WiFi on arc and sub must be enabled

Thank you, that solved it for me as well! However the sub was working when arc wifi was disabled.Both of them connected with cable.

Thanks!

Hello everyone. I’ve had my Era 300s for a week and I have exactly the same problem. I did a factory reset on both and the problem persists. Any fixes yet?

Userlevel 1
Badge +1

WiFi on arc and sub must be enabled”. Does this apply only to the Era 300’s? My Home Theater setup = Arc plus 2 Fives as surrounds. My Arc is plugged directly into my Netgear Orbi via ethernet. I have wifi disabled on my Arc. My 2 Fives and Arc play TV (streaming movies, regular TV, etc.), and streaming music just fine. I can also add my 3 Play Fives to this setup via Alexa or Sonos Voice when streaming music, so the music plays throughout the house, actually the TV will play throughout the house the same way - all speakers playing the same thing at the same time. I know this is not a groundbreaking observation (grouping speakers), just curious as to why my setup will work this way with wifi turned off on the Arc, and the Era 300’s will not, since both of our setups include the Arc being connected via ethernet.

Userlevel 2
Badge

@ProfessorPeach  @Sebkulu  @LuvMySono 

Did you set the Era 300’s to “Full” for music playback when used as surrounds?

Just came back from work, and tried deactivating this setting, the issue still occurs.

Userlevel 7

I was wondering: Sonos states that when using era 300 as surround, the line-in is disabled, but does that also apply to Ethernet ?

If that’s not the case, would the Ethernet adapter solve the issue?

And do I have to buy the Sonos adapter (which cost a fortune) or can I use a regular type C to Ethernet adapter?

I must say that I’d rather not plug the era’s to Ethernet due to their placement (apparent cables…), but if I have no choice, I’m going to for sure…

Of course before buying, I’m gonna try every solution you guys advise me to test.

All information says the “Line-in” is not available when used as a surround setup. Can’t find anything specific to the Ethernet portion as being an independent connection. However, since surrounds use the 5 Ghz channel between the Arc/Beam to receive their information; I'm not sure that wiring an Era 300/100 would make a difference. I guess I’m leaving toward some type wireless interference as the culprit 🤔

Userlevel 2
Badge

I just called the support and sent them the diagnostics.

They analyzed it, and apparently it was because I switched WiFi off on my Arc and Sub (which are directly wired to my network using Ethernet)

It did the trick and now I don’t have any cutoffs any more.

 

They also gave me 3 advice that make no sense to me:

  • Plug the Arc directly into the router without going through a network switch
    1. it could cause firmware update problems
    2. it could cause problems to direct connection to other Sonos devices

It litteraly makes no sense to me as a switch is completely capable to send the signal to the target device. More over all my Sonos device are updated to firmware 15.2, and I don’t see why a direct WiFi connection between Sonos devices could be altered by a switch…

 

  • From time to time, plug directly a Sonos product to the router to ensure updates

Again, I don’t see why that would be an issue

 

  • Buy a Sonos Boost

I don’t see how that would change a thing, since it will create its own WiFi network dedicated to Sonos devices, and I can’t have it directly plugged into my router AND my Arc… So it will still have to go through a switch, or I won’t have any RJ45 ports available any more if I plug the other RJ45 port into my Arc…

 

My setup at home is the following:

  • Internet optical fiber arriving in the garage
  • ISP router in the garage to be plugged in the fiber channel
  • 1x RJ45 port from ISP router plugged into 1 RJ45 port of my house
  • 1x RJ45 port from ISP router plugged into a 8 ports switch
  • 5x RJ45 ports from switch plugged into 5 RJ45 ports of my house

And in my TV Room, I have one of those RJ45 ports, but I also have a lot of devices to plug to my network (consoles, TV, Arc, etc...) so I can’t dedicate that port to the Arc.

 

Anyway, back to the original problem, WHY do I have to turn WiFi on again on my Arc AND Sub, when it was perfectly working with the One’s SL?

I really would appreciate a technical answer, and some insights about this issue.

Userlevel 1
Badge +1

Thank you for your quick response. My connection is not “spotty” thank goodness. However, your response precipitated another question. Since bonded speakers are designed by Sonos to connect via a hidden 5Ghz WI-FI connection, theoretically, does that mean the sound will be better than a wired connection for bonded speakers? I guess my 2 Fives “bond” to my Arc via the home network? (since the Arc wifi is turned off). 

Userlevel 2
Badge

@Airgetlam thank you for this clear answer.

But why was I asked to re-enable the WiFi also on my sub?

Since it is connected to the switch where the arc is connected, it should directly communicate with the Arc or am I missing something?

The normal setup for a Sonos “bonded” speaker, such as a Sub and / or a surround speaker is to connect to a unseen 5Ghz signal generated by the sound bar. It saves a “hop”/”processing time” or two, which is important for a latency sensitive connection, so that it doesn’t go to the router for additional handling. That’s the way Sonos designed it to work. There are some cases in which a direct wire can work, but there’s additional work being done by the network, so it’s not really the “best” or primary/intended use case. 

In addition to the above excellent post from, @AjTrek1 , a more concise answer to your question:

The Sub needs to connect to the sound bar’s wifi signal. So both “radios” need to be turned on. The one sending, and the one receiving the signal. 

 

SONOS has misnamed “WiFi OFF” because it turns OFF the radio, thus stranding wireless surrounds and communications with wireless SonosNet and WiFi.

BOOST is a different product, replacing BRIDGE. At this point one should consider BRIDGE to be EOL because they often cause issues due to hardware failure.

A history note: At one point the competition accused SONOS of lying about being wireless because at least one unit needed to be wired. The wired unit could be an inexpensive BRIDGE if it was not physically convenient to wire a player. For a while SONOS included a free BRIDGE with a purchase, but this did not eliminate the “lying” dialog. It was a relatively cheap trick for SONOS to enable WiFi and this deflated the “lying” dialog overnight. It should be noted that SONOS has been “mesh” since inception in 2005. Only lately has “mesh” become a magic word in consumer WiFi. While competition was accusing SONOS of “lying”, they struggled to serve more than a handful of wireless clients. As the competition devised more robust schemes, they bumped into SONOS patents.

Since I don’t work for Sonos, nor am a network engineer, I’ll give you my ‘opinion’, which is worth every penny you’ve paid for it (much like my comments before). 
 

  1. The data being carried doesn’t change due to the carrier type. It’s exactly the same via wireless as it would be via wired. It is all digital. 
  2. The initial design was for wireless, the wired connection is, in my mind, a secondary connection. Which means potential issues. Unless there is substantial wifi interference  in the environment, I consider the intended Wi-Fi signal to be preferable (but not better, or worse, acoustically). 
  3. If you’ve got the Arc’s ‘radio/Wi-Fi’ turned off, and your surrounds wired, and are not having issues, or problems with the extra cables, etc, leave well enough alone. 
Userlevel 7
Badge +22

On switches, as said managed switches can cause issues with Sonos, some can be cured by tweaking the switch. But also some un-managed gear seems to fall short of supporting all that Sonos needs, see the incompatible hardware page for a list of known gear.

Badge +2

I have experienced this too. There have been a number of issues reported with the Era 300’s, but I thought I was alone on this particular problem. I never had this fading-out-and-in trouble with my lovely Ones or prior speakers. I am rapidly beginning to feel like I should have been paid the £875 to beta test the 300’s, not do it at my own expense.

Userlevel 7

@ProfessorPeach  @Sebkulu  @LuvMySono 

Did you set the Era 300’s to “Full” for music playback when used as surrounds?

Userlevel 2
Badge

@ProfessorPeach  @Sebkulu  @LuvMySono 

Did you set the Era 300’s to “Full” for music playback when used as surrounds?

Yes I did

Userlevel 2
Badge

I should also mention that I read the thread about fixing wifi issues stating it’s better to have 2 distincts SSID for 2.4 and 5 GHz bands, which I did.

So I had to factory reset all of the speakers connected to wifi in order to setup them using the new 2.4Ghz WiFi SSID.

Note that before doing so I checked my WiFi network and noticed that some speakers were connected to the 5Ghz band.

Anyway, that didn’t do the trick, and the issue persists.

 

@AjTrek1 : Please note that the problem also occurs when sending sound from the TV, not only when streaming music from phone or any other music streaming service.

 

@ProfessorPeach @LuvMySono Do you also have your sound bar (and sub) directly plugged in your network over ethernet?

Userlevel 2
Badge

I was wondering: Sonos states that when using era 300 as surround, the line-in is disabled, but does that also apply to Ethernet ?

If that’s not the case, would the Ethernet adapter solve the issue?

And do I have to buy the Sonos adapter (which cost a fortune) or can I use a regular type C to Ethernet adapter?

I must say that I’d rather not plug the era’s to Ethernet due to their placement (apparent cables…), but if I have no choice, I’m going to for sure…

Of course before buying, I’m gonna try every solution you guys advise me to test.

There are two types of Sonos connections.

The first is the normal peer to peer type, which can occur across multiple types of connections. 2.4Ghz Wi-Fi (b/g/n) or 5Ghz, or SonosNet ( a separate mesh Wi-Fi signal parallel to a normal Wi-Fi signal, but unseen except by Sonos). And of course wired. 

The second is a parent/child (master/slave) type, which is used for speakers known as ‘bonded’ speakers, such as Subwoofers and surround speakers. This is usually across a ‘hidden’ 5Ghz Wi-Fi connection, as designed by Sonos. In some cases, it can work over a wired connection, but that seems to be ‘spotty’, at least from what I have seen. The normal use case is the wireless connection, which requires the ‘radio’ to be turned on on both speakers.