Answered

delay on play 1s but not on any other speakers.

  • 23 November 2023
  • 18 replies
  • 600 views

Userlevel 2
Badge +4

This is really getting to me know it’s been on going for months, 

 

Whenever I play the 2 paired up kitchen speakers there’s a delay when using the volume and also when changing tracks, it only happened on my kitchen speakers.

if I play my kitchen speakers with the playbar and use the volume the playbar works fine but there’s still a delay with the kitchen speakers. 
It makes no difference if I hardwire my connect which is the only one pretty near the router for sonosnet or I just use WiFi 

I have a play one upstairs which is the farthest from the router but that is perfect, it’s just the ones in the kitchen that this happens on. 

ive reset everything many times, unplugged, etc but stil a slow response on those speakers. They also relatively near the router too. 
So frustrating, Sonos problem or router problem god knows. 
I was convinced it was a poor quality Ethernet cable so I’ve just bought a better one but it’s made no difference at all 🤦🏼

icon

Best answer by Ken_Griffiths 24 November 2023, 20:45

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

18 replies

@Wrightytyke 
Note too that whilst running all on your WiFi signal, you can go onto check the SNR level of your speakers too. See this link: 

https://support.sonos.com/en-us/article/understanding-the-network-details-section-in-the-sonos-app

If the SNR levels are low for your Play:1’s in the Kitchen, then you perhaps need to move them and try to get an SNR level of 45dB or higher (ideally). Although they will also work below that signal level.

I would leave it enabled - if you can set the 2.4Ghz WiFi band to say channel 11, the 5Ghz band to channel 48 and set the SonosNet channel in the App to either 1 or 6 and reboot all, router, mobile and speakers and just see if that fixes things. Don’t worry about setting the channel-width to 20Mhz, some routers may not allow that change anyway.

Thanks for the help, tried all of that and not made a blind bit of difference FFS. 

My final thought is to try running ALL on your router WiFi, with nothing wired and play Sonos Radio to the ‘grouped’ rooms and just see if that works for you. If no joy, then it maybe best to submit a Sonos system diagnostic report from within the Sonos App, note it’s reference and then contact/chat with Sonos Support Staff via this LINK and see what the Staff can perhaps suggest to resolve the matter.

Userlevel 2
Badge +4

I’ve checked on the router settings and can’t see how to set the 2.4Ghz band to use a 20Mhz channel-width only? 
 

Do I leave the 5.0Ghz on or switch that off? I don’t really know what I’m doing so don’t want to kill the internet for my 11 and 13 year olds 😂

I would leave it enabled - if you can set the 2.4Ghz WiFi band to say channel 11, the 5Ghz band to channel 48 and set the SonosNet channel in the App to either 1 or 6 and reboot all, router, mobile and speakers and just see if that fixes things. Don’t worry about setting the channel-width to 20Mhz, some routers may not allow that change anyway.

Thanks for the help, tried all of that and not made a blind bit of difference FFS. 

I’ve checked on the router settings and can’t see how to set the 2.4Ghz band to use a 20Mhz channel-width only? 
 

Do I leave the 5.0Ghz on or switch that off? I don’t really know what I’m doing so don’t want to kill the internet for my 11 and 13 year olds 😂

I would leave it enabled - if you can set the 2.4Ghz WiFi band to say channel 11, the 5Ghz band to channel 48 and set the SonosNet channel in the App to either 1 or 6 and reboot all, router, mobile and speakers and just see if that fixes things. Don’t worry about setting the channel-width to 20Mhz, some routers may not allow that change anyway.

Userlevel 2
Badge +4

I’ve checked on the router settings and can’t see how to set the 2.4Ghz band to use a 20Mhz channel-width only? 
 

Do I leave the 5.0Ghz on or switch that off? I don’t really know what I’m doing so don’t want to kill the internet for my 11 and 13 year olds 😂

Basically tried it on and off, made sure the channels aren’t overlapping and it’s exactly the same. 🤦🏼

Think I’m going to have to live with it which is so frustrating 

Userlevel 2
Badge +4

I’ve checked on the router settings and can’t see how to set the 2.4Ghz band to use a 20Mhz channel-width only? 
 

Do I leave the 5.0Ghz on or switch that off? I don’t really know what I’m doing so don’t want to kill the internet for my 11 and 13 year olds 😂

Userlevel 2
Badge +4

Hub is currently wired to my connect which is about 4 metres away but makes no difference. Wired or WiFi it responds exactly the same which seems wired to me. 

Have you tried the WiFi/SonosNet ‘non-overlapping’ channels and channel-width mentioned earlier?

I haven’t mate, TBH I’m not 100% how to do it? 🤦🏼

Hub is currently wired to my connect which is about 4 metres away but makes no difference. Wired or WiFi it responds exactly the same which seems wired to me. 

Have you tried the WiFi/SonosNet ‘non-overlapping’ channels and channel-width mentioned earlier?

Userlevel 2
Badge +4

I’m using a bt smart hub2 which did give me problems at first in a slightly different why though. 
 

The kitchen speakers have been in the same location for years with no problems and no new kitchen electrical products have been placed near them but I will try moving them to see if it makes any difference 👍🏻

thanks for the responses 

Just to briefly mention, that BT Hub is widely mentioned as being problematic here in the community. It seems there are intermittent issues with it, so you might want to try wiring one Sonos device to it and waiting 10 minutes or so for all the Sonos devices to switch to SonosNet. Do not use a Sub or Surround speaker as the wired device. Keep the wired product at least one metre away from the router too. See if that perhaps resolves your issue.

Hub is currently wired to my connect which is about 4 metres away but makes no difference. Wired or WiFi it responds exactly the same which seems wired to me. 

I’m using a bt smart hub2 which did give me problems at first in a slightly different why though. 
 

The kitchen speakers have been in the same location for years with no problems and no new kitchen electrical products have been placed near them but I will try moving them to see if it makes any difference 👍🏻

thanks for the responses 

Just to briefly mention, that BT Hub is widely mentioned as being problematic here in the community. It seems there are intermittent issues with it, so you might want to try wiring one Sonos device to it and waiting 10 minutes or so for all the Sonos devices to switch to SonosNet. Do not use a Sub or Surround speaker as the wired device. Keep the wired product at least one metre away from the router too. See if that perhaps resolves your issue.

Userlevel 2
Badge +4

I’m using a bt smart hub2 which did give me problems at first in a slightly different why though. 
 

The kitchen speakers have been in the same location for years with no problems and no new kitchen electrical products have been placed near them but I will try moving them to see if it makes any difference 👍🏻

thanks for the responses 

“They” responded on another thread equally oddly….

Except that post preceded the above. 

Unless the AI has become self-aware I have to ask …. why? 

“They” responded on another thread equally oddly….

More ChatGPT AI nonsense.

Yep - now wondering if it/she/he will respond to my quoted reply?.. ha ha

More ChatGPT AI nonsense.

What? 

The post was reported, as ‘odd’...

It sounds incredibly frustrating dealing with the ongoing delay issue in your kitchen speakers despite various troubleshooting attempts. Whether it's a Sonos or router problem remains unclear, despite proximity to the router and cable upgrades.

This situation, especially given its persistence, impacts your experience significantly. If resolving this issue requires outside assistance, it's an investment worth considering for the sake of your audio enjoyment. Salary considerations might factor into decisions regarding professional support or new equipment.

What? … It’s probably just a few simple changes to local wireless channels - a five minute read of any router user-manual, or quick start guide, can sort it. Sometimes it’s also just moving a speaker from point A to point B to set it away from the interference source - Also ‘outside assistance’ more often means calling on a helpful mate, or colleague, not paying someone for something that is not any more difficult than changing a light bulb.

This is really getting to me know it’s been on going for months, 

Whenever I play the 2 paired up kitchen speakers there’s a delay when using the volume and also when changing tracks, it only happened on my kitchen speakers.

Wireless interference is my initial guess here - microwaves can be an issue, if you have one nearby, but anyhow see this link:

 https://support.sonos.com/s/article/3286

if I play my kitchen speakers with the playbar and use the volume the playbar works fine but there’s still a delay with the kitchen speakers. 

Note if playing TV audio to Sonos ‘grouped rooms’ there is a 75ms audio delay in this instance and that’s "by design" to cope with networking issues. All should play in sync though when playing music audio, eg: from the Sonos App sources.

It makes no difference if I hardwire my connect which is the only one pretty near the router for sonosnet or I just use WiFi 

It needs more steps than this - you need to ensure the router is using a fixed non-overlapping 2.4Ghz WiFi channel eg: Ch 1, 6, or 11 and then set the SonosNet channel in the App to a completely different channel. I would also set the routers 2.4Ghz band to use a 20Mhz channel-width only. The wired device also needs to be at least 1m away from the router. 

In some cases it’s helpful when using SonosNet to remove the WiFi credentials from the App, but never do that if you have any Sonos ‘portable’ or ‘Era’ products in your system. 

I have a play one upstairs which is the farthest from the router but that is perfect, it’s just the ones in the kitchen that this happens on. 

ive reset everything many times, unplugged, etc but stil a slow response on those speakers. They also relatively near the router too. 

Only factory reset your devices on the advice of Sonos Support Staff, or if you plan to sell your products. A factory reset is likely to not help at all and it will remove any helpful diagnostic information. Sometimes a reset can cause more harm than good… don’t do it often, it’s a very (very) last resort option.

So frustrating, Sonos problem or router problem god knows. 
I was convinced it was a poor quality Ethernet cable so I’ve just bought a better one but it’s made no difference at all 🤦🏼

Perhaps the above suggestions will now help you to resolve your issues.🤞