Answered

Airplay stopped working "Unable to connect to "Family Room 2"."

  • 5 February 2022
  • 8 replies
  • 4964 views

My system has stopped connecting to AirPlay. It worked perfectly for years but then stopped sometime around the end of 2021. I’ve tried various resets and other methods mentioned in this forum but nothing has helped. I can see my Sonos products listed in the airplay options. I’d appreciate any suggestions as to why this is happening and how to correct it.

My system:

  • 2 Play 5s (airplay compatable)
  • 2 Play 3s (not airplay compatable but grouped with the 5s)
  • One Play 5 is wired to the network, the rest are on wifi 

I’ve already tried:

  • Rebooting router after waiting 30 seconds
  • Reconfiguring network settings via sonos app
  • Rebooting Sonos products
  • Ensured Sonos products are showing up correctly in the home app
icon

Best answer by Airgetlam 5 February 2022, 16:59

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

8 replies

Every time I’ve had AirPlay 2 stop working, a reboot of the Apple device, not my Sonos or router, has fixed it. Sample devices is two, an iPhone and an iPad, number of failures has been low, below five over the years since Sonos has implemented it, as a guess. Your situation may be different, but I didn’t see any reboot of the sending device in your post. 

Thanks for the suggestion Bruce. I tried that, but no dice.

Interesting, then it’s evidently something different than what I was experiencing. 

I would recommend that you submit a system diagnostic within 10 minutes of experiencing this problem, and call Sonos Support to discuss it.

There may be information included in the diagnostic that will help Sonos pinpoint the issue and help you find a solution.

When you speak directly to the phone folks, they have tools at their disposal that will allow them to give you advice specific to your Sonos system and network.

Good advice. Thanks Bruce.

Here are some suggestions from Apple sources to fix problems with Airplay connections:

  • Restart all devices and try to AirPlay again
  • Toggle off Bluetooth, or if already off, try turning it on
  • Turn off Cellular Data
  • Disconnect from any other Bluetooth devices
  • Connect to the same WiFi network access point
  • Reset your network settings on your iDevice in Settings > General > Reset > Reset Network Settings
  • Update iOS, and speaker firmware/software
  • Move your devices away from other electronics and closer to the main router
  • Renew your devices DHCP lease via the router configuration pages or reboot the router
  • Switch off any Security/VPN software installed on the sending (mobile) device

Thanksn @Ken_Griffiths 

I’ve tried all of your suggestions, aside from this one as I’m experiencing the airplay issue with multiple devices:
 

  • Reset your network settings on your iDevice in Settings > General > Reset > Reset Network Settings

I got on a chat with Sonos support. They walked me through a few suggestions to get it working but they seem to be stumped as well. I’ll keep trying. I feel it’s related to Apple’s most recent ios updates in some way or another...

Also @Ken_Griffiths, this thread has been very helpful in trying to determine what may be causing this. It’s not solved my mystery, but at least it highlights some dead ends. Thanks.

 

 

I tried airplaying to my sonos speaker from my mac (m1). I got a similar error message: