Sonos: unable to browse music with spotify



Show first post
This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

67 replies

Same problem as other posters: Sonos cannot play music from Spotify Premium as a source. Sonos ‘sees’ our Spotify account as a source: but returns an empty field of blue with “Unable to browse music” when you click on Spotify “Playlists”, or “There was a problem searching” if you use the Search field. System is 5 Sonos players, a Bridge, 3 Macs and 5 iPhone/iPad controllers. Had been working perfectly for a year, until problem exclusively with Spotify started 2 weeks ago. All Players, Controllers and System continue to work fine with all sources other than Spotify. Able to play from Amazon, Pandora and Internet Radio Spotify app itself working fine on all devices, and our Premium account is uptodate. Have removed and re-added/authorized Spotify as a Sonos source 3 times. There is no problem adding and authorizing the Spotify Premium account. Have today uninstalled Sonos, downloaded current controller software for all devices, reset Bridge and Players to factory defaults, and re-configured entire system. No change in problem. Is there a system reset or update that can be done on Sonos’ end that might solve my problem?

yep..mine too...all resolved, looks like it was a backend issue ..now gets those tunes going 😉
yeah! Great fun now - thanks for sort ing out! 
I to can not get Spotify working on my Sonos. Everything had been fine until yesterday and all of a sudden it says 'There was a problem searching. Please try again'. I have tried following the re-boot process outlined earlier in the post and Spotify works fine on stand alone on my MAC. Also the radio function and music library on my MAC works fine through Sonos - just not Spotify, which is annoying as I wanted to play lots of Christmas songs through the system. 
It was working yesterday after you resolved it. Now, it's stopped again! What is going on?
Same issue here...
Same here - very frustrating, You sound like my IT at work "re-boot the system" or how the hell am I going to change my router's channel. I'm just going to stop using spotify but to be fair there is not a lot of options for music streaming. really disappointed. 
me as well - working fine on Christmas eve but had continual problems since yesterday
same for me. worked fine until a couple of days ago now just says "unable to browse music". tried on 3 different devices. reauthorized my spotify account. spotify works ok on its own
Exactly the same problem here in The Netherlands. Must be a sonos problem because spotify app works fine. Getting tired of sonos/ spotify problems.
Im having exactly the same problem in the channel islands! So annoying!!! Sonos need to sort this out ASAP
me as well - working fine on Christmas eve but had continual problems since yesterday
Me too
take the opportunity to try some of the free Radio stations...there's Christmas only ones and every type of genre you can think of--some playing continuous music.
Not really good enough when i pay for Spotify Premium and have a very expensive speaker system that will only allow me to listen to the free radio stations currently ! Spotify works perfectly, Sonos is not !
Yup, adding my name to the list of all those who bothered to find this forum. Spotify through Sonos failed on Christmas morning. Spotify working fine directly on iPad/Macbook, etc., but unable to browse via Sonos. Very disappointing and still can't play music over this Christmas holiday. Tried rebooting everything, reauthorising, and all that jazz -nowt, nada, klum, zilch... 
Same problem here (Netherlands). Apparently re-authorisation and other suggested fixes don't work, so I will wait for an official Sonos solution and successful feedback from some users (I'm not the most technical guy)
So disappointed with my Sonos system! I can't use my spotify account either. It is Christmas - please can you techi guys at Sonos please resolve this ASAP.
Same problem...
Badge
Stopped working again - very disappointed!
None of the recommended solutions work for me so I guess we just wait again for Sonos to accept that they have a problem Again! and sort it out! Merry xmas everybody!!!!!!!!
Same issue as well, this is very frustrating!
Exactly the same issue here. (Netherlands) Never had this issue before.
Same here in Sweden, worked just fine yesterday, today not. I've had this problem from time to time, and to me it seems like a capacity problem from sonos as spotify itself works just fine. When are sonos going to solve this problem once and for all?
If there is a problem with the Sonos Spotify integration then please just let us know and confirm a fix is being worked on. Users shouldn't be wasting time rebooting their routers if the problem lies with the Sonos/Spotify integration.
Exactly same problem as you all.  Worked fine on Christmas Eve then boom - no Spotify Premium all XMAS! Just not good enough Sonos. You need to fix this! 
Userlevel 1
This is so annoying i don't even even have the play 5 24 hours and i already want to get rid of it... 😞