Answered

Play:1 and Alexa : Sonos is linked to Alexa skill but Alexa just cant find the Sonos device

  • 5 December 2023
  • 5 replies
  • 107 views

Badge

Sonos skill WAS  enabled in Alexa but don’t recall any account linking taking place


So  following suggestion's found on here I have subsequently Disabled the Sonos skill and re-Enabled it
That triggers the re linking,  prompted to sign into Sonos account, now says accounts are linked 
closing that screen, next screen is search for device 
But reports “Alexa couldn’t find a new device to connect”
Asks if I can control device using Sonos app -  Yes I can - it tries to connect again - fails again  and again 

Found the suggestion on here about changing the Sonos Play:1 name and going thru whole process again - still no joy  ( tried multiple names/times ) 

Any other suggestions please ?
 

Sonos App : Ver 15:10  on Android phone running Android 11
Sonos OS : S2
Hardware version : 1.8.3.7-2.0
I’m in the UK : so a supported region

icon

Best answer by bob_a_builder 8 December 2023, 10:45

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

5 replies

The PLAY:1 does not have a microphone, and can not be used as an ‘Alexa enabled’ device. 

That being said, I do control a PLAY:1 using an echo dot, using Alexa voice commands.

Badge

Thanks
Yes I’m aware that there is no mic in the Play:1
But do have plenty of Alexa devices here to perform the voice control part
Although the phone running the Alexa app could also do that 
 
If only I could the Alexa app to detect the Sonos speaker ?

Process I’m using 
https://photos.app.goo.gl/ANFDfWsM1Z5tmfvG6

This is the process you should be using:

https://support.sonos.com/en-us/article/set-up-an-amazon-alexa-device-to-control-sonos

If it’s not discovering your device during that, I’d recommend that you call Sonos Support directly to discuss it.

When you speak directly to the phone folks, they have tools at their disposal that will allow them to give you advice specific to your network and Sonos system.

 

Badge

Thanks 
Yes, that linked page is the process I’m trying 

I’ll give them a call later this week , see if they can help

If it gets fixed, I’ll report back here what the issue was

Badge

Called support …..

Feeling a little bit silly ….

Supp: 1st question : “Despite fact its reporting unable to find device, have you tried asking Alexa to play via that device ?”
Me : “Not sure, thought I had !”
Supp: “Give it a try ….“
Me :  “Ah - That seems to be working OK”


So just because it (Alexa)  says “Unable to find a device” 
Don’t necessarily believe it  - Actually try a voice command