No power led on a play 5

  • 7 June 2013
  • 6 replies

I have 2 play 5 units paired , and they have worked without a problem since purchase . This morning they, and the paired sub all dropped off the network, When I physically examined the units, one of the play 5 units had no led light on. I have tried different power sockets, and a different power lead, but the unit does not flash the led when switched on, and is not recognised on the network. I used the pair in the morning, put them on mute, and then this afternoon this problem happened. Is their any way to reset or do I need a replacement ?

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

6 replies

Userlevel 5
Badge +1
Hello Steve, Looks like you've already contacted us and we've setup a replacement for your PLAY:5. Please let us know if there is anything else we can assist you with. Thanks!
We have 3 Play 5's. We opened up this morning and went to turn on the system and one of the units was not connected. The LED light on top is not on and the unit is no where to be found.
Duplicate post.
I was having the same issue.
Hmm, had the Play 5 for four months without a problem. Dropped of the network today, no power light 😞 Came back online briefly but is now not working..................... any suggestions ?
First, submit a system diagnostic from your controller. Then call in to them, their number is to be found at If it is indeed a hardware fault, it can't be dealt with in the boards, only by phone.