Answered

Connect second speaker to wired network


Due to connection problems I just had an online chat with support, and he suggested to connect a speaker (besides the already connected Boost) to the wired network. All 11 speakers are on a ‘wifi-vlan’, and both the Boost and One I try to connect are on that VLAN, both as untagged ports. But when I connect an ethernet cable the One, the network times out, unresponsive. Do I need to set anything special on my network devices (vlan) to connect 2 Sonos devices to the network?

icon

Best answer by ratty 4 July 2022, 13:57

View original

15 replies

With two or more Sonos devices wired the core network has to handle STP traffic correctly, else a loop develops and a broadcast storm takes the network out. Specifically, the wired path between the two (or more) wired units needs to forward BPDUs.

Hi ratty,

Thanks for your quick and really helpful answer. Now I have to figure out how to configure RSTP, if I’m correct, on my TP-Link and 3 Cisco SG200-08 switches. 

Hi ratty,

Thanks for your quick and really helpful answer. Now I have to figure out how to configure RSTP, if I’m correct, on my TP-Link and 3 Cisco SG200-08 switches. 

I think Sonos supports STP rather than the later/quicker Rapid STP, but I guess @ratty will chime in, if I have that incorrect?

This support link maybe of help to you too…

https://support.sonos.com/s/article/2118

Hi ratty,

Thanks for your quick and really helpful answer. Now I have to figure out how to configure RSTP, if I’m correct, on my TP-Link and 3 Cisco SG200-08 switches. 

I think Sonos supports STP rather than the later/quicker Rapid STP, but I guess @ratty will chime in, if I have that incorrect?

Sonos does indeed still use low STP-like path costs, which can cause problems if the core network is at RSTP and two Sonos devices are wired at different points on the backbone. Where the STP wireless path cost is less than the RSTP wired path, SonosNet will wirelessly bridge all the traffic that ought to be carried by the backbone.

Thanks guy for your support, hopefully this will clarify the situation more. It’s a complicated subject for me, because I’m not a network guy. So I’ve created a simple drawing, because my home environment is simple 😉. I have also added screen shots of the individual switches with STP settings.

 

 

You can check what SonosNet is doing from the Network Matrix at http://x.x.x.x:1400/support/review. x.x.x.x is the IP of a player, not the Boost.

That will reveal whether there’s an active wireless tunnel between Boost and Bedroom. If there is, then something will need to be done in the switch settings.

Because the Boost will create the STP storm, it’s not connected. I wouldn’t be able to see the setting in that situation. 

So I’ve created a simple drawing, because my home environment is simple 😉. 

Well, you’ve sure chosen to complicate things then by using enterprise managed switches and VLANs. 

Your second image above is labelled ‘Boost connected’, yet port 5 appears to be disabled? Have you changed any of the switch settings from their defaults? RSTP is clearly active, based on the port costs. Can you not configure the switches to use Classic STP? 

You’re right, I should have said that port #5 is the Boost port, but it’s not connected. These switches can do STP, so I’ll double check the setting.

It seems like both the switches are STP configured, not RSTP, right? Or am I missing something?

 

 

 

 

OK, first of all, thanks especially @ratty, because you pointed me into the right direction. I turned out that my ‘core’ switch didn’t have STP enabled on the interface connected to the next switch. So I got 2 speakers connected now, but it still not great. In the living the players pick up the stream in 1-2 seconds, great! But the next level in the house takes sometimes minutes before the stream is picked up. I will check with support as well (04071100), but ideas are very welcome.

OK, first of all, thanks especially @ratty, because you pointed me into the right direction. I turned out that my ‘core’ switch didn’t have STP enabled on the interface connected to the next switch. So I got 2 speakers connected now, but it still not great. In the living the players pick up the stream in 1-2 seconds, great! But the next level in the house takes sometimes minutes before the stream is picked up. I will check with support as well (04071100), but ideas are very welcome.

Did you double-check your switch STP settings with the Sonos support document-link posted earlier…

This one: https://support.sonos.com/s/article/2118

…and is all good there?

I’ve tried to get the exact settings, but I’m working with Cisco, as well as TP-Link. It says: Bridge Settings is Priority 4096, is that the global setting for the switch?

Bridge Settings
Priority

4096

I’ve tried to get the exact settings, but I’m working with Cisco, as well as TP-Link. It says: Bridge Settings is Priority 4096, is that the global setting for the switch?

Bridge Settings
Priority

4096

Don’t know, not sure. It’s not really my area, but I’m all for trying such things, to see if it may improve the lag you’re experiencing. 

Reply