Answered

Sonos Roam and Airplay

  • 20 November 2022
  • 10 replies
  • 218 views

Hi,

Do you have problems with Airplay with stutters on Roam right after turning it on?

Let’s say we have 4 states:

1 - when Roam is tuned on and available in network and it’s the only state that allows to play music

2 - when Roam completely turned off, after 12 second press on the back button

3 - when Roam is in sleep mode, after press on back button

4 - low power mode after several minutes on inactivity when WIFI POWER SAVE setting is on.

So, transferring from state 1 to 2 and back to 1 (1->2->1) enables stutters. Then transferring from 1 to 3 and back to 1 (1>3>1) n amount of times fixes that.

I spoke with Sonos Support and got replacement. The new Roam that I received has exactly the same problem. I tried in different networks with different routers and result is the same.

icon

Best answer by Corry P 30 November 2022, 11:14

View original

10 replies

Update: 14.19.1 did not fix the problem

Userlevel 7
Badge +18

Hi @delexa 

Welcome to the Sonos Community! If you reply to yourself, your topic is no longer “in need of reply”, so it may take longer to get an answer.

AirPlay involves 4 things - the app on the broadcasting device, the broadcasting device, the network and the target speaker.

So far, you have replaced the speaker and tried on another network, with no change in the results. As I think it unlikely to be the app that’s playing and more likely the device it’s playing on, have you tested the Roam on another phone/tablet, or tried rebooting the one you have?

I hope this helps.

Hi @Corry P 

I’ve tried to use 2 iPhones as Internet access point and connect Roam and another iPhone to them as controller. I also tried to use 3 different controllers - 2 iPhones and one Mac. The result is the same. Of course, I rebooted iPhones and Mac and even reseted Roam several times.

I believe that problem is in hardware or firmware.

Roam does not stutter all the time when I play something via Airplay. It stutters the first n minutes after turning it on and when it stops stuttering after n minutes, it does not stutter upon the next time I turn it off (or it does automatically if Battery Saver is on in the Sonos Roam Settings) and turn on. Amount of minutes n is random number, but it usually 3<n<30.

Userlevel 7
Badge +18

Hi @delexa 

Thanks for the details.

I can only recommend you get back in touch with our technical support team - they should at least be able to determine the source/cause of the interruptions for you.

For what it’s worth, I just rebooted my own Roam and immediately connected it to my Android phone via Bluetooth and played without issue. Unfortunately, I have no iOS devices to test with.

test

@Corry P 

Thanks for your answer. I am currently in process with support team and already on Level 3 Engineers.

There’s no problem with Bluetooth playing for me either. The problem is only specifically with Airplay.

Userlevel 7
Badge +18

Hi @delexa 

Ah, I may have glossed over that when coming back to the thread. Apologies.

Well, if anyone can help, it’ll be the L3 wizards.

Hi @delexa,

Did you make any progress with L3 support? I had what sounds like essentially the same problem with a Roam early last year and was working with support to resolve. After a few of weeks of back-and-forth, they offered to replace it but by then I only had a few days left to return for refund so I chose the latter. I rolled the dice again in the summer and bought a pair of Roam SL hoping that first one was defective, but quickly established that they had the same issue - it definitely seems like a hardware/firmware problem. They did suggest it could be related to a bad router, but it seemed unlikely as it was a then fairly new Eero 6 Pro. I didn’t stay in the ecosystem long enough to troubleshoot that theory, but would really like to jump back in if they can get this issue sorted.

Hi @papaskitch 

I did have some progress with L3 support team. I spoke with them in the beginning of December and in the end of my communication with them they were be able to reproduce my issue. According to what I understood, the issue is somehow connected with usage of Bluetooth on both, controller devices and Sonos speakers.

The guy, with whom I spoke told that he’s going to be in touch with me if they have a next step, or once they know more around this problem. He told that they were investigating this issue at that time. And since beginning of December I don’t have any update about this.

To use my Sonos Roam without stutters I do not turn off my Roam. When I am not using it, it stays on wireless charging station. But I hope Sonos team will finally fix the issue in the next firmware update.

Hi @delexa,

I’m glad to hear they can reproduce the issue, and I hope they can fix it (perhaps I shouldn’t have given up so quickly). Maybe not related, but I see they’ve added some bluetooth settings in 14.20 so it looks like at least they’re working on some bluetooth related items.

 

 

Reply