Roam unable to register - Ready to return

  • 6 February 2023
  • 12 replies

Userlevel 1

My current setup has a BEAM gen 2 up and running easily on the wifi network for my TV.


I bought Sonos Roam SL as a speaker to connect to my computer a bluetooth device.


I have tried this numerous times:

  1. Factor reset (power + play) wait for green blinking
  2. Sonos app (iOS) go to system and add device.
  3. Device shows up, connects to my wifi (takes a few minutes)
  4. Shutdown (5 second press) and startup
  5. Shows in my Sonos app -- as unregistered.
  6. Click to register, asks for my account + password

At this point, it NEVER works.  Says something went wrong please try later.  Wow, that’s as useless an error message as you can get! 

My online profile shows my Roam SL registered, so it got to your website.


I figured, ok don’t care if it doesn’t work over wifi, I need bluetooth anyway:

The instructions say press-hold power button to get pairing tone and blue light… NEVER happens…

I’ve seen conversations about getting the firmware updated.. how can I accomplish that?  The sonos app doesn’t see it registered and there doesn’t seem to be an option to ‘upgrade firmware’.


And to add to the pain, when I’m in this state in the Sonos app, the Beam often drops out and disappears on my IOS app.


Please, all I want to do is to use this as a bluetooth speaker.  It shouldn’t be that hard. 

I see notes about “rebooting” your wifi network.  Well, I did that.  No improvement.  I do see the device on the wifi, so I did DHCP reserve the device to insure the IP address is always the same.


BTW, “reboot your network” are you kidding me?  I’ve got servers and multiple computers running my wifi and hard wired for the home and family.  I bit the bullet and reset the wifi.  Same results.  You can’t tell me it’s the WIFI problem.  I have synology mesh network, and if I try to connection with IOS app when I’m roaming on the remote: forget it, I can’t get anywhere. I don’t have a restrictive firewall, no content filtering, UPnP is enabled if needed (can’t imagine sonos would use that -- I hope not).  Its as open as any basic WIFI can be set to safely.


Sonos, please let me know how to proceed.  I love the speakers but your software is -- well -- * at this point. 




*Moderator Note: Modified in accordance with the Community Code of Conduct.*

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

12 replies

Submit a diagnostic and post the confirmation number here.

After submitting the diagnostic, resetting the controller App might help.

Userlevel 1

And how would I submit a diagnostic?   It never connects back to the sonos application on IOS.  It will not show up on the windows version of the software. 


How do I reset the controller app?  Close it out in IOS or is delete the data? 



Agreed that if you can’t connect, you can’t run a diagnostic. 

For a large portion of the masses, the ‘reboot your network’ is not bad advice, but it is certainly not a panacea for all issues. 

I’ve got a Synology NAS, but will admit I’ve never heard of them providing a mesh network device before. Not that I’ve looked, mind you.  And since we’re talking about the Roam, you obviously can’t wire it to the root of the network. 

One thing I’d try, before calling Sonos Support directly to discuss it, is unplugging all ‘mesh’ extenders and see if you then can connect. It’s possible, not knowing anything about a Synology mesh network, that the Roam is on a different subnet than your controller/iOS is, and hence can’t make contact. I’d stay away from the windows controller for the moment, and stick with the iOS one.


Is that the Synology MR2200ac? Which bands are you using? 

Resetting the controller.


Userlevel 1

I have experienced similar issues with Roam and no longer trust it.  It is extraordinarily finicky to connect and keep connected.  Furthermore, the fact that you need to register it to Sonos before use is a nonstarter for a portable speaker sold to be taken anywhere. 

Most recently, we experienced connectivity issues on a trip with no wi-fi to register the device once we reset it, effectively rendering it useless for the remainder of our trip.  It’s been in my drawer ever since and won’t be the speaker I grab for our next trip. 

Once it’s been set up on Wi-Fi, why would you ever reset it?

Userlevel 1

Because it continually runs into Bluetooth connectivity issues, even past initial setup.  I was directed to reset the device by both Sonos troubleshooting documentation and also by a live Sonos Rep over phone support. 

Huh, thanks for the response. 

It’s odd, I guess, since I set up my Roam, I’ve never had a single issue connecting to it with multiple Bluetooth devices. But I’ve never tried a reset of my Roam, either, and certainly wouldn’t consider doing a reset of a device while away from home. I guess the CS rep either didn’t understand that you were away, or gave you bad advice. 

Userlevel 1

It is possible that I have a bad device, although that is not the conclusion that Sonos arrived at.  The Sonos rep I worked with did state that they would look at updating their SOP for device connectivity and resets.  On the phone, the rep didn’t foresee how WiFi connectivity could be an issue and was initially perplexed as to how I wouldn’t have connection.  In my opinion, it’s not that uncommon to be somewhere without a network at all or where a public WiFi network won’t suffice for this use.

Given it is a speaker designed to be used away from home, I don’t see why they would require registration prior to using it over Bluetooth to begin with.  Let me register it when I get home and want to connect it to the rest of my system, but in the meantime I think the Bluetooth should be enabled. 

I had the same issue as described with my roam (I had to reset everything due to an major issue), all my other Sonos products factory reset and connected fine, the Roam kept failing at the final step and simply said unable to register.

Long story short, I turned the 5GHz radio off on my router. Tried again and worked perfectly. So I’d say it’s a problem with wifi band. Use 2.4GHz on its own for this process and then reenable afterwards.