Bluetooth on Roam

  • 21 April 2021
  • 54 replies
  • 19226 views

Cant connect, only getting a white colour appearing, Roam not showing up as a device in Android when next to it

Oh and the App is useless BTW bit will keep product if can Bluetooth it !


54 replies

Delighted the issue was able to be resolved!

Thank you again  Bruce.   I called customer support today (finally at a place with stable Wi-Fi and cell service)…   the wait was short,  the agent was knowledgeable and walked me through the setup steps successfully and I’m listening to music over Bluetooth as I write this.    Relieved I won’t be carrying a brick for 2 months,   and happy to have exactly what I intended to have when I chose the Roam for this trip and later home use.    Without your support I might have tossed it into a river in frustration - I appreciate you.   

Norton

Agreed, it won’t function as a Bluetooth device until it’s been set up as a Sonos device. I’ll be interested to hear what CS has to say. 

As a guess, I’d be saying a VPN or other port blocking software, but it’s hard to tell remotely. 

Bruce, 

 

Thank you for that.   To clarify, it's the Sonos app crashing.   I tried both your suggestions, but no luck.  Next I'll take your suggestion to call them.   

 

The behavior is:

 

Launch app

Add product, it finds Roam

It displays a window saying Setting up Roam, then crashes 

As far as I can tell, I can't use it as a Bluetooth speaker with other audio apps on my phone until I clear this step of adding it to a Sonos system.   

That’s odd. Once it’s set up, the Roam should be able to be connected to by any compatible Bluetooth device. Not just the single device that set it up originally. 

What app crashes? When using Bluetooth, you shouldn’t be using the Sonos app, but any other music app. 

Although you say you’ve done so, I’d be tempted to try another factory reset. If any app is crashing, it seems as though the factory reset didn’t ‘take’. I’d also be tempted to delete the Sonos app, and download a fresh one from the Apple or Google stores, on the offhand chance that it has become corrupt.

Finally, I’d really be tempted to call Sonos Support directly to discuss it.

When you speak directly to the phone folks, they have tools at their disposal that will allow them to give you advice specific to your Sonos system and network.

I set up my Roam on my home system on WiFi and verified it worked as a WiFi speaker in a group,  and as a Bluetooth speaker.   

 

Then,  I broke my phone,  and had to get a new one,  just as I left town for 2 months.   I bought this Roam to be my Bluetooth speaker on this trip.   

 

My new phone didn’t connect to the bluetooth…   I went to a place with Wifi,  and started a new system in the Sonos App,   factory reset the Roam,  and tried to add it as a speaker in the app.    The app sees it,  and tries to add it,  but crashes every time.   

Any thoughts on what I need to do?   

 

Thanks!

I got my Meander before 2 day and I set it up and could play it on both Wifi and Bluetooth. I was all the while having the chance to grasps with it and I some way or another figured out how to lose the Bluetoth functionallity. I figured out how to reconnect to wifi yet from that point forward I can not set it up for Bluetooth. I'm squeezing the button on the back however the main light that seems is the white one which is either steady or glimmering. The orange light shows up at the base as well.

Any thoughts how I can figure this out please? PS When it works it sounds magnificent

your recommendation will highly appreciated. Thank you

I think you described it very well. great <3

I got my Meander before 2 day and I set it up and could play it on both Wifi and Bluetooth. I was all the while having the chance to grasps with it and I some way or another figured out how to lose the Bluetoth functionallity. I figured out how to reconnect to wifi yet from that point forward I can not set it up for Bluetooth. I'm squeezing the button on the back however the main light that seems is the white one which is either steady or glimmering. The orange light shows up at the base as well.

Any thoughts how I can figure this out please? PS When it works it sounds magnificent

your recommendation will highly appreciated. Thank you

 

https://support.sonos.com/s/article/4989?language=en_US

Thank You 

 

I got my Meander before 2 day and I set it up and could play it on both Wifi and Bluetooth. I was all the while having the chance to grasps with it and I some way or another figured out how to lose the Bluetoth functionallity. I figured out how to reconnect to wifi yet from that point forward I can not set it up for Bluetooth. I'm squeezing the button on the back however the main light that seems is the white one which is either steady or glimmering. The orange light shows up at the base as well.

Any thoughts how I can figure this out please? PS When it works it sounds magnificent

your recommendation will highly appreciated. Thank you

 

https://support.sonos.com/s/article/4989?language=en_US

I got my Meander before 2 day and I set it up and could play it on both Wifi and Bluetooth. I was all the while having the chance to grasps with it and I some way or another figured out how to lose the Bluetoth functionallity. I figured out how to reconnect to wifi yet from that point forward I can not set it up for Bluetooth. I'm squeezing the button on the back however the main light that seems is the white one which is either steady or glimmering. The orange light shows up at the base as well.

Any thoughts how I can figure this out please? PS When it works it sounds magnificent

your recommendation will highly appreciated. Thank you

Most devices do have a make and model number (and other pieces of information) printed on a label on the bottom of the device. No need to find the documentation, just flip it over for a moment. 

It's quite hard to help with such  vague information. Surely the "repeater" has the make and model on it?

Do you know if the repeater is in bridge mode, also known as access point mode?

Which SSIDs have you entered into Sonos?

Userlevel 3
Badge +5

Hi John and thanks for getting back to me

I have the modem and the router in my living room, the modem is a circular device with a LED on the top and Ethernet ports, and this is the one I’ve worked with, the modem that is the square with an Antenna, and the repeater in the guests building. I don’t know the models of these network devices, I need someone in my home  who can take a look at them, as well as changing the wireless channels and yes, the SSIDs are different too     

Hi. I’m a bit unclear.  Do you have one router, with a repeater / extender that creates a second network?  Or do you have two routers, and a third device (extender / repeater) that is part of one of those two networks?  Essentially, are there two or three devices?

SSID is the WiFi name. Channel 48 is in the 5GHz band. Channels 1, 6 and 11 are in the 2.4GHz band.

Please give model numbers for the router and the repeater.

Userlevel 3
Badge +5

Answering your questions, my main network seems to be 2.4 gigahertz because we had the 5 gigahertz but it  was removed, it no longer appears in the list,  but my Roam is connected to the second network because it seems more reliable for it to work because I noticed it was having many issues with the main one, I don’t know why, is the strongest.

We have two networks because my house is too big, in the back we have a new building for guests, where we have a dining room/ kichen downstairs, and upstairs a music livingroom, 2 bethrooms and a bathroom, and there isn’t enough signal for the main router so we had to put a repeater, and yes, they have different names and different passwords, and I don’t know anything about the SSIDs, neither  the channel of my main network, but the Tech support noticed in a diagnostic that my Roam was using the channel 48 and 2.4 gigahertz, but I don’t know if my provided network has the ability to change the channels into either 1 6 or 11 which are the ones that Sonos recommends for minor wireless interference. 
Thanks for your kind help guys      
 
 

Userlevel 3
Badge +5

I’ll try firstly to set my wireless channel into my main  router hoping it would solve the matter, anyways, it’s been stable with Bluetooth playing content from YouTube, no audio  drop outs at all so far after a large reboot of my router an reinstalling the Sonos app   

I'd be happy to see if I can help make your Roam stable. Shall we try?

First question has to be why do you have two networks?

Do both routers have 2.4 and 5GHz bands? Do the bands have separate SSIDs.

Does the extender have the same SSID and password as one of the routers?

 

 

Well John, I’m not  criticizing Sonos in any way, be aware that I’m just trying to find a solution to these issues, trying to stop my roam from behaving unstable, as technical support in Mexico is so unresponsive. 
I absolutely love my Roam as a sounding speaker, sounds great being too small, I tested outdoors near the beach and it was amazing. I just want to stop it from being so unstable, Which network requirements does it need to work flawlessly and errors free? Reading many posts here in the community, it seems to be a común issue without any fix, and this is the only and the first Sonos speaker I’ve ever had, so, if I don’t find any efective sollution to this issue, I’ll probably be returning it soon       

Have you yet gone onto try the suggestions provided to you earlier, in the various other threads - for example: Shift the Roam off your 5Ghz WiFi band onto the 2.4Ghz band and select a channel-width of 20Mhz?

Userlevel 3
Badge +5

Well John, I’m not  criticizing Sonos in any way, be aware that I’m just trying to find a solution to these issues, trying to stop my roam from behaving unstable, as technical support in Mexico is so unresponsive. 
I absolutely love my Roam as a sounding speaker, sounds great being too small, I tested outdoors near the beach and it was amazing. I just want to stop it from being so unstable, Which network requirements does it need to work flawlessly and errors free? Reading many posts here in the community, it seems to be a común issue without any fix, and this is the only and the first Sonos speaker I’ve ever had, so, if I don’t find any efective sollution to this issue, I’ll probably be returning it soon       

Why is the Roam the only problem?. Possibly because it is only one that has to talk to another device or devices across your network.

You have two networks, one with an extender. Extenders are not supported by Sonos. You can get away with a poorly configured network with lots of devices, but not Sonos. And your network situation sounds a bit of a mess. 

But you have clearly made up your mind that it is the Sonos that's the problem, so I wish you well

Userlevel 3
Badge +5

Thanks for your reply  John, I appreciate it.  Reliable? Stable? Mmmh! 
Well I have a modem, the Router and a Wifi repeater, and two networks with different names, but in my main network it often has connectivity issues, so I need to change it to an other network. Even though, Alexa gets stuck, Airplay cutting out, Apple Music stopped and skipped the last week or so, etc. 
The walls in my home are made of concrete and clearly this can interfere with the signal, but here my concern is:  none of my other devices are having  an issue, neither my iPhone 11, neither my iPad Pro, neither my HP laptop, neither my Alexa 4th gen,   neither my brother’s  Xbox Series X and neither  the rest of all other Devices in my network, just the Roam. Why? I’m glad I’m not the only one, but looking at other posts here in the community, many people don’t seem to fine an effective solution to these issues. What is the main cause?    What should I do if one of  my  neighbor installed a new device that’s causing interference in my environment? Talk to him and explaining that I have issues with my network? Let’s fix it. 
Thanks a lot for your kind help 

I’m so sorry but if I don’t find an efective Sollution to these issues, I’ll be returning it soon. 
Great speaker, anyways 

The Roam, like other Sonos speakers, is stable and reliable.  If you are having problems when it is on your network, then the issue is a networking one - drops in sound are due to network issues 99.9% of the time.  This does not mean that there is anything faulty about your network. if may be that a setting needs changing somewhere, or that there is wireless interference. Or maybe just that you are too far from the router.

Tell us more about your router and network.  Is it a mesh? Any extenders or access points?  Dual band?

You have to resolve this.  There is nothing for Sonos to resolve.  My Roam, like Bruce’s, operates without a hitch.

 

Userlevel 3
Badge +5

I’m so sorry but if I don’t find an efective Sollution to these issues, I’ll be returning it soon. 
Great speaker, anyways 

I’ve never had an issue with my Roam on Bluetooth. 

Reply