Answered

Problems connecting to CNBC via TuneIn

  • 27 February 2020
  • 49 replies
  • 1058 views

This week I have had problems connecting to CNBC on my SONOS system via Tunein.  The CNBC stream will start as expected then drop off after about two minutes.  The Tunein CNBC stream works fine on other devices on the same WIFI.  It appears that the problem is with SONOS. 

 

Is anyone having a similar problem.  

 

Scott

 

Update:  The CNN Station failed after five minutes.  Now I assume its not just CNBC.

icon

Best answer by Sebastien D. 28 February 2020, 21:16

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

49 replies

It seems to be related to the Tunein services like CNBC, CNN….   initiated by voice commands to Alexa to play on a Sonos speaker.

Example: “Alexa, listen to CNN in the Bedroom”   Alexa says something like “Will play CNN through Tunein in the Bedroom” Bedroom is a Sonos Play 3.  Bedroom will then play CNN (or whatever Tunein Station I asked for) for 5 minutes or so as expected then fail. 

NOTE: Until Monday this week this process has worked for years flawlessly.

Userlevel 5
Badge +16

Hello @Gnibbil, I stand corrected.

Your Sagemcom Fast 5280 is a router only and does not have a built in modem as many other ISP provided routers do, my apologies. 

You should receive an update for this issue when we have a fix, this is something that we are aware of and working on a solution for.

Meanwhile, you should be able to listen to these services by triggering playback through the app. 

We know that this is less than ideal but we’re working on it.   

  

Badge +1

It seems to be related to the Tunein services like CNBC, CNN….   initiated by voice commands to Alexa to play on a Sonos speaker.

Example: “Alexa, listen to CNN in the Bedroom”   Alexa says something like “Will play CNN through Tunein in the Bedroom” Bedroom is a Sonos Play 3.  Bedroom will then play CNN (or whatever Tunein Station I asked for) for 5 minutes or so as expected then fail. 

NOTE: Until Monday this week this process has worked for years flawlessly.

I am having the same situation...up until a few weeks ago everything was working fine. 

Badge

I am having this same issue with a similar configuration - it is specifically with CNBC and CNN through tunein.  It definitely happens when using Alexa but I think it is happening when I launch it from the app as well.   I was able to play other music and news through tunein.  I am also able to play CNN/CNBC through an Alexa device without an issue.  Just the feed through Sonos is the problem.  

 

Have had numerous calls with Sonos support.  Have reset router.  Have hardwired one speaker into the modem and then tried selecting different channels.  Have tried different groups and individual speakers to see if there was one offending speaker.  Nothing has worked.  This just started happening a week or two ago.   Given it is happening to other people this seems to be an issue with Sonos / Tunein rather than our individual systems.

Apple music, pandors, etc all work fine.

Help!!!

 

Userlevel 5
Badge +16

Hi @Gnibbil 

It’s an oddly specific issue, that’s what is so strange about it. 

So asking Alexa to start playback of any of those four stations to the Office Play: 5 results in playback stopping/dropping.

Starting playback on any other service or starting playback through the Sonos app results in no playback issues at all, correct?

The Office Play 5 is wired directly to your ISP provided router with no network switches or pass-throughs and yet audio is stalling out.

The only errors I’m explicitly picking up are interference and bandwidth related which I assume would effect playback on other services and playback methods.

I assume that you have run a speedtest on your WiFi network, yes?  

   

 

Badge +1

I have gone through all the steps and still have issues when using Alexa version of laying channel...playing channel via sonos app is fine. 

Badge

Yes, my Speedtest is over 100 download speed.   
 

the odd thing is that it will play for 10 minutes or so before cutting out - it doesn’t happen right away 

Userlevel 5
Badge +16

Can I ask if both your Arris modem and Sagemcom router are ISP provided? 

Is there a particular reason for having both a modem and a combined modem-router?  

It does look like your support ticket has been escalated and hopefully we can figure this one out with you. 

Badge

Both devices were provided by the ISP (Charter Spectrum);   I didn’t realize the router was also a modem - I was under the impression it was just a router 

 

this system all worked fine for over a year (same hardware etc);  it just suddenly started doing this a few weeks ago when I hadn’t changed anything in the system 

Userlevel 4
Badge +11

Try power cycling your Sonos products by unplugging them directly from power, leave them off for about 5-10 seconds as I see they have been up and running for at least a few weeks. After the reboot Sonos will take a couple of minutes to boot up again. When it does, please check to see if CNBC continues to play via voice command.

Report back with a new confirmation number if the problem continues.

Userlevel 4
Badge +11

Welcome to the community @manshms ,

Are your stations saved under My Sonos or Sonos Favorites within your Sonos app? If so, are you to get the station playing after browsing directly in Radio by TuneIn on your Sonos system?

I was playing with that this morning.  I can listen to CNBC by using the Sonos app no problem.  In the previous scenario (I forgot to mention) I was using Alexa to activate CNBC on my Sonos system. As I have for years.   Therefore it may be an issue with Alexa and Sonos.

Userlevel 4
Badge +11

Does the issue occur when you initiate playback from other music streaming services besides CNBC stations via voice command?

Userlevel 4
Badge +11

Scott,

Submitting a diagnostic through the Sonos app provides us with a snapshot of your system so we can help identify what is causing your issue. Then, please reply back the diagnostic confirmation number so I can take a closer look at the issue.

 

Badge +1

That has not made a difference. 

350009525

 

Thanks

 

 

Userlevel 4
Badge +11

Do you have Amazon Alexa setup at another physical address under the same Amazon account?

Badge +1

no

Userlevel 4
Badge +11

Thanks for posting the confirmation number. Let’s start off by rebooting router by unplugging it from power for 5-10 minutes then plug it back in. Once you have internet back online, I would also recommend power cycling your Sonos products for 10-30 seconds.

 

If the issue still persists, disable the Sonos skill and re-enable the skill within the Alexa app.

Badge

I’ve confirmed with my system as well - I can play CNN/CNBC using the Sonos controller to start it, but when I start it using Alexa it fizzles out after several minutes.   Other tunein channels I use play when I start them with Alexa with no issue.   This is some connection between Tunein-Alexa-Sonos-CNN/CNBC specifically.   Very strange

Userlevel 4
Badge +11

I have recently looked up the CNBC skill within the Alexa app. Try and see if you can enable the CNBC skill and let me know if that worked.

Badge +1

Nope.  Not playing at all right now.  Asking “play CNBC live”. It replied, from tunein here is the CNBC audio stream...then I get nothing at all.  
 

Userlevel 4
Badge +11

Then try these steps below:

  1. Disable the Sonos skill in the Alexa app.  DO NOT re-enable the skill, leave it disabled.
  2. Now, remove Voice Services for all voice enabled Sonos devices under the Amazon Alexa menu in the Sonos app, one room at a time. Tap on the Room to choose the option to Remove Amazon Alexa.
  3. Log out of all Amazon Apps on the mobile device, i.e. Amazon Shopping App & Alexa App, and Amazon.com.
  4. Go through the Alexa Setup in Sonos again.
  5. When prompt to sign in, ensure this is the correct Amazon account to link Alexa.

 

Once voice services have been re-enabled, test music playback from other music streaming services if possible.

Userlevel 5
Badge +16

@Gnibbil 

This issue is not yet resolved, we’re still working towards a solution on this. 

There will be an announcement when we have a resolution here.  

Badge +1

Same issues!