Planet Rock unable to play unless select again from My Sonos stations


Userlevel 6
Badge +7

I have the proper Planet Rock plugin (or whatever it is called!) for Sonos and it seems to work every time on my Roam, but on the lounge speakers, if I don’t play it for a day or so, when I then press play on the Lounge it is never able to play - it comes back with “can’t find Planet Rock station” or something like that.

I then have to re-select it from my radio stations on My Sonos and then it plays fine. It does the same thing no matter which app I use - I have it on an iPad Pro and on an Android phone. They both have the same issue.

 


45 replies

So do I take it that mine will be set to Virgin DNS Servers?

Because the person didn’t explain why and what the new settings were, I was reluctant to change my settings!

The VirginMedia DNS servers are (usually):

194.168.4.100 & 194.168.8.100

I’ve just changed my router to the Google public DNS…  8.8.8.8 and 8.8.4.4 and will also try the cloudflare public DNS server 1.1.1.1 too when I get a chance, just to see if that makes any difference.

Userlevel 6
Badge +7

I’ve just been into my Hub3 settings and can see no way of changing my DNS servers so that is not an option for me. Thanks for trying this for me.

 

Actually I just read something on the Virgin forums saying that the Hub3 has no facility to allow you to change the DNS servers!

Ah okay, The only way around such ISP restrictions would likely be to use their Superhub in "modem mode" and just add your own router.

I personally prefer to have my own router, but appreciate that’s not going to be the case for everyone. 

If it does prove to be a DNS issue, I assume you could take-up the issue with VirginMedia, I guess🤔?, but perhaps let’s see what happens now that I’ve switched to the DNS servers suggested.  

I’ve just been into my Hub3 settings and can see no way of changing my DNS servers so that is not an option for me. Thanks for trying this for me.

 

There are ways of achieving this. Probably the easiest would be to put the Hub3 into modem mode and run your own wireless router instead. (Edit: Ken got there first on this point.)

Alternatively (if feasible) disable the Hub3’s DHCP server and run your own somewhere on the LAN. Since your own DHCP server could well be a re-purposed Ethernet router it might be argued that you may as well go for the first option, unless you already had an old low-power router lying around.

FWIW I don’t rely solely on my ISP’s DNS (I’m with BT), having had periodic resolution failures in times gone by. I supplement the BT servers with Cloudflare. 

Userlevel 6
Badge +7

For a while now I have been thinking of getting my own router - one with at least 4 gigabit network ports and wifi. At the moment with my Superhub3 I can only have one wired Sonos speaker whereas when I had my own router before (it broke so had to switch hub3 into router mode) I had most of my speakers wired.

I’ve had my eye on a TP-Link AX1800 on Amazon as it seems to get a lot of good reviews but it always feels like it’s going to be a hassle having to reconfigure things and keep my fingers crossed that it doesn’t cause any issues with Sonos.

 

I wouldn’t imagine that the TP-Link router would be any problem at all for your Sonos. Your system is wired/SonosNet, so it’s not reliant on the WiFi other than for controller connection. I have a bunch of TP-Link WiFi kit and it all supports Sonos without problem, both for controller devices and for WiFi-only (portable) players.

By the way, you’re restricted to one Sonos device wired directly to the Hub3 because of STP issues. You could always add a small switch and wire multiple Sonos units through that.

Userlevel 6
Badge +7

The last time I tried it didn’t matter where I had the Sonos devices plugged in, it still caused problems.

And looking at the issue report on Sonos about this, it does say to only wire one Sonos device.

 

 

That article says connecting more than one product to the router with an Ethernet cable results in a broadcast storm. This is a classic case of the router blocking STP traffic between its ports (which the SH3 is known for), leading to an undetected network loop if more than one Sonos device is wired directly to it. This situation shouldn’t arise if the whole Sonos system hangs off a single router port, either via a separate switch or by daisy-chaining.

Userlevel 6
Badge +7

OK I do have some daisy chained switches so might give it a try. I can’t remember if when I tried it before, the switches were connected to more than one port on the router.

Thanks

 

I thought I would just quickly give the paused ‘Planet Rock’ Station a quick try, having earlier switched the DNS servers ..and it did play ok for me this time, that’s after 3 to 4 hours of it being paused.

So will now leave it overnight and just see what happens tomorrow.

So after the router DNS change yesterday, I’m still seeing the issue after 10+ hours of pausing the station - it seems it does timeout at some point. Diagnostic Report: 484082776

It starts what is presumably a new session when going into the service and starting the station afresh.

I’m pretty sure this is going to be ‘by design’ and that the Station drops the session at some point post-inactivity.

Userlevel 6
Badge +7

Thanks for trying this. At least I know I don’t need to change my router for the DNS Server settings.

It’s not a major issue but I just have to remember to reload the Planet Rock station every time and that’s not my usual way of using the app :)

I may still change my router at some point though because if I have to “upgrade” to the Hub5 at any time soon, I’m hearing about lots of issues with this in day to day use and most people are being advised to use it in modem mode.

 

I may still change my router at some point though because if I have to “upgrade” to the Hub5 at any time soon, I’m hearing about lots of issues with this in day to day use and most people are being advised to use it in modem mode.

 

As a matter of academic interest, has there ever been a VM Hub which folks happily use as a router?

As a matter of academic interest, has there ever been a VM Hub which folks happily use as a router.

Their Superhub2 (Netgear) was about their best, but that got worse with each new update and it went downhill after that. It became hackable too, allegedly.

VM have now added Plume WiFi mesh (in bridge mode) for some of their users on their 1gig connection, but at an added cost of £5+ per month. 

I do use their v5 Superhub (802.11ax) but it’s just in ‘router mode’, it’s features are limited… and so is Plume for that matter. It seems they don’t like users changing very much at all, guess it leads to support requests which they now do via WhatsApp text/chat by the way - which I find poor too.

I’ve perhaps been a bit unfair on VM in my last post, their broadband speed is excellent and admittedly there have been very few disconnections in the past 20+ years that I’ve been with them, so I’m not complaining about their service, just the hardware is not very configurable. At one point they limited DHCP reservation to 16 devices only (just as an example).

Userlevel 7
Badge +18

Hi @JohnG666 

Thanks for your post!

I took a look at your diagnostics and potentially found a not-uncommon issue with your Virgin Media Super Hub 3’s DHCP lease time. Please log into your router and check the DHCP Lease time and check whether it is 864,000 or 86,400 seconds. If it is the latter, then your Hub very likely has a fault as every Sonos device is reporting a lease time of 864,000. I recommend switching it to modem mode and purchasing a third-party router, just as I did when I found I had the exact same problem. An alternative would be to get a replacement, more up-to-date, router from Virgin Media.

I’m not sure if this issue is causing your reported problem - not after @Ken_Griffiths has been able to reproduce it - but the some of the error messages seen in the diagnostic do often relate to DNS. The others are Resource Not Found, indicating networking problems. Even if it doesn’t fix this particular problem, the increase in stability will be worth it. The Super Hub 3 does not cope well with more than about 10 devices.

In the meantime, please reboot your router every 12 hours by switching it off for at least 30 seconds each time.

I used to see this issue a lot when I was on the support phone lines, and had this pre-prepared for anyone who suffered from it:

Basically, when a device connects to a router and asks for a unique IP address, the router gives it one, and specifies how long it's valid for. This is called the DHCP lease time. The default setting on Virgin routers is 1 day, or 86,400 seconds. The speakers are reporting that the lease time is 864,000 seconds, or 10 days. This isn't in itself an issue, but the router thinks it's saying 1 day, and it's this discrepancy that causes a problem. After half of the time (12 hours), the router expects the device to get back in touch and confirm it's OK to continue using the IP address. When the device doesn't - because it's waiting another 4.5 days - the router un-assigns the IP address, and the device cannot communicate with the network.

If you do replace your router, I'd recommend you spend at least £50 - £70, and go for a known brand, like Netgear, Asus, TP-Link or D-Link. If your WiFi coverage is a little lacking, then there are mesh options from Tenda, Google, Linksys, and others, though these tend to be around the £200 mark.

When adding a new third-party router, please disconnect anything that's wired into your current router. Log in to the Virgin router setup page (http://192.168.0.1) and switch it into modem mode. The router (or modem, now) will reboot and you'll get a red/orange light at the bottom - that's it ready. Next, connect an ethernet cable going from 1 of the 4 ports on the modem to the individual port on the new router, usually labelled as Internet or WAN. Don't connect to a port labelled LAN on the new router. All of the ethernet cables that used to plug into your Virgin router should be plugged into your new router, using the LAN ports.

Turn on the new router.

Your router manual will come with a card or manual telling you the default IP address it will use. Type this address into your browser and log in using the details on the same card  (you'll need to connect to the new WiFi first). If you want to change the name of your WiFi network, you will be able to do so on the Wireless pages. This won't be strictly necessary, but if you want to avoid reprogramming all of your WiFi devices, you can make the name and password match what they were on the Virgin router exactly.

I hope this helps.

Userlevel 6
Badge +7

Mine is definately set to 86,400 seconds - I remember it was that figure because I worked it out to 24 hours.

If I try and change that value in the router it won’t let me set a value above 604800 so it can’t be set to the higher value you mentioned.

Why are the Sonos speakers getting the wrong value from the router as a matter of interest?

 

 

 

Userlevel 7
Badge +18

Hi @JohnG666 

Why are the Sonos speakers getting the wrong value from the router as a matter of interest?

Because your router is faulty ☹️

 

Userlevel 6
Badge +7

Typically the TP-Link AX1800 I’ve been looking at on Amazon has now gone back up to £87…. it was down to £59 the other week!!

 

Userlevel 7
Badge +18

@JohnG666 

I have a TP-Link Archer C6 AC1200 that I am very happy with - it’s currently £45, not sure what I paid in 2020. I do have a small flat though, and no family-sized amount of WiFi devices.

Reply