Surround and Sub audio disabled each night

  • 8 June 2023
  • 3 replies

Each night (at least that has been the case since I added a new Beam Gen 2 to my systems) my surrounds start flashing green. It’s usually after midnight for some reason.

The flashing keeps me awake so I go into the S2 app and notice the surround audio setting has been disabled. I enable it and the flashing stops. LED changes to the normal white.


The same is happening for another 5.1 system I have upstairs. The sub and surround audio settings are disabled and need to be manually enabled each day.

Any thoughts as to what might be causing the setting to change each night?



Best answer by Corry P 12 June 2023, 14:58

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

3 replies

Probably some wifi interference causing enough disruption to break the connections between the speakers and the Beam. 

Userlevel 7
Badge +18

Hi @DonSmy3005 

Welcome to the Sonos Community!

I haven’t heard of this before. I recommend you get in touch with our technical support team who have tools at their disposal that will allow them to give you advice specific to your Sonos system and what it reports.

I hope this helps.

Well I’ve solved the symptom but not the cause. I have a very complex network at home with a lot of chatter on 2.4 GHz both Wifi and Zigbee. I believe the root cause is a bug in Google Mesh wifi. There appears to be a bug that has yet to be solved that gradually degrades wifi performance over time. Symptoms are very poor speeds, mesh point reporting weak signals when nothing has changed etc. To make things worse, Google doesn’t allow you to control wifi channels manually either.


I’ve fixed my problem by adding a Home Assistance routine that is triggered when my sonos systems disable surround audio. Home assistant just enables it again immediately.


I’ve had no more issues since doing this.