Sonos Beam Can't Adjust Volume With Samsung TV

  • 17 August 2021
  • 3 replies

Hello, I would like to know if this problem has happened to anyone else in this community, i have been trying to connect a sonos beam to a samsung tv using the ARC port on the TV, i can even see the sonos beam being recognised by the tv, only problem is using the samsung remote i am unable to adjust the volume, the tv is using the anynet+ system and anytime i try to put the volume up or down on the bottom of the tv it says “Anynet+ Sonos Beam” followed by five or so dots almost like its loading and after that either a + or - depending on if im trying to turn up or down the volume. But unlike the other samsung TV using a Sonos Beam this one doesn't give a number between 1 and 100 to indicate how loud it is, simply a + or - but either case no sound is playing. I think the problem is coming from the Anynet+ but i am unable to find out in the settings what's wrong. (also posting this thread in the samsung support center)


Best answer by Corry P 20 August 2021, 10:38

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

3 replies

Assuming the remote is infrared-linked to the TV and not Bluetooth, have you setup your remote in the Beam’s room settings in the Sonos App and did it show as having completed successfully?

“Settings/System/[Beam Room Name]/Home Theatre/Remote Control Setup"

Also check that your TV audio out is set to use ‘Dolby Digital’ and not something else like DTS or Dolby Digital Plus.

There’s an extensive FAQ for the Samsung One remotes here, also. 

Userlevel 7
Badge +18

Hi @Gems II 

Welcome to the Sonos Community!

When using HDMI to connect the Beam, you won’t need to program the remote in the Sonos app as the signals are passed through the cable (Anynet+). However, if I read you correctly, the main issue is that you’re not getting any TV audio from the Beam at all, not that you can’t adjust the volume.

As @Ken_Griffiths says, please make sure your TV is outputting Dolby Digital (set Digital Audio Output Format to Auto on the TV). I also recommend you unplug the TV from power for a few minutes, in case that fixes it.

If you still get no audio, please unplug the TV from power again and while it’s off, disconnect other HDMI devices from the TV, then power it back on. If you now get volume, you can reconnect the devices - one at a time and testing in between - until you find the problem device. Disable CEC on this device, if you can.

I hope this helps.